Wpa3 support in OpenWrt?

Which combinations exactly dont work?

I installed snapshot, removed wpad-basic and installed wpad-wolfssl and rebooted, but I still don't see any WPA3 options in LuCI. What else is needed?

Try closing and reopening the LuCI browser tab (or clear the cache).

Hi guys,

Interesting topic.

I only updated wpad to wpad-openssl.

In overview tab, the wireless indicates no encryption,

But in wireless tab it does indicate ,

Is this what should be expected or ?
What about hostap, should that be upgrade to openssl version?

PS: my WPA2 only clients connects ok

There's a lot of little bug fixes required to have LuCI properly handle WPA3. A number of these went into master a few hours ago. You should upgrade the libiwinfo and libiwinfo-lua packages throughout the next days to get proper encryption status reporting.

1 Like

tested wpa3 and the new wifi programming interface seems strange to me!

picture in 3 vertical parts …

Hi everyone, I've just pulled in all the changes in master and recompiled everything, but unfortunately WPA3 options just won't show up in LuCI for me. I've tried it on 2 spare devices so far (ar71xx and ath79). I'm pretty sure this is a dependency issue, does anyone have a clear list of packages that is required for using WPA3 in LuCI that is not included in the default config?

For the record I'm using the full version of wpad instead of wpad-mini, and I had both wpad-openssl and wpad-wolfssl selected as modules.

Note: both of the devices appear to have broken radios as well. They both have 2 radios each, and all of them worked perfectly fine on 18.06.

You need to install either wpad-openssl or wpad-wolfssl (which are distinct packages from wpad, wpad-basic, wpad-mini or wpad-full), as WPA3 requires functionalities of a full ssl/ tls library.

If you upgraded (or switched) from ar71xx to ath79 (or vice versa), you need to recreate your wireless config, as the device path of your devices changes between both implementations:

# rm /etc/config/wireless
# wifi config

Thank you for the clarification. Now rebuilding with this config:

Also I guess I didn't make myself clear about the two devices, I tested them with separate builds, and I'll try factory resetting them first.

No, you don't want wpad at all (even less as CONFIG_PACKAGE_wpad=y), but only wpad-wolfssl (in the form of CONFIG_PACKAGE_wpad-wolfssl=y); respectively the -openssl variant.

1 Like

:man_facepalming: oh... no wonder it didn't work

:confused: No dice. The wpad-wolfssl has a version number of 2018-12-02-c2c6c01b-11, is this too old?

Just to check the obvious, what does opkg list_installed | grep -e wpa -e hostapd say?

Personally I'm using wpad-openssl, as I do need openssl for other packages anyways - I haven't tested wpad-wolfssl so far.

# opkg list_installed | grep -e wpa -e hostapd
hostapd-common - 2018-12-02-c2c6c01b-11
wpad-wolfssl - 2018-12-02-c2c6c01b-11

I'll try the openssl variant now to see if it makes any difference.

How do you get rid of wpad-basic and select just wpad-openssl/wpad-wolfssl?

I'm trying to test WPA3 on mvebu and I can't work out how to do it through make menuconfig. It only gives you the option to build wpad-basic as a module when -openssl is <*>. Is there something obvious I'm missing?

Building wpad-basic just as a module should do the job as well, as that means it merely gets built, not installed into the firmware.

Can you please backport to 19.07 when you have an opportunity?

Broken "luci-theme-material", when use default theme "bootstrap" it's ok.

So is. Not updated (material) to the latest LuCI changes.

It seems I can't work around it by building it as a module (I tried that before posting). I think it might be a forced dependency of mwlwifi or something...

`Package kmod-mwlwifi (4.19.74+2019-03-02-31d93860-2) installed in root is up to date.
Package iwinfo (2019-09-20-02112f9b-1) installed in root is up to date.
Package swconfig (12) installed in root is up to date.
Installing wpad-basic (2018-12-02-c2c6c01b-11) to root...
Downloading file:///home/*snip*/mvebu/staging_dir/packages/mvebu/wpad-basic_2018-12-02-c2c6c01b-11_arm_cortex-a9_vfpv3.ipk
Package mwlwifi-firmware-88w8864 (2019-03-02-31d93860-2) installed in root is up to date.
Collected errors:
 * check_data_file_clashes: Package wpad-basic wants to install file /home/*snip*/mvebu/build_dir/target-arm_cortex-a9+vfpv3_musl_eabi/linux-mvebu_cortexa9/target-dir-42f8af1a/usr/sbin/hostapd
        But that file is already provided by package  * wpad-openssl
 * check_data_file_clashes: Package wpad-basic wants to install file /home/*snip*/mvebu/build_dir/target-arm_cortex-a9+vfpv3_musl_eabi/linux-mvebu_cortexa9/target-dir-42f8af1a/usr/sbin/wpa_supplicant
        But that file is already provided by package  * wpad-openssl
 * check_data_file_clashes: Package wpad-basic wants to install file /home/*snip*/mvebu/build_dir/target-arm_cortex-a9+vfpv3_musl_eabi/linux-mvebu_cortexa9/target-dir-42f8af1a/usr/sbin/wpad
        But that file is already provided by package  * wpad-openssl
 * opkg_install_cmd: Cannot install package wpad-basic.
make[5]: *** [/home/*snip*/mvebu/include/image.mk:349: target-dir-42f8af1a] Error 255
make[5]: Leaving directory '/home/*snip*/mvebu/target/linux/mvebu/image'
make[4]: *** [Makefile:21: install] Error 2
make[4]: Leaving directory '/home/*snip*/mvebu/target/linux/mvebu'
make[3]: *** [Makefile:13: install] Error 2
make[3]: Leaving directory '/home/*snip*/mvebu/target/linux'
time: target/linux/install#128.62#24.61#141.91
make[2]: *** [target/Makefile:25: target/linux/install] Error 2
make[2]: Leaving directory '/home/*snip*/mvebu'
make[1]: *** [target/Makefile:19: /home/*snip*/mvebu/staging_dir/target-arm_cortex-a9+vfpv3_musl_eabi/stamp/.target_install] Error 2
make[1]: Leaving directory '/home/*snip*/mvebu'
make: *** [/home/*snip*/mvebu/include/toplevel.mk:218: world] Error 2`

Anyway, I made a bug report about it (https://bugs.openwrt.org/index.php?do=details&task_id=2513). Hopefully it's an easy fix. Seems like it wouldn't be the intended behavior. I'm surprised this hasn't come up before.

Edit: I tried a build for Archer C7 v2 (ath79) and it doesn't have the same issue. I'll try lantiq and ar71xx once my x86 build is done. I'm betting they'll be fine too.