Wpa3 support in OpenWrt?

Adding some iwinfo strings doesn't really change functionality, and as far as I can see the change still doesn't cover the WPA2/WPA3 mixed mode which will be very common as new devices cohabitate old ones.

Or are there other changes you are referring to?

What is the issue you are facing with WPA3?
I was just getting iwinfo to properly identify WPA3 so that in LuCI you dont see it being configured as WPA2 which is not correct

Using sae-mixed displays as WPA2.
It should display as WPA3/WPA2 Or similar.

I'm not ungrateful for the change you pushed. There's just a bit missing.

Yeah, I did not cover that.
I will take a look at it at the end of month

1 Like

I didn't look into It at all, but if I had to guess they're bit masks, so you're looking for case 6.


I have working WPA3 on Netgear 6220 @ snapshot / wpad-wolfssl:

Yes, iwinfo can identify the WPA2/WPA3 mixed mode easily.
It will be detected as WPA3 PSK, SAE

For "sae-mixed" (WPA2+WPA3), this is not true for IBSS/Ad-hoc connections, which will show "none", and 802.11s mesh connections, which show "unknown". This is current as of yesterdays master snapshot.

Which combinations exactly dont work?

I installed snapshot, removed wpad-basic and installed wpad-wolfssl and rebooted, but I still don't see any WPA3 options in LuCI. What else is needed?

Try closing and reopening the LuCI browser tab (or clear the cache).

Hi guys,

Interesting topic.

I only updated wpad to wpad-openssl.

In overview tab, the wireless indicates no encryption,

But in wireless tab it does indicate ,

Is this what should be expected or ?
What about hostap, should that be upgrade to openssl version?

PS: my WPA2 only clients connects ok

There's a lot of little bug fixes required to have LuCI properly handle WPA3. A number of these went into master a few hours ago. You should upgrade the libiwinfo and libiwinfo-lua packages throughout the next days to get proper encryption status reporting.

1 Like

tested wpa3 and the new wifi programming interface seems strange to me!

picture in 3 vertical parts …

Hi everyone, I've just pulled in all the changes in master and recompiled everything, but unfortunately WPA3 options just won't show up in LuCI for me. I've tried it on 2 spare devices so far (ar71xx and ath79). I'm pretty sure this is a dependency issue, does anyone have a clear list of packages that is required for using WPA3 in LuCI that is not included in the default config?

For the record I'm using the full version of wpad instead of wpad-mini, and I had both wpad-openssl and wpad-wolfssl selected as modules.

Note: both of the devices appear to have broken radios as well. They both have 2 radios each, and all of them worked perfectly fine on 18.06.

You need to install either wpad-openssl or wpad-wolfssl (which are distinct packages from wpad, wpad-basic, wpad-mini or wpad-full), as WPA3 requires functionalities of a full ssl/ tls library.

If you upgraded (or switched) from ar71xx to ath79 (or vice versa), you need to recreate your wireless config, as the device path of your devices changes between both implementations:

# rm /etc/config/wireless
# wifi config

Thank you for the clarification. Now rebuilding with this config:

Also I guess I didn't make myself clear about the two devices, I tested them with separate builds, and I'll try factory resetting them first.

No, you don't want wpad at all (even less as CONFIG_PACKAGE_wpad=y), but only wpad-wolfssl (in the form of CONFIG_PACKAGE_wpad-wolfssl=y); respectively the -openssl variant.

1 Like

:man_facepalming: oh... no wonder it didn't work

:confused: No dice. The wpad-wolfssl has a version number of 2018-12-02-c2c6c01b-11, is this too old?