WPA3 Setup - mwlwifi

Hey Guys/Girls,

I updated my Linksys WRT3200acm to 19.07. So the first thing that I wanted to play was WPA3.
I installed hostapd-openssl.
Now WPA3 shows up in config after rebooting:

So what I tried was using WPA2/WPA3 SAE mixed mode.
But when I change to this setting, none my devices are able to connect.
Not my Macbook, iPhone, Samsung Tablet, Samsung Phone or HP Probook.
I read in the forum that there are some issues with iOS/Mac OS Devices.
But also I read that people got it to work when adding:
option auth_cache '1'
Am I right that this needs to be added in: /etc/config/wireless ?

This did not change anything for me by the way.

And what is about the 802.11w feature ? Is it required to get WPA3 working ?
It seems like If I enable this, even though not enabling WPA3, it will break my WIFI.

Can someone please help me?

Thank you,

I fear with mwlwifi you'll be out of luck, 802.11w and WPA3 being broken is a known bug - and very unlikely to get fixed, 'thanks' to Marvell selling their wireless department to NXP.

(WPA3 and Apple devices isn't exactly easy either, but here the elephant in the room is mwlwifi)


I tried it on the same device, but with 19.07 rc2. Some devices are connected and some are not. But it doesn't depend on the wifi chip in my opinion. Not all devices are able to connect to a mixed wpa2/wpa3 network, as also reported in the release notes of 19.07 stable. In addition, if you search the internet you will find several articles that do not recommend a mixed network, because the devices on wpa3 are only at risk. In fact, on mixed there are techniques to climb everything to wpa2 and break the network. The advice is to dedicate one frequency to wpa3 (5GHz?) And another to wpa2.

Thank you for your reply. Saw you were pretty active in other WPA3 related threads, right ?
To be honest, I'm really pissed of about Linksys. I should probably sell that device and never buy one from Linksys again. I didn't to any research on it because I had good experiences so far. Can you recommend an powerful device ?

For hardware recommendations please open a new topic in the Hardware Questions and Recommendations
category of this forum.

Please state your usecase, your requirements and price limit when asking which device to buy.

1 Like

At home I'm using an Archer C2600 (mixed mode WPA2/WPA3 SAE in 2.4 Ghz. /5 Ghz.), I have various WiFI devices (2 Android Tablets, 3 Android Phones, 1 Nintendo Switch, 1 Samsung Smart TV, PS4 in 2.4 Ghz., HP Laptop, Lenovo Desktop....) and I have no problems.

The only problem I have, is known bug in PS4 Pro and 5 Ghz. band using CT driver, but is a driver bug, nothing to do with WPA2/WPA3 encryption.

Interesting. Do some of these devices use wpa3 to connect ? I guess android phones do?

Linksys just packaged up the Marvell chip. Now that NXP owns Marvell there isn't much they could do. If Nvidia stops updating drivers for an old GPU you have to go after Nvidia, not Alienware or Dell that packaged up the parts. Maybe you can get NXP to release the source?

Next time go for the most open drivers you can and this can't happen.

The 7800 seems to be a popular replacement for the 3200.

1 Like

Just don't use WPA3. I don't think anything requires it.

My laptop running Ubuntu 19.10 is the only device supporting WPA3, the rest of them only WPA2.

while I agree with low number of devices supporting wpa3 , it is only software related and can be added in phone and tablets later by manufacturers.
also I, a normal user, see faster initial connection setup times with wpa3 access point vs wpa2 on the same router and same interface. though this may be linux related and better wpa3 connection setup than wpa2

This is what I noticed on my MacBook Pro:
if you select WPA3 only and previously your Mac was associated with WPA2, it won't work unless you re-input the password (and if you switch back to WPA2 you have to delete the network config again).
In my experience, WPA3/2 mixed mode would only work if there weren't any other access point broadcasting the same SSID with WPA2 only.
I put 802.11w as required for 5ghz, optional for 2.4 ghz (my printer wouldn't connect otherwise).

(Just to clarify: my experience is limited with MT7620/MT7621 devices)

I've tested using OpenWRT Snapshot build on Feb 27, 2021 on Linksys wrt1200ac (hardware revision is v2). The Wi-Fi will turn on as WPA3 only mode and my device can connect to this Linksys router.

See my post #13