WPA3 disappeared

I've been setting up a new asus ax6000 router, and I set my security to WPA3.

Over the course of setting up various others areas of the system, I finished up and connected a device to wifi. It no longer worked, and I had to re-save the security to WPA2.

The WPA3 option is now gone - Does anyone know what setting may have cause this to go?

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
{
	"kernel": "5.15.162",
	"hostname": "asus",
	"system": "ARMv8 Processor rev 4",
	"model": "ASUS TUF-AX6000",
	"board_name": "asus,tuf-ax6000",
	"rootfs_type": "squashfs",
	"release": {
		"distribution": "OpenWrt",
		"version": "23.05.4",
		"revision": "r24012-d8dd03c46f",
		"target": "mediatek/filogic",
		"description": "OpenWrt 23.05.4 r24012-d8dd03c46f"
	}
}

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdac:e9f6:79bc::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'
	list ports 'eth1'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	list ports 'lan5'

config device
	option name 'lan1'
	option macaddr 'mac'

config device
	option name 'lan2'
	option macaddr 'mac'

config device
	option name 'lan3'
	option macaddr 'mac'

config device
	option name 'lan4'
	option macaddr 'mac'

config device
	option name 'lan5'
	option macaddr 'mac'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ip6assign '60'
	option gateway '192.168.212.1'
	list dns '192.168.212.1'
	list dns_search 'mydomain'
	list ipaddr '192.168.212.4/24'

config device
	option name 'eth1'
	option macaddr 'MAC'

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/18000000.wifi'
	option channel '6'
	option band '2g'
	option htmode 'HE40'
	option cell_density '0'
	option country 'GB'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'SSSID'
	option encryption 'psk2'
	option key 'PPPASS'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/18000000.wifi+1'
	option channel '36'
	option band '5g'
	option htmode 'HE160'
	option cell_density '0'
	option country 'GB'
	option he_su_beamformee '1'
	option he_bss_color '8'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'SSID'
	option encryption 'psk2'
	option key 'PAASSSSSSSS'
	
config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

config defaults
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'


Edit encryption to become 'sae' instead. All possible hostapd versions support it.

GB+HE160 mandates auto-channel.

I changes to AES encryption, removed country code, set the channel to auto - For both bands.

Rebooted - Still not option for WPA3

I am going to reset everything. I am also getting some lagging every few minutes behaviour

Flash sysupgrade to same version clearing configuration. Is it meant to be a wired extender? And you have a DHCP server on other router?

You have to set country code AND auto channel since any 160MHz combination needs DFS.

First connect wifi to LAN and check if radio works properly.

It's an access point only, yeah.

I reset; but I'll flash and reset, now. I was also getting some signature errors on packages

Please sysupgrade to unmodified image from firmware-selector.openwrt.org
There should be no install or checksum or any other errors.

It's there after a reset and unmodified image.

I did wonder if it was something to do with 'bridger' package. I am supposed to install that but it stops wifi working

In fact scrap that. It seems to basically break everything

You can set qwerty cryptions if you want. I told you SAE in smalls.

That wasn't an option ?

Seems it was down to band steering; and these two options

option bss_transition '1'
option ieee80211k '1'

https://openwrt.org/docs/guide-user/network/wifi/dawn

How come, they are not in your initial setup AT ALL.
Please set up clean device with as little as possible wifi options changed.