WPA2 Enterprise setup problem

Hello! New OpenWrt user here. Bought a TP-Link Archer C7 and installed OpenWrt with the purpose to setup a test WPA2-Enterprise network.

I followed the guide at https://openwrt.org/docs/guide-user/network/wifi/freeradius and completed the config. I also installed wpad, because I couldn't see a WPA2-Enterprise option through the GUI.

So, I'm starting radiusd (auth & accounting server are listening on all interfaces) and tried to setup a WPA2-Enterprise through the GUI but it keeps staying as 'wifi not associated'.

Interface configuration:
Encryption: WPA2-EAP
Cipher: auto
Radius-Authentication-Port: 1812
Radius-Authentication-Secret: testing123
Radius-Accounting-Port: 1813
Radius-Accounting-Secret: testing123

I have no clue what might be the problem with my config and how to troubleshoot this.

Any help is appreciated.

I have this running on the C7 v2 as well.
Please post your complete wireless config.

Also a list of packages would be helpful - not seeing WPA2 Enterprise likely indicates you do not have the full wpad / hostapd installed.

Hey, thanks for the answer. For some reason it now works without having changed anything. My router probably just needed a reboot, which tbh I should have tried earlier. :sweat_smile:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.