Wpa_supplicant, wpad Package Size // MSCHAPV2

Hello guys,

I can't install WPA2-Enterprise support on my Router (TL-WR841N) since there are only 80 Kb left.
Can anyone help me out?

grafik

Is it possible to install it into the /tmp folder?

Cheers!

You'll either need to use external, non-volatile storage, such as a USB stick and "extroot" or build your own image, removing packages that you don't need. (/tmp/ is in-memory and disappears when the router is rebooted.)

You're a lot more than 80 kB short, as you need multiple free "erase blocks" for the overlay filesystem to keep working.

1 Like

Hmm well I don't have an USB port & tried option Nr 2 as well, so I had to factory reset the device :smiley:

I tried to deinstall the wpad-mini package & then installing wpad.
grafik

This is what I got... I can't find the most recent wpad.ipk so I can't install it. Otherwise it could maybe work.

"Deinstall" of a built-in package doesn't recover any space, as it still exists in the ROM and is just "hidden" by the writable JFFS2 overlay file system. The only way to recover that space is to build a custom ROM.

2 Likes

Okay so I wanted to build my own makeconfig but my router ("Target Profile") is not it the list. Only the router 842 with the 8 Mb flash :frowning:

which version is your router
https://openwrt.org/toh/start?dataflt[Model*~]=WR841N

check the device tech data for your device and from that you can choose the correct profile

for example v13 would be
Screenshot_2018-08-21_17-44-03

1 Like

Wow thank you for the quick reply.

I have version 8, but it is not avaiable in my list.
grafik

Since Im a Linux noob I was just following this:
https://openwrt.org/docs/guide-developer/quickstart-build-images

Can you maybe compile it for me?

You are almost there
Screenshot_2018-08-21_18-38-21

If you pay attention to the path and name to the release image you will notice

http ://downloads.openwrt.org/releases/18.06.1/targets/ar71xx/tiny/openwrt-18.06.1-ar71xx-tiny-tl-wr841-v8-squashfs-factory.bin

Target is ar71xx => ATHEROS AR7XXX/AR9XXX
Subtarget is tiny=> Device with small flash

NOTE:

If you follow the guide, I think you will end up with checkout of MASTER, use GIT to checkout the release branch source code to avoid unexpected problems from source that is still under test/development

1 Like