Wpa_supplicant scan time too long

wpa_supplicant scan time too long

I am using wpa_supplicant to do roamming between 2 APs, the driver is ath10k.

I saw wpa_supplicant to use active scan by default(if not set passive scan in conf), however, from the log, the scan time per channel is around 140ms, obviously, this is passive scan since AP beacon sends every 100ms. How to disable this passive scan? I just want to use active scan, I prefer to scan each channel less than 50ms. In fact, I saw mac80211/scan.c, the channel time is just 30ms. But don’t know why it still stay on that channel around 100ms