Wpa_supplicant problem in 19.07.5 - only one radio works

Hi,

perhaps it's an easy issue, but I can't find it

device is an Lenovo Newifi Mini Y1

OpenWRT 19.07.5 is installed and running

there are 2 radios in the device
radio0 = 5 GHz
radio1 = 2.4 GHz

on both radios I have configured an 802.11s mesh with encryption, and both meshed do work (batctl shows the neighbours and the other mesh points do see this device as well)

so in principle wpa_supplicant is working.

wpad-mesh-openssl is installed

APs without encryption do work on both radios, the the wifi-device settings seem to be OK

Now for the error:

when I set up APs with encryption on the radios, this only works on the 5 GHz radio, using
option encryption 'sae-mixed'

but it does not work on 2.4 GHz (radio1)

I started with an encrypted AP and added one option after the other. Everything worked until I added
option encryption
option key
As soon as I try that, the interface does not come up anymore.

neither 'sae-mixed' nor 'psk2' work.

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '9'
        option hwmode '11g'
        option path 'platform/10180000.wmac'
        option htmode 'HT40'
        option country 'DE'
        option diversity '1'
        option disabled '0'

this works fine

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt-test'
        option encryption 'none'
        option ieee80211w '1'
        option ieee80211r '1'
        option mobility_domain '6f68'
        option disabled '0'

and this works fine as well, but this is on radio0 = 5 GHz

config wifi-iface 'prod_radio0'
        option device 'radio0'
        option mode 'ap'
        option ssid 'Test'
        option key '1111111111111111'
        option network 'lan'
        option ieee80211w '1'
        option encryption 'sae-mixed'
        option ieee80211r '1'
        option mobility_domain '6f68'
        option disabled '0'

and this does NOT work (radio1 = 2.4 GHz)

config wifi-iface 'prod_radio1'
        option device 'radio1'
        option mode 'ap'
        option ssid 'Tst'
        option key '1111111111111111'
        option network 'lan'
        option ieee80211w '1'
        option encryption 'sae-mixed'
#       option encryption 'psk2+tkip+aes'
        option ieee80211r '1'
        option mobility_domain '6f68'
        option disabled '0'

the config for prod_radio1 has been copy&paste form prod_radio0 in nano and just changing the 0's to 1's ...

I have totally run out of ideas :frowning:

log with error

Wed Dec 23 21:08:19 2020 user.notice mac80211: Failed command: iw phy phy1 set antenna 0xffffffff 0xffffffff
Wed Dec 23 21:08:19 2020 daemon.notice netifd: radio1 (14809): command failed: Not supported (-122)
Wed Dec 23 21:08:19 2020 user.notice mac80211: Failed command: iw phy phy1 set distance 0
Wed Dec 23 21:08:19 2020 daemon.err hostapd: Configuration file: /var/run/hostapd-phy1.conf
Wed Dec 23 21:08:19 2020 daemon.notice hostapd: nl80211: deinit ifname=wlan1-1 disabled_11b_rates=0
Wed Dec 23 21:08:19 2020 daemon.err hostapd: nl80211 driver initialization failed.
Wed Dec 23 21:08:19 2020 daemon.notice hostapd: wlan1-1: interface state UNINITIALIZED->DISABLED
Wed Dec 23 21:08:19 2020 daemon.notice hostapd: wlan1-1: AP-DISABLED
Wed Dec 23 21:08:19 2020 daemon.notice hostapd: wlan1-1: CTRL-EVENT-TERMINATING
Wed Dec 23 21:08:19 2020 daemon.err hostapd: hostapd_free_hapd_data: Interface wlan1-1 wasn't started
Wed Dec 23 21:08:19 2020 daemon.notice netifd: radio1 (14809): WARNING (wireless_add_process): executable path /usr/sbin/wpad does not match process 9513 path ()
Wed Dec 23 21:08:19 2020 daemon.notice netifd: radio1 (14809): Device setup failed: HOSTAPD_START_FAILED
Wed Dec 23 21:08:30 2020 user.notice mac80211: Failed command: iw phy phy1 set antenna 0xffffffff 0xffffffff
Wed Dec 23 21:08:30 2020 daemon.notice netifd: radio1 (14934): command failed: Not supported (-122)
Wed Dec 23 21:08:30 2020 user.notice mac80211: Failed command: iw phy phy1 set distance 0
Wed Dec 23 21:08:30 2020 daemon.err hostapd: Configuration file: /var/run/hostapd-phy1.conf
Wed Dec 23 21:08:30 2020 daemon.notice hostapd: nl80211: deinit ifname=wlan1-1 disabled_11b_rates=0
Wed Dec 23 21:08:30 2020 daemon.err hostapd: nl80211 driver initialization failed.
Wed Dec 23 21:08:30 2020 daemon.notice hostapd: wlan1-1: interface state UNINITIALIZED->DISABLED
Wed Dec 23 21:08:30 2020 daemon.notice hostapd: wlan1-1: AP-DISABLED
Wed Dec 23 21:08:30 2020 daemon.notice hostapd: wlan1-1: CTRL-EVENT-TERMINATING
Wed Dec 23 21:08:30 2020 daemon.err hostapd: hostapd_free_hapd_data: Interface wlan1-1 wasn't started
Wed Dec 23 21:08:30 2020 daemon.notice netifd: radio1 (14934): WARNING (wireless_add_process): executable path /usr/sbin/wpad does not match process 9513 path ()
Wed Dec 23 21:08:30 2020 daemon.notice netifd: radio1 (14934): Device setup failed: HOSTAPD_START_FAILED

log without AP

Wed Dec 23 21:11:48 2020 user.notice mac80211: Failed command: iw phy phy1 set antenna 0xffffffff 0xffffffff
Wed Dec 23 21:11:48 2020 daemon.notice netifd: radio1 (15336): command failed: Not supported (-122)
Wed Dec 23 21:11:48 2020 user.notice mac80211: Failed command: iw phy phy1 set distance 0
Wed Dec 23 21:11:50 2020 kern.info kernel: [ 3773.950012] ieee80211 phy1: rt2800_rf_self_txdc_cal: Info - RF Tx self calibration start
Wed Dec 23 21:11:50 2020 kern.info kernel: [ 3773.958737] ieee80211 phy1: rt2800_rf_self_txdc_cal: Info - RF Tx self calibration end
Wed Dec 23 21:11:51 2020 kern.info kernel: [ 3775.813872] ieee80211 phy1: rt2800_loft_iq_calibration: Info - LOFT Calibration Done!
Wed Dec 23 21:11:51 2020 kern.info kernel: [ 3775.825751] ieee80211 phy1: rt2800_iq_search: Info - IQCalibration Start!
Wed Dec 23 21:11:51 2020 kern.info kernel: [ 3775.847113] ieee80211 phy1: rt2800_iq_search: Info - IQCalibration Done! CH = 0, (gain= f, phase=3f)
Wed Dec 23 21:11:51 2020 kern.info kernel: [ 3775.857360] ieee80211 phy1: rt2800_iq_search: Info - IQCalibration Start!
Wed Dec 23 21:11:51 2020 kern.info kernel: [ 3775.878686] ieee80211 phy1: rt2800_iq_search: Info - IQCalibration Done! CH = 1, (gain= d, phase=3e)
Wed Dec 23 21:11:51 2020 kern.info kernel: [ 3775.888048] ieee80211 phy1: rt2800_loft_iq_calibration: Info - TX IQ Calibration Done!
Wed Dec 23 21:11:51 2020 kern.info kernel: [ 3775.913939] ieee80211 phy1: rt2800_rxiq_calibration: Info - RXIQ G_imb=0, Ph_rx=0
Wed Dec 23 21:11:51 2020 kern.info kernel: [ 3775.931909] ieee80211 phy1: rt2800_rxiq_calibration: Info - RXIQ G_imb=0, Ph_rx=-2
Wed Dec 23 21:11:51 2020 kern.info kernel: [ 3775.951621] IPv6: ADDRCONF(NETDEV_UP): mesh1: link is not ready
Wed Dec 23 21:11:51 2020 daemon.notice wpa_supplicant[15424]: Successfully initialized wpa_supplicant
Wed Dec 23 21:11:51 2020 daemon.notice netifd: radio1 (15336): command failed: Link has been severed (-67)
Wed Dec 23 21:11:51 2020 user.notice mac80211: Failed command: iw dev mesh1 set mesh_param mesh_rssi_threshold 0
Wed Dec 23 21:11:51 2020 daemon.notice netifd: radio1 (15336): command failed: Link has been severed (-67)
Wed Dec 23 21:11:51 2020 user.notice mac80211: Failed command: iw dev mesh1 set mesh_param mesh_fwding 0
Wed Dec 23 21:11:51 2020 daemon.notice netifd: Interface 'nwi_mesh1' is enabled
Wed Dec 23 21:11:52 2020 daemon.err wpa_supplicant[15425]: Using interface mesh1 with hwaddr 22:76:93:2b:8e:6b and ssid ""
Wed Dec 23 21:11:52 2020 daemon.notice wpa_supplicant[15425]: mesh1: interface state UNINITIALIZED->ENABLED
Wed Dec 23 21:11:52 2020 daemon.notice wpa_supplicant[15425]: mesh1: AP-ENABLED
Wed Dec 23 21:11:52 2020 daemon.notice wpa_supplicant[15425]: mesh1: joining mesh mesh-2.4ghz
Wed Dec 23 21:11:52 2020 daemon.notice netifd: Network device 'mesh1' link is up
Wed Dec 23 21:11:52 2020 daemon.notice netifd: Interface 'nwi_mesh1' has link connectivity
Wed Dec 23 21:11:52 2020 daemon.notice netifd: Interface 'nwi_mesh1' is setting up now
Wed Dec 23 21:11:52 2020 kern.info kernel: [ 3776.698559] IPv6: ADDRCONF(NETDEV_CHANGE): mesh1: link becomes ready
Wed Dec 23 21:11:52 2020 daemon.notice wpa_supplicant[15425]: mesh1: CTRL-EVENT-CONNECTED - Connection to 00:00:00:00:00:00 completed [id=0 id_str=]
Wed Dec 23 21:11:52 2020 daemon.notice wpa_supplicant[15425]: mesh1: MESH-GROUP-STARTED ssid="mesh-2.4ghz" id=0
Wed Dec 23 21:11:52 2020 daemon.notice wpa_supplicant[15425]: mesh1: new peer notification for 8c:3b:ad:ef:ef:0b
Wed Dec 23 21:11:52 2020 kern.info kernel: [ 3776.845096] batman_adv: bat0: Adding interface: mesh1
Wed Dec 23 21:11:52 2020 kern.info kernel: [ 3776.850365] batman_adv: bat0: Interface activated: mesh1
Wed Dec 23 21:11:53 2020 daemon.notice netifd: Interface 'nwi_mesh1' is now up
Wed Dec 23 21:11:53 2020 daemon.notice wpa_supplicant[15425]: mesh1: new peer notification for 50:d4:f7:14:db:82

any help is welcome ...