Wpa_supplicant: BEACON-LOSS

I'm seeing many of this wpa_supplicant []: wlan: CTRL-EVENT-BEACON-LOSS in my log. How can I hide them? Couldn't find log level for wpa_supplicant.

This message is coming from the wlan interface that is connected to another OpenWrt wlan device in station mode (repeating). No problem whatsoever with the connection, only those logs.

Web suggests this as a power saving issue but power save is disabled in both APs.

Does the forum search yield anything useful for you?


No... apart from checking whether power save is disabled (which was). No solutions.

I have another device which is on older version (18.06.8) (repeating to main) and interestingly I don't have this issue on it. Archer C7, my main AP (gets repeated conn1, plus serves its own conn2), is on snapshot.

Even the log level in the system settings cant hide this logs. Its spamming my entire log file! How so we can change log level of hostapd but not wpa supplicant?

edit: or anyway to filter out these logs on the log page? Found that fancy log packages can filter out but my few scripts rely on normal syslog to read logs.

I was reading some pdfs and found out this. Looks like my situation (repeaters). Turns out it was suggesting to increase basic rates thus increased beacon rate. Funny thing is, I already had those options in my main AP set, but forgot or didn't think for repeater. I'm testing now...

Hi! What do you mean under "to increase basic rates"? Is there any progress in testing? I'm facing the same problem

Nope, no progress unless you set your AP's beacon interval to 2999ms (higher than 100 basically), which decreases the amount of lost beacons. A silly workaround I know but better than nothing, and plus I'm not using that AP for home, but a second failover wireless WAN. So no disadvantages for me there.

Increasing basic rates basically help you for sticky clients, for example, your one client sticks on 5GHz even at far and wont go to 2GHz, increasing basic rate for 5GHz forces the AP to not accept devices at far, reducing the area.

I did that for a hope to fix this issue too, thinking from the above presentation it would help beacon rate, but it didn't. I guess that's a natural problem for repeaters, funny I don't get that warning on 18.06.x or maybe it just not showing on earlier versions of wpa_supplicant.

Only thing I found on the web was to disable power save of wireless, which it is by default.

1 Like

Thanks for your answer. Will try to increase beacon interval.
I have repeater configuration with two WR-841N, one as Main, second as Client.
Funny things is that I had made a settings reset on the Client router and then rolled out a configuration from backup and now it's works perfectly - no any device disconnecting or internet disappearing. What a f*ck? I have no idea what is going on, because I still see CTRL-EVENT-BEACON-LOSS events on system logs.

Yes those BEACON_LOSS warnings are harmless for the connection, it seems to be running just fine for me.