Wpa-enterprise, connection on client, not on access point

Hi all

I'm super new to OpenWrt, I'm trying to set up an access point for my chromecast and google home because I have a wpa-enterprise encrypted wifi (eduroam to be more specific).

I installed wpad and wpa-cli, I tried to add custom DNS-servers because I thought that was the issue.

I can connect to the access point but in the browser the site keeps loading and eventually times out, basically no reponse and if I try pinging google.com I get no response. On the router itself I do get a respond from pinging.

Below is my config,
Thanks in advance

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdd1:633f:947f::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option dns '8.8.8.8 4.4.4.4'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
        option peerdns '0'
        option dns '8.8.8.8 4.4.4.4'

config device 'wan_dev'
        option name 'eth0.2'
        option macaddr '94:83:c4:01:86:d2'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0 6t'

config interface 'wwan'
        option proto 'dhcp'
        option peerdns '0'
        option dns '8.8.8.8 4.4.4.4'

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'
        option ra_management '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan wan6 wwan'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'```

Remove the DNS entries from the LAN interface.
If you connect with cable on the router, does it work fine?
Post also the wireless configuration and some more troubleshooting:

uci export wireless; ip -4 addr; ip -4 ru; ip -4 ro ls tab all; \
ping -c 4 8.8.8.8; ping -c 4 www.google.com; \
ls -l  /etc/resolv.* /tmp/resolv.*; head -n -0 /etc/resolv.* /tmp/resolv.*

You may want to cover the username and password of the wwan.

This is more of a good practice, as you should assign nameservers that are reachable over the specific interface and Google NS are not reachable from the LAN.

I meant from a wired LAN port.

Anyway, ping and DNS work fine from what I see, and I cannot spot any problem in your configuration.
Do the wireless clients get correct settings from the OpenWrt? Like IP/mask/gateway/dns?
Can you open the web interface of the OpenWrt from any client?

1 Like

Thanks for pointing this out, I didn't notice it.

Same thing as the wireless clients, I'm able to connect but I have no internet connection.
I am however able to open the openWrt web interface.

I attached the ipconfig of one of the clients, I do see that the client (the ethernet connection in this case) has a different default gateway, dhcp server and ip adress than the wireless connection (the eduroam wifi network).
I tried changing the settings for the lan interface of the router, but the values did not change, am I doing something wrong?

Ethernet adapter Ethernet 2:

   Connection-specific DNS Suffix  . : lan
   Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller #2
   Physical Address. . . . . . . . . : 3C-52-82-38-01-39
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : fdd1:633f:947f::2b1(Preferred)
   Lease Obtained. . . . . . . . . . : woensdag 4 maart 2020 22:41:14
   Lease Expires . . . . . . . . . . : zondag 11 april 2156 5:11:54
   IPv6 Address. . . . . . . . . . . : fdd1:633f:947f::9e6(Preferred)
   Lease Obtained. . . . . . . . . . : woensdag 4 maart 2020 19:15:17
   Lease Expires . . . . . . . . . . : zondag 11 april 2156 5:11:54
   IPv6 Address. . . . . . . . . . . : fdd1:633f:947f:0:f4a9:6c6e:e353:1498(Preferred)
   Temporary IPv6 Address. . . . . . : fdd1:633f:947f:0:35f3:8b7d:e023:f8a8(Preferred)
   Link-local IPv6 Address . . . . . : fe80::f4a9:6c6e:e353:1498%12(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.114(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : woensdag 4 maart 2020 19:15:22
   Lease Expires . . . . . . . . . . : donderdag 5 maart 2020 10:41:19
   Default Gateway . . . . . . . . . : 192.168.1.1
   DHCP Server . . . . . . . . . . . : 192.168.1.1
   DHCPv6 IAID . . . . . . . . . . . : 104616578
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-22-69-13-0D-3C-52-82-38-01-39
   DNS Servers . . . . . . . . . . . : fdd1:633f:947f::1
                                       192.168.1.1
                                       fdd1:633f:947f::1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Wireless LAN adapter Wi-Fi:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) Dual Band Wireless-AC 7265
   Physical Address. . . . . . . . . : 88-78-73-5C-31-E0
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::8cb9:9d16:575:dfd5%18(Preferred)
   IPv4 Address. . . . . . . . . . . : 10.1.167.132(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : woensdag 4 maart 2020 22:35:32
   Lease Expires . . . . . . . . . . : woensdag 4 maart 2020 23:36:19
   Default Gateway . . . . . . . . . : 10.1.167.1
   DHCP Server . . . . . . . . . . . : 10.1.167.1
   DHCPv6 IAID . . . . . . . . . . . : 92829811
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-22-69-13-0D-3C-52-82-38-01-39
   DNS Servers . . . . . . . . . . . : 10.1.167.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

That is correct.

No need, the defaults work fine.

Can you run a iw list ?

Connect the wifi client to wan. Remove the ethernet port from wan so your connection is wireless. Firewall rules are already in place for wan. It isn't necessary to make a new 'wwan'-- if you do that the firewall needs to be set up for it.

wwan is already in the wan zone.

Wiphy phy0
        max # scan SSIDs: 4
        max scan IEs length: 2257 bytes
        max # sched scan SSIDs: 0
        max # match sets: 0
        max # scan plans: 1
        max scan plan interval: -1
        max scan plan iterations: 0
        Retry short limit: 7
        Retry long limit: 4
        Coverage class: 0 (up to 0m)
        Available Antennas: TX 0x3 RX 0x3
        Supported interface modes:
                 * IBSS
                 * managed
                 * AP
                 * AP/VLAN
                 * monitor
                 * mesh point
        Band 1:
                Capabilities: 0x1fe
                        HT20/HT40
                        SM Power Save disabled
                        RX Greenfield
                        RX HT20 SGI
                        RX HT40 SGI
                        TX STBC
                        RX STBC 1-stream
                        Max AMSDU length: 3839 bytes
                        No DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: 4 usec (0x05)
                HT TX/RX MCS rate indexes supported: 0-15
                Frequencies:
                        * 2412 MHz [1] (20.0 dBm)
                        * 2417 MHz [2] (20.0 dBm)
                        * 2422 MHz [3] (20.0 dBm)
                        * 2427 MHz [4] (20.0 dBm)
                        * 2432 MHz [5] (20.0 dBm)
                        * 2437 MHz [6] (20.0 dBm)
                        * 2442 MHz [7] (20.0 dBm)
                        * 2447 MHz [8] (20.0 dBm)
                        * 2452 MHz [9] (20.0 dBm)
                        * 2457 MHz [10] (20.0 dBm)
                        * 2462 MHz [11] (20.0 dBm)
                        * 2467 MHz [12] (20.0 dBm)
                        * 2472 MHz [13] (20.0 dBm)
                        * 2484 MHz [14] (disabled)
        valid interface combinations:
                 * #{ IBSS } <= 1, #{ managed, AP, mesh point } <= 4,
                   total <= 4, #channels <= 1, STA/AP BI must match
        HT Capability overrides:
                 * MCS: ff ff ff ff ff ff ff ff ff ff
                 * maximum A-MSDU length
                 * supported channel width
                 * short GI for 40 MHz
                 * max A-MPDU length exponent
                 * min MPDU start spacing

I'm really stuck at what the issue could be, thanks for the help

I added system and kernel logs, maybe they are usefull

Thu Mar  5 17:12:47 2020 kern.notice kernel: [    0.000000] Linux version 4.14.95 (buildbot@2b39dc2beaf4) (gcc version 7.3.0 (OpenWrt GCC 7.3.0 r7676-cddd7b4c77)) #0 Wed Jan 30 12:21:02 2019
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.000000] Board has DDR2
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.000000] Analog PMU set to hw control
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.000000] Digital PMU set to hw control
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.000000] SoC Type: MediaTek MT7628AN ver:1 eco:2
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.000000] bootconsole [early0] enabled
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.000000] CPU0 revision is: 00019655 (MIPS 24KEc)
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.000000] MIPS: machine is GL-MT300N-V2
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.000000] Determined physical RAM map:
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.000000]  memory: 08000000 @ 00000000 (usable)
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.000000] Initrd not found or empty - disabling initrd
Thu Mar  5 17:12:47 2020 kern.warn kernel: [    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
Thu Mar  5 17:12:47 2020 kern.warn kernel: [    0.000000] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.000000] Zone ranges:
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.000000]   Normal   [mem 0x0000000000000000-0x0000000007ffffff]
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.000000] Movable zone start for each node
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.000000] Early memory node ranges
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.000000]   node   0: [mem 0x0000000000000000-0x0000000007ffffff]
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000007ffffff]
Thu Mar  5 17:12:47 2020 kern.debug kernel: [    0.000000] On node 0 totalpages: 32768
Thu Mar  5 17:12:47 2020 kern.debug kernel: [    0.000000] free_area_init_node: node 0, pgdat 80422fc0, node_mem_map 81000040
Thu Mar  5 17:12:47 2020 kern.debug kernel: [    0.000000]   Normal zone: 256 pages used for memmap
Thu Mar  5 17:12:47 2020 kern.debug kernel: [    0.000000]   Normal zone: 0 pages reserved
Thu Mar  5 17:12:47 2020 kern.debug kernel: [    0.000000]   Normal zone: 32768 pages, LIFO batch:7
Thu Mar  5 17:12:47 2020 kern.notice kernel: [    0.000000] random: get_random_bytes called from 0x8042672c with crng_init=0
Thu Mar  5 17:12:47 2020 kern.debug kernel: [    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
Thu Mar  5 17:12:47 2020 kern.debug kernel: [    0.000000] pcpu-alloc: [0] 0
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 32512
Thu Mar  5 17:12:47 2020 kern.notice kernel: [    0.000000] Kernel command line: console=ttyS0,115200 rootfstype=squashfs,jffs2
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.000000] PID hash table entries: 512 (order: -1, 2048 bytes)
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.000000] Writing ErrCtl register=0007e000
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.000000] Readback ErrCtl register=0007e000
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.000000] Memory: 125224K/131072K available (3592K kernel code, 183K rwdata, 464K rodata, 168K init, 206K bss, 5848K reserved, 0K cma-reserved)
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.000000] NR_IRQS: 256
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.000000] intc: using register map from devicetree
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.000000] CPU Clock: 575MHz
Thu Mar  5 17:12:47 2020 kern.crit kernel: [    0.000000] timer_probe: no matching timers found
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 6647862422 ns
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.000012] sched_clock: 32 bits at 287MHz, resolution 3ns, wraps every 7469508094ns
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.007549] Calibrating delay loop... 380.92 BogoMIPS (lpj=1904640)
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.073456] pid_max: default: 32768 minimum: 301
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.078167] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.084520] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.097215] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.106708] futex hash table entries: 256 (order: -1, 3072 bytes)
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.112662] pinctrl core: initialized pinctrl subsystem
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.119037] NET: Registered protocol family 16
Thu Mar  5 17:12:47 2020 kern.warn kernel: [    0.127943] Can't analyze schedule() prologue at 8037dd78
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.150894] mt7621_gpio 10000600.gpio: registering 32 gpios
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.156494] mt7621_gpio 10000600.gpio: registering 32 gpios
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.162090] mt7621_gpio 10000600.gpio: registering 32 gpios
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.172431] clocksource: Switched to clocksource MIPS
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.178452] NET: Registered protocol family 2
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.183702] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.190395] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.196580] TCP: Hash tables configured (established 1024 bind 1024)
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.202834] UDP hash table entries: 256 (order: 0, 4096 bytes)
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.208436] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.214770] NET: Registered protocol family 1
Thu Mar  5 17:12:47 2020 kern.debug kernel: [    0.218946] PCI: CLS 0 bytes, default 32
Thu Mar  5 17:12:47 2020 kern.warn kernel: [    0.222408] Crashlog allocated RAM at address 0x3f00000
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.229106] workingset: timestamp_bits=30 max_order=15 bucket_order=0
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.241454] squashfs: version 4.0 (2009/01/31) Phillip Lougher
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.247077] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.267271] io scheduler noop registered
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.271005] io scheduler deadline registered (default)
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.276936] gpio-export gpio_export: 1 gpio(s) exported
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.282150] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.291163] console [ttyS0] disabled
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.294661] 10000c00.uartlite: ttyS0 at MMIO 0x10000c00 (irq = 28, base_baud = 2500000) is a 16550A
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.303375] console [ttyS0] enabled
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.310378] bootconsole [early0] disabled
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.319154] 10000d00.uart1: ttyS1 at MMIO 0x10000d00 (irq = 29, base_baud = 2500000) is a 16550A
Thu Mar  5 17:12:47 2020 kern.err kernel: [    0.328743] cacheinfo: Failed to find cpu0 device node
Thu Mar  5 17:12:47 2020 kern.warn kernel: [    0.333996] cacheinfo: Unable to detect cache hierarchy for CPU 0
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.340946] spi-mt7621 10000b00.spi: sys_freq: 191666666
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.363456] m25p80 spi0.0: w25q128 (16384 Kbytes)
Thu Mar  5 17:12:47 2020 kern.notice kernel: [    0.368283] 4 fixed-partitions partitions found on MTD device spi0.0
Thu Mar  5 17:12:47 2020 kern.notice kernel: [    0.374743] Creating 4 MTD partitions on "spi0.0":
Thu Mar  5 17:12:47 2020 kern.notice kernel: [    0.379612] 0x000000000000-0x000000030000 : "u-boot"
Thu Mar  5 17:12:47 2020 kern.notice kernel: [    0.385612] 0x000000030000-0x000000040000 : "u-boot-env"
Thu Mar  5 17:12:47 2020 kern.notice kernel: [    0.391828] 0x000000040000-0x000000050000 : "factory"
Thu Mar  5 17:12:47 2020 kern.notice kernel: [    0.397914] 0x000000050000-0x000001000000 : "firmware"
Thu Mar  5 17:12:47 2020 kern.notice kernel: [    0.476790] 2 uimage-fw partitions found on MTD device firmware
Thu Mar  5 17:12:47 2020 kern.notice kernel: [    0.482841] 0x000000050000-0x0000001af25e : "kernel"
Thu Mar  5 17:12:47 2020 kern.notice kernel: [    0.488818] 0x0000001af25e-0x000001000000 : "rootfs"
Thu Mar  5 17:12:47 2020 kern.notice kernel: [    0.494744] mtd: device 5 (rootfs) set to be root filesystem
Thu Mar  5 17:12:47 2020 kern.notice kernel: [    0.502045] 1 squashfs-split partitions found on MTD device rootfs
Thu Mar  5 17:12:47 2020 kern.notice kernel: [    0.508397] 0x000000400000-0x000001000000 : "rootfs_data"
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.515534] libphy: Fixed MDIO Bus: probed
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.529095] rt3050-esw 10110000.esw: link changed 0x00
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.537574] mtk_soc_eth 10100000.ethernet eth0: mediatek frame engine at 0xb0100000, irq 5
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.547898] NET: Registered protocol family 10
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.556519] Segment Routing with IPv6
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.560355] NET: Registered protocol family 17
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.564985] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.578137] 8021q: 802.1Q VLAN Support v1.8
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.594621] VFS: Mounted root (squashfs filesystem) readonly on device 31:5.
Thu Mar  5 17:12:47 2020 kern.info kernel: [    0.602753] Freeing unused kernel memory: 168K
Thu Mar  5 17:12:47 2020 kern.warn kernel: [    0.607258] This architecture does not have kernel memory protection.
Thu Mar  5 17:12:47 2020 user.info kernel: [    1.805242] init: Console is alive
Thu Mar  5 17:12:47 2020 user.info kernel: [    1.808935] init: - watchdog -
Thu Mar  5 17:12:47 2020 kern.notice kernel: [    2.282484] random: fast init done
Thu Mar  5 17:12:47 2020 user.info kernel: [    3.160387] kmodloader: loading kernel modules from /etc/modules-boot.d/*
Thu Mar  5 17:12:47 2020 kern.info kernel: [    3.391486] usbcore: registered new interface driver usbfs
Thu Mar  5 17:12:47 2020 kern.info kernel: [    3.397240] usbcore: registered new interface driver hub
Thu Mar  5 17:12:47 2020 kern.info kernel: [    3.402776] usbcore: registered new device driver usb
Thu Mar  5 17:12:47 2020 kern.info kernel: [    3.414625] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
Thu Mar  5 17:12:47 2020 kern.info kernel: [    3.422961] ehci-platform: EHCI generic platform driver
Thu Mar  5 17:12:47 2020 kern.info kernel: [    3.438553] phy phy-10120000.usbphy.0: remote usb device wakeup disabled
Thu Mar  5 17:12:47 2020 kern.info kernel: [    3.445368] phy phy-10120000.usbphy.0: UTMI 16bit 30MHz
Thu Mar  5 17:12:47 2020 kern.info kernel: [    3.450684] ehci-platform 101c0000.ehci: EHCI Host Controller
Thu Mar  5 17:12:47 2020 kern.info kernel: [    3.456567] ehci-platform 101c0000.ehci: new USB bus registered, assigned bus number 1
Thu Mar  5 17:12:47 2020 kern.info kernel: [    3.464731] ehci-platform 101c0000.ehci: irq 26, io mem 0x101c0000
Thu Mar  5 17:12:47 2020 kern.info kernel: [    3.492451] ehci-platform 101c0000.ehci: USB 2.0 started, EHCI 1.00
Thu Mar  5 17:12:47 2020 kern.info kernel: [    3.499837] hub 1-0:1.0: USB hub found
Thu Mar  5 17:12:47 2020 kern.info kernel: [    3.504162] hub 1-0:1.0: 1 port detected
Thu Mar  5 17:12:47 2020 kern.info kernel: [    3.511329] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
Thu Mar  5 17:12:47 2020 kern.info kernel: [    3.519259] ohci-platform: OHCI generic platform driver
Thu Mar  5 17:12:47 2020 kern.info kernel: [    3.524914] ohci-platform 101c1000.ohci: Generic Platform OHCI controller
Thu Mar  5 17:12:47 2020 kern.info kernel: [    3.531851] ohci-platform 101c1000.ohci: new USB bus registered, assigned bus number 2
Thu Mar  5 17:12:47 2020 kern.info kernel: [    3.540026] ohci-platform 101c1000.ohci: irq 26, io mem 0x101c1000
Thu Mar  5 17:12:47 2020 kern.info kernel: [    3.617625] hub 2-0:1.0: USB hub found
Thu Mar  5 17:12:47 2020 kern.info kernel: [    3.621829] hub 2-0:1.0: 1 port detected
Thu Mar  5 17:12:47 2020 user.info kernel: [    3.630253] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
Thu Mar  5 17:12:47 2020 user.info kernel: [    3.648141] init: - preinit -
Thu Mar  5 17:12:47 2020 kern.info kernel: [    5.070456] rt3050-esw 10110000.esw: link changed 0x00
Thu Mar  5 17:12:47 2020 kern.notice kernel: [    5.261183] random: procd: uninitialized urandom read (4 bytes read)
Thu Mar  5 17:12:47 2020 kern.notice kernel: [    8.707683] jffs2: notice: (383) jffs2_build_xattr_subsystem: complete building xattr subsystem, 18 of xdatum (2 unchecked, 16 orphan) and 69 of xref (13 dead, 34 orphan) found.
Thu Mar  5 17:12:47 2020 user.info kernel: [    8.725813] mount_root: switching to jffs2 overlay
Thu Mar  5 17:12:47 2020 kern.warn kernel: [    8.758300] overlayfs: upper fs does not support tmpfile.
Thu Mar  5 17:12:47 2020 user.warn kernel: [    8.773388] urandom-seed: Seeding with /etc/urandom.seed
Thu Mar  5 17:12:47 2020 user.info kernel: [    8.834518] procd: - early -
Thu Mar  5 17:12:47 2020 user.info kernel: [    8.837558] procd: - watchdog -
Thu Mar  5 17:12:47 2020 kern.info kernel: [    9.639773] rt3050-esw 10110000.esw: link changed 0x02
Thu Mar  5 17:12:47 2020 user.info kernel: [    9.769155] procd: - watchdog -
Thu Mar  5 17:12:47 2020 user.info kernel: [    9.772833] procd: - ubus -
Thu Mar  5 17:12:47 2020 kern.notice kernel: [   10.163884] random: ubusd: uninitialized urandom read (4 bytes read)
Thu Mar  5 17:12:47 2020 kern.notice kernel: [   10.263232] random: ubusd: uninitialized urandom read (4 bytes read)
Thu Mar  5 17:12:47 2020 kern.notice kernel: [   10.271084] random: ubusd: uninitialized urandom read (4 bytes read)
Thu Mar  5 17:12:47 2020 user.info kernel: [   10.279555] procd: - init -
Thu Mar  5 17:12:47 2020 user.info kernel: [   10.862035] kmodloader: loading kernel modules from /etc/modules.d/*
Thu Mar  5 17:12:47 2020 kern.info kernel: [   10.959317] ip6_tables: (C) 2000-2006 Netfilter Core Team
Thu Mar  5 17:12:47 2020 kern.info kernel: [   10.976851] Loading modules backported from Linux version wt-2017-11-01-0-gfe248fc2c180
Thu Mar  5 17:12:47 2020 kern.info kernel: [   10.985044] Backport generated by backports.git v4.14-rc2-1-31-g86cf0e5d
Thu Mar  5 17:12:47 2020 kern.info kernel: [   10.995178] ip_tables: (C) 2000-2006 Netfilter Core Team
Thu Mar  5 17:12:47 2020 kern.info kernel: [   11.009856] nf_conntrack version 0.5.0 (2048 buckets, 8192 max)
Thu Mar  5 17:12:47 2020 kern.info kernel: [   11.088705] xt_time: kernel timezone is -0000
Thu Mar  5 17:12:47 2020 kern.info kernel: [   11.157032] mt76_wmac 10300000.wmac: ASIC revision: 76280001
Thu Mar  5 17:12:47 2020 kern.info kernel: [   12.184481] mt76_wmac 10300000.wmac: Firmware Version: 20151201
Thu Mar  5 17:12:47 2020 kern.info kernel: [   12.190507] mt76_wmac 10300000.wmac: Build Time: 20151201183641
Thu Mar  5 17:12:47 2020 kern.info kernel: [   12.212439] mt76_wmac 10300000.wmac: firmware init done
Thu Mar  5 17:12:47 2020 kern.debug kernel: [   12.385467] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
Thu Mar  5 17:12:47 2020 kern.info kernel: [   12.432307] PPP generic driver version 2.4.2
Thu Mar  5 17:12:47 2020 kern.info kernel: [   12.441968] NET: Registered protocol family 24
Thu Mar  5 17:12:47 2020 user.info kernel: [   12.520429] kmodloader: done loading kernel modules from /etc/modules.d/*
Thu Mar  5 17:12:47 2020 kern.warn kernel: [   13.610714] urandom_read: 5 callbacks suppressed
Thu Mar  5 17:12:47 2020 kern.notice kernel: [   13.610724] random: jshn: uninitialized urandom read (4 bytes read)
Thu Mar  5 17:12:48 2020 user.notice dnsmasq: DNS rebinding protection is active, will discard upstream RFC1918 responses!
Thu Mar  5 17:12:48 2020 user.notice dnsmasq: Allowing 127.0.0.0/8 responses
Thu Mar  5 17:12:49 2020 daemon.info dnsmasq[714]: started, version 2.80 cachesize 150
Thu Mar  5 17:12:49 2020 daemon.info dnsmasq[714]: DNS service limited to local subnets
Thu Mar  5 17:12:49 2020 daemon.info dnsmasq[714]: compile time options: IPv6 GNU-getopt no-DBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack no-ipset no-auth no-DNSSEC no-ID loop-detect inotify dumpfile
Thu Mar  5 17:12:49 2020 daemon.info dnsmasq[714]: using local addresses only for domain test
Thu Mar  5 17:12:49 2020 daemon.info dnsmasq[714]: using local addresses only for domain onion
Thu Mar  5 17:12:49 2020 daemon.info dnsmasq[714]: using local addresses only for domain localhost
Thu Mar  5 17:12:49 2020 daemon.info dnsmasq[714]: using local addresses only for domain local
Thu Mar  5 17:12:49 2020 daemon.info dnsmasq[714]: using local addresses only for domain invalid
Thu Mar  5 17:12:49 2020 daemon.info dnsmasq[714]: using local addresses only for domain bind
Thu Mar  5 17:12:49 2020 daemon.info dnsmasq[714]: using local addresses only for domain lan
Thu Mar  5 17:12:49 2020 daemon.warn dnsmasq[714]: no servers found in /tmp/resolv.conf.auto, will retry
Thu Mar  5 17:12:49 2020 daemon.info dnsmasq[714]: read /etc/hosts - 4 addresses
Thu Mar  5 17:12:49 2020 daemon.info dnsmasq[714]: read /tmp/hosts/dhcp.cfg01411c - 0 addresses
Thu Mar  5 17:12:49 2020 kern.info kernel: [   16.609875] rt3050-esw 10110000.esw: link changed 0x00
Thu Mar  5 17:12:49 2020 authpriv.info dropbear[741]: Not backgrounding
Thu Mar  5 17:12:50 2020 user.notice : Added device handler type: tunnel
Thu Mar  5 17:12:50 2020 user.notice : Added device handler type: Network device
Thu Mar  5 17:12:50 2020 user.notice : Added device handler type: bridge
Thu Mar  5 17:12:50 2020 user.notice : Added device handler type: veth
Thu Mar  5 17:12:50 2020 user.notice : Added device handler type: macvlan
Thu Mar  5 17:12:50 2020 user.notice : Added device handler type: 8021ad
Thu Mar  5 17:12:50 2020 user.notice : Added device handler type: 8021q
Thu Mar  5 17:12:53 2020 user.notice ucitrack: Setting up /etc/config/network reload dependency on /etc/config/dhcp
Thu Mar  5 17:12:53 2020 user.notice ucitrack: Setting up /etc/config/network reload dependency on /etc/config/radvd
Thu Mar  5 17:12:53 2020 user.notice ucitrack: Setting up /etc/config/wireless reload dependency on /etc/config/network
Thu Mar  5 17:12:53 2020 user.notice ucitrack: Setting up /etc/config/firewall reload dependency on /etc/config/luci-splash
Thu Mar  5 17:12:53 2020 user.notice ucitrack: Setting up /etc/config/firewall reload dependency on /etc/config/qos
Thu Mar  5 17:12:53 2020 user.notice ucitrack: Setting up /etc/config/firewall reload dependency on /etc/config/miniupnpd
Thu Mar  5 17:12:53 2020 user.notice ucitrack: Setting up /etc/config/dhcp reload dependency on /etc/config/odhcpd
Thu Mar  5 17:12:54 2020 user.notice ucitrack: Setting up non-init /etc/config/fstab reload handler: /sbin/block mount
Thu Mar  5 17:12:54 2020 user.notice ucitrack: Setting up /etc/config/system reload trigger for non-procd /etc/init.d/led
Thu Mar  5 17:12:54 2020 kern.info kernel: [   21.193254] rt3050-esw 10110000.esw: link changed 0x02
Thu Mar  5 17:12:54 2020 user.notice ucitrack: Setting up /etc/config/system reload dependency on /etc/config/luci_statistics
Thu Mar  5 17:12:54 2020 user.notice ucitrack: Setting up /etc/config/system reload dependency on /etc/config/dhcp
Thu Mar  5 17:12:55 2020 daemon.notice procd: /etc/rc.d/S96led: setting up led wifi
Thu Mar  5 17:12:55 2020 daemon.notice procd: /etc/rc.d/S96led: setting up led wan
Thu Mar  5 17:12:56 2020 kern.info kernel: [   22.675151] br-lan: port 1(eth0.1) entered blocking state
Thu Mar  5 17:12:56 2020 kern.info kernel: [   22.680644] br-lan: port 1(eth0.1) entered disabled state
Thu Mar  5 17:12:56 2020 kern.info kernel: [   22.686582] device eth0.1 entered promiscuous mode
Thu Mar  5 17:12:56 2020 kern.info kernel: [   22.691446] device eth0 entered promiscuous mode
Thu Mar  5 17:12:56 2020 kern.info kernel: [   22.832740] br-lan: port 1(eth0.1) entered blocking state
Thu Mar  5 17:12:56 2020 kern.info kernel: [   22.838240] br-lan: port 1(eth0.1) entered forwarding state
Thu Mar  5 17:12:56 2020 kern.info kernel: [   22.844348] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
Thu Mar  5 17:12:56 2020 daemon.notice netifd: Interface 'lan' is enabled
Thu Mar  5 17:12:56 2020 daemon.notice netifd: Interface 'lan' is setting up now
Thu Mar  5 17:12:56 2020 daemon.notice netifd: Interface 'lan' is now up
Thu Mar  5 17:12:56 2020 daemon.notice netifd: Interface 'loopback' is enabled
Thu Mar  5 17:12:56 2020 daemon.notice netifd: Interface 'loopback' is setting up now
Thu Mar  5 17:12:56 2020 daemon.notice netifd: Interface 'loopback' is now up
Thu Mar  5 17:12:56 2020 daemon.notice netifd: Interface 'wan' is enabled
Thu Mar  5 17:12:56 2020 daemon.notice netifd: Interface 'wan6' is enabled
Thu Mar  5 17:12:56 2020 daemon.notice netifd: bridge 'br-lan' link is up
Thu Mar  5 17:12:56 2020 daemon.notice netifd: Interface 'lan' has link connectivity
Thu Mar  5 17:12:56 2020 daemon.notice netifd: Network device 'eth0' link is up
Thu Mar  5 17:12:56 2020 daemon.notice netifd: VLAN 'eth0.1' link is up
Thu Mar  5 17:12:56 2020 daemon.notice netifd: Network device 'lo' link is up
Thu Mar  5 17:12:56 2020 daemon.notice netifd: Interface 'loopback' has link connectivity
Thu Mar  5 17:12:56 2020 daemon.notice netifd: VLAN 'eth0.2' link is up
Thu Mar  5 17:12:56 2020 daemon.notice netifd: Interface 'wan' has link connectivity
Thu Mar  5 17:12:56 2020 daemon.notice netifd: Interface 'wan' is setting up now
Thu Mar  5 17:12:56 2020 daemon.notice netifd: Interface 'wan6' has link connectivity
Thu Mar  5 17:12:56 2020 daemon.notice netifd: Interface 'wan6' is setting up now
Thu Mar  5 17:12:57 2020 kern.info kernel: [   23.692713] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
Thu Mar  5 17:12:57 2020 daemon.notice netifd: wan (1086): udhcpc: started, v1.28.4
Thu Mar  5 17:12:57 2020 daemon.warn odhcpd[810]: DHCPV6 SOLICIT IA_NA from 000100012269130d3c5282380139 on br-lan: ok fdd1:633f:947f::2b1/128
Thu Mar  5 17:12:58 2020 daemon.notice netifd: wan (1086): udhcpc: sending discover
Thu Mar  5 17:12:58 2020 daemon.info dnsmasq[714]: read /etc/hosts - 4 addresses
Thu Mar  5 17:12:58 2020 daemon.info dnsmasq[714]: read /tmp/hosts/odhcpd - 0 addresses
Thu Mar  5 17:12:58 2020 daemon.info dnsmasq[714]: read /tmp/hosts/dhcp.cfg01411c.1091 - 0 addresses
Thu Mar  5 17:12:58 2020 daemon.info dnsmasq[714]: read /tmp/hosts/dhcp.cfg01411c - 0 addresses
Thu Mar  5 17:12:59 2020 daemon.warn odhcpd[810]: DHCPV6 SOLICIT IA_NA from 000100012269130d3c5282380139 on br-lan: ok fdd1:633f:947f::2b1/128
Thu Mar  5 17:12:59 2020 daemon.info procd: - init complete -
Thu Mar  5 17:12:59 2020 user.notice mac80211: Failed command: iw phy phy0 set antenna all all
Thu Mar  5 17:13:00 2020 daemon.warn odhcpd[810]: DHCPV6 REQUEST IA_NA from 000100012269130d3c5282380139 on br-lan: ok fdd1:633f:947f::2b1/128
Thu Mar  5 17:13:00 2020 daemon.info dnsmasq[714]: read /etc/hosts - 4 addresses
Thu Mar  5 17:13:00 2020 daemon.info dnsmasq[714]: read /tmp/hosts/odhcpd - 1 addresses
Thu Mar  5 17:13:00 2020 daemon.info dnsmasq[714]: read /tmp/hosts/dhcp.cfg01411c.1091 - 0 addresses
Thu Mar  5 17:13:00 2020 daemon.info dnsmasq[714]: read /tmp/hosts/dhcp.cfg01411c - 0 addresses
Thu Mar  5 17:13:00 2020 daemon.err hostapd: Configuration file: /var/run/hostapd-phy0.conf
Thu Mar  5 17:13:00 2020 kern.info kernel: [   27.466838] IPv6: ADDRCONF(NETDEV_UP): wlan0-1: link is not ready
Thu Mar  5 17:13:00 2020 kern.info kernel: [   27.483768] br-lan: port 2(wlan0-1) entered blocking state
Thu Mar  5 17:13:00 2020 kern.info kernel: [   27.489455] br-lan: port 2(wlan0-1) entered disabled state
Thu Mar  5 17:13:00 2020 kern.info kernel: [   27.495502] device wlan0-1 entered promiscuous mode
Thu Mar  5 17:13:00 2020 daemon.notice hostapd: wlan0-1: interface state UNINITIALIZED->COUNTRY_UPDATE
Thu Mar  5 17:13:00 2020 daemon.err hostapd: Using interface wlan0-1 with hwaddr 96:83:c4:01:86:d2 and ssid "OpenWrt"
Thu Mar  5 17:13:01 2020 daemon.notice netifd: wan (1086): udhcpc: sending discover
Thu Mar  5 17:13:01 2020 daemon.notice hostapd: wlan0-1: interface state COUNTRY_UPDATE->ENABLED
Thu Mar  5 17:13:01 2020 daemon.notice hostapd: wlan0-1: AP-ENABLED
Thu Mar  5 17:13:01 2020 kern.info kernel: [   28.331243] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Thu Mar  5 17:13:01 2020 daemon.notice netifd: radio0 (1031): Successfully initialized wpa_supplicant
Thu Mar  5 17:13:02 2020 daemon.notice netifd: Interface 'wwan' is enabled
Thu Mar  5 17:13:02 2020 daemon.info dnsmasq[714]: exiting on receipt of SIGTERM
Thu Mar  5 17:13:02 2020 daemon.info dnsmasq[1384]: started, version 2.80 cachesize 150
Thu Mar  5 17:13:02 2020 daemon.info dnsmasq[1384]: DNS service limited to local subnets
Thu Mar  5 17:13:02 2020 daemon.info dnsmasq[1384]: compile time options: IPv6 GNU-getopt no-DBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack no-ipset no-auth no-DNSSEC no-ID loop-detect inotify dumpfile
Thu Mar  5 17:13:02 2020 daemon.info dnsmasq-dhcp[1384]: DHCP, IP range 192.168.1.100 -- 192.168.1.249, lease time 12h
Thu Mar  5 17:13:02 2020 daemon.info dnsmasq[1384]: using local addresses only for domain test
Thu Mar  5 17:13:02 2020 daemon.info dnsmasq[1384]: using local addresses only for domain onion
Thu Mar  5 17:13:02 2020 daemon.info dnsmasq[1384]: using local addresses only for domain localhost
Thu Mar  5 17:13:02 2020 daemon.info dnsmasq[1384]: using local addresses only for domain local
Thu Mar  5 17:13:02 2020 daemon.info dnsmasq[1384]: using local addresses only for domain invalid
Thu Mar  5 17:13:02 2020 daemon.info dnsmasq[1384]: using local addresses only for domain bind
Thu Mar  5 17:13:02 2020 daemon.info dnsmasq[1384]: using local addresses only for domain lan
Thu Mar  5 17:13:02 2020 daemon.warn dnsmasq[1384]: no servers found in /tmp/resolv.conf.auto, will retry
Thu Mar  5 17:13:02 2020 daemon.info dnsmasq[1384]: read /etc/hosts - 4 addresses
Thu Mar  5 17:13:02 2020 daemon.info dnsmasq[1384]: read /tmp/hosts/odhcpd - 1 addresses
Thu Mar  5 17:13:02 2020 daemon.info dnsmasq[1384]: read /tmp/hosts/dhcp.cfg01411c - 2 addresses
Thu Mar  5 17:13:02 2020 daemon.info dnsmasq-dhcp[1384]: read /etc/ethers - 0 addresses
Thu Mar  5 17:13:02 2020 daemon.info dnsmasq[1384]: read /etc/hosts - 4 addresses
Thu Mar  5 17:13:02 2020 daemon.info dnsmasq[1384]: read /tmp/hosts/odhcpd - 1 addresses
Thu Mar  5 17:13:02 2020 daemon.info dnsmasq[1384]: read /tmp/hosts/dhcp.cfg01411c - 2 addresses
Thu Mar  5 17:13:02 2020 daemon.info dnsmasq-dhcp[1384]: read /etc/ethers - 0 addresses
Thu Mar  5 17:13:03 2020 kern.info kernel: [   29.941096] wlan0: authenticate with ba:69:f4:37:90:30
Thu Mar  5 17:13:03 2020 kern.info kernel: [   29.953656] wlan0: send auth to ba:69:f4:37:90:30 (try 1/3)
Thu Mar  5 17:13:03 2020 kern.info kernel: [   29.960501] wlan0: authenticated
Thu Mar  5 17:13:03 2020 kern.info kernel: [   29.972519] wlan0: associate with ba:69:f4:37:90:30 (try 1/3)
Thu Mar  5 17:13:03 2020 daemon.notice netifd: Network device 'wlan0' link is up
Thu Mar  5 17:13:03 2020 daemon.notice netifd: Interface 'wwan' has link connectivity
Thu Mar  5 17:13:03 2020 daemon.notice netifd: Interface 'wwan' is setting up now
Thu Mar  5 17:13:03 2020 kern.info kernel: [   29.984646] wlan0: RX AssocResp from ba:69:f4:37:90:30 (capab=0x401 status=0 aid=1)
Thu Mar  5 17:13:03 2020 kern.info kernel: [   29.992737] wlan0: associated
Thu Mar  5 17:13:03 2020 daemon.info dnsmasq-dhcp[1384]: DHCPREQUEST(br-lan) 192.168.1.114 3c:52:82:38:01:39
Thu Mar  5 17:13:03 2020 daemon.info dnsmasq-dhcp[1384]: DHCPACK(br-lan) 192.168.1.114 3c:52:82:38:01:39 LAPTOP-A4F48KMV
Thu Mar  5 17:13:03 2020 daemon.notice netifd: wwan (1399): udhcpc: started, v1.28.4
Thu Mar  5 17:13:03 2020 daemon.notice netifd: wwan (1399): udhcpc: sending discover
Thu Mar  5 17:13:04 2020 kern.info kernel: [   30.711123] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Thu Mar  5 17:13:04 2020 daemon.notice netifd: wan (1086): udhcpc: sending discover
Thu Mar  5 17:13:05 2020 kern.info kernel: [   31.954467] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0-1: link becomes ready
Thu Mar  5 17:13:05 2020 kern.info kernel: [   31.961413] br-lan: port 2(wlan0-1) entered blocking state
Thu Mar  5 17:13:05 2020 kern.info kernel: [   31.967062] br-lan: port 2(wlan0-1) entered forwarding state
Thu Mar  5 17:13:05 2020 daemon.notice netifd: Network device 'wlan0-1' link is up
Thu Mar  5 17:13:06 2020 daemon.notice netifd: wwan (1399): udhcpc: sending discover
Thu Mar  5 17:13:06 2020 daemon.notice netifd: wwan (1399): udhcpc: sending select for 10.1.167.131
Thu Mar  5 17:13:06 2020 daemon.notice netifd: wwan (1399): udhcpc: lease of 10.1.167.131 obtained, lease time 3600
Thu Mar  5 17:13:06 2020 daemon.notice netifd: Interface 'wwan' is now up
Thu Mar  5 17:13:06 2020 daemon.info dnsmasq[1384]: reading /tmp/resolv.conf.auto
Thu Mar  5 17:13:06 2020 daemon.info dnsmasq[1384]: using local addresses only for domain test
Thu Mar  5 17:13:06 2020 daemon.info dnsmasq[1384]: using local addresses only for domain onion
Thu Mar  5 17:13:06 2020 daemon.info dnsmasq[1384]: using local addresses only for domain localhost
Thu Mar  5 17:13:06 2020 daemon.info dnsmasq[1384]: using local addresses only for domain local
Thu Mar  5 17:13:06 2020 daemon.info dnsmasq[1384]: using local addresses only for domain invalid
Thu Mar  5 17:13:06 2020 daemon.info dnsmasq[1384]: using local addresses only for domain bind
Thu Mar  5 17:13:06 2020 daemon.info dnsmasq[1384]: using local addresses only for domain lan
Thu Mar  5 17:13:06 2020 daemon.info dnsmasq[1384]: using nameserver 8.8.8.8#53
Thu Mar  5 17:13:06 2020 daemon.info dnsmasq[1384]: using nameserver 4.4.4.4#53
Thu Mar  5 17:15:32 2020 daemon.err uhttpd[867]: luci: accepted login on / for root from 192.168.1.114

Kernel:

[    0.000000] Linux version 4.14.95 (buildbot@2b39dc2beaf4) (gcc version 7.3.0 (OpenWrt GCC 7.3.0 r7676-cddd7b4c77)) #0 Wed Jan 30 12:21:02 2019
[    0.000000] Board has DDR2
[    0.000000] Analog PMU set to hw control
[    0.000000] Digital PMU set to hw control
[    0.000000] SoC Type: MediaTek MT7628AN ver:1 eco:2
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 00019655 (MIPS 24KEc)
[    0.000000] MIPS: machine is GL-MT300N-V2
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 08000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] On node 0 totalpages: 32768
[    0.000000] free_area_init_node: node 0, pgdat 80422fc0, node_mem_map 81000040
[    0.000000]   Normal zone: 256 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 32768 pages, LIFO batch:7
[    0.000000] random: get_random_bytes called from 0x8042672c with crng_init=0
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc: [0] 0 
[    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 32512
[    0.000000] Kernel command line: console=ttyS0,115200 rootfstype=squashfs,jffs2
[    0.000000] PID hash table entries: 512 (order: -1, 2048 bytes)
[    0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
[    0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
[    0.000000] Writing ErrCtl register=0007e000
[    0.000000] Readback ErrCtl register=0007e000
[    0.000000] Memory: 125224K/131072K available (3592K kernel code, 183K rwdata, 464K rodata, 168K init, 206K bss, 5848K reserved, 0K cma-reserved)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS: 256
[    0.000000] intc: using register map from devicetree
[    0.000000] CPU Clock: 575MHz
[    0.000000] timer_probe: no matching timers found
[    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 6647862422 ns
[    0.000012] sched_clock: 32 bits at 287MHz, resolution 3ns, wraps every 7469508094ns
[    0.007549] Calibrating delay loop... 380.92 BogoMIPS (lpj=1904640)
[    0.073456] pid_max: default: 32768 minimum: 301
[    0.078167] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.084520] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.097215] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.106708] futex hash table entries: 256 (order: -1, 3072 bytes)
[    0.112662] pinctrl core: initialized pinctrl subsystem
[    0.119037] NET: Registered protocol family 16
[    0.127943] Can't analyze schedule() prologue at 8037dd78
[    0.150894] mt7621_gpio 10000600.gpio: registering 32 gpios
[    0.156494] mt7621_gpio 10000600.gpio: registering 32 gpios
[    0.162090] mt7621_gpio 10000600.gpio: registering 32 gpios
[    0.172431] clocksource: Switched to clocksource MIPS
[    0.178452] NET: Registered protocol family 2
[    0.183702] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
[    0.190395] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[    0.196580] TCP: Hash tables configured (established 1024 bind 1024)
[    0.202834] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.208436] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.214770] NET: Registered protocol family 1
[    0.218946] PCI: CLS 0 bytes, default 32
[    0.222408] Crashlog allocated RAM at address 0x3f00000
[    0.229106] workingset: timestamp_bits=30 max_order=15 bucket_order=0
[    0.241454] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.247077] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.267271] io scheduler noop registered
[    0.271005] io scheduler deadline registered (default)
[    0.276936] gpio-export gpio_export: 1 gpio(s) exported
[    0.282150] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    0.291163] console [ttyS0] disabled
[    0.294661] 10000c00.uartlite: ttyS0 at MMIO 0x10000c00 (irq = 28, base_baud = 2500000) is a 16550A
[    0.303375] console [ttyS0] enabled
[    0.310378] bootconsole [early0] disabled
[    0.319154] 10000d00.uart1: ttyS1 at MMIO 0x10000d00 (irq = 29, base_baud = 2500000) is a 16550A
[    0.328743] cacheinfo: Failed to find cpu0 device node
[    0.333996] cacheinfo: Unable to detect cache hierarchy for CPU 0
[    0.340946] spi-mt7621 10000b00.spi: sys_freq: 191666666
[    0.363456] m25p80 spi0.0: w25q128 (16384 Kbytes)
[    0.368283] 4 fixed-partitions partitions found on MTD device spi0.0
[    0.374743] Creating 4 MTD partitions on "spi0.0":
[    0.379612] 0x000000000000-0x000000030000 : "u-boot"
[    0.385612] 0x000000030000-0x000000040000 : "u-boot-env"
[    0.391828] 0x000000040000-0x000000050000 : "factory"
[    0.397914] 0x000000050000-0x000001000000 : "firmware"
[    0.476790] 2 uimage-fw partitions found on MTD device firmware
[    0.482841] 0x000000050000-0x0000001af25e : "kernel"
[    0.488818] 0x0000001af25e-0x000001000000 : "rootfs"
[    0.494744] mtd: device 5 (rootfs) set to be root filesystem
[    0.502045] 1 squashfs-split partitions found on MTD device rootfs
[    0.508397] 0x000000400000-0x000001000000 : "rootfs_data"
[    0.515534] libphy: Fixed MDIO Bus: probed
[    0.529095] rt3050-esw 10110000.esw: link changed 0x00
[    0.537574] mtk_soc_eth 10100000.ethernet eth0: mediatek frame engine at 0xb0100000, irq 5
[    0.547898] NET: Registered protocol family 10
[    0.556519] Segment Routing with IPv6
[    0.560355] NET: Registered protocol family 17
[    0.564985] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[    0.578137] 8021q: 802.1Q VLAN Support v1.8
[    0.594621] VFS: Mounted root (squashfs filesystem) readonly on device 31:5.
[    0.602753] Freeing unused kernel memory: 168K
[    0.607258] This architecture does not have kernel memory protection.
[    1.805242] init: Console is alive
[    1.808935] init: - watchdog -
[    2.282484] random: fast init done
[    3.160387] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    3.391486] usbcore: registered new interface driver usbfs
[    3.397240] usbcore: registered new interface driver hub
[    3.402776] usbcore: registered new device driver usb
[    3.414625] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    3.422961] ehci-platform: EHCI generic platform driver
[    3.438553] phy phy-10120000.usbphy.0: remote usb device wakeup disabled
[    3.445368] phy phy-10120000.usbphy.0: UTMI 16bit 30MHz
[    3.450684] ehci-platform 101c0000.ehci: EHCI Host Controller
[    3.456567] ehci-platform 101c0000.ehci: new USB bus registered, assigned bus number 1
[    3.464731] ehci-platform 101c0000.ehci: irq 26, io mem 0x101c0000
[    3.492451] ehci-platform 101c0000.ehci: USB 2.0 started, EHCI 1.00
[    3.499837] hub 1-0:1.0: USB hub found
[    3.504162] hub 1-0:1.0: 1 port detected
[    3.511329] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    3.519259] ohci-platform: OHCI generic platform driver
[    3.524914] ohci-platform 101c1000.ohci: Generic Platform OHCI controller
[    3.531851] ohci-platform 101c1000.ohci: new USB bus registered, assigned bus number 2
[    3.540026] ohci-platform 101c1000.ohci: irq 26, io mem 0x101c1000
[    3.617625] hub 2-0:1.0: USB hub found
[    3.621829] hub 2-0:1.0: 1 port detected
[    3.630253] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[    3.648141] init: - preinit -
[    5.070456] rt3050-esw 10110000.esw: link changed 0x00
[    5.261183] random: procd: uninitialized urandom read (4 bytes read)
[    8.707683] jffs2: notice: (383) jffs2_build_xattr_subsystem: complete building xattr subsystem, 18 of xdatum (2 unchecked, 16 orphan) and 69 of xref (13 dead, 34 orphan) found.
[    8.725813] mount_root: switching to jffs2 overlay
[    8.758300] overlayfs: upper fs does not support tmpfile.
[    8.773388] urandom-seed: Seeding with /etc/urandom.seed
[    8.834518] procd: - early -
[    8.837558] procd: - watchdog -
[    9.639773] rt3050-esw 10110000.esw: link changed 0x02
[    9.769155] procd: - watchdog -
[    9.772833] procd: - ubus -
[   10.163884] random: ubusd: uninitialized urandom read (4 bytes read)
[   10.263232] random: ubusd: uninitialized urandom read (4 bytes read)
[   10.271084] random: ubusd: uninitialized urandom read (4 bytes read)
[   10.279555] procd: - init -
[   10.862035] kmodloader: loading kernel modules from /etc/modules.d/*
[   10.959317] ip6_tables: (C) 2000-2006 Netfilter Core Team
[   10.976851] Loading modules backported from Linux version wt-2017-11-01-0-gfe248fc2c180
[   10.985044] Backport generated by backports.git v4.14-rc2-1-31-g86cf0e5d
[   10.995178] ip_tables: (C) 2000-2006 Netfilter Core Team
[   11.009856] nf_conntrack version 0.5.0 (2048 buckets, 8192 max)
[   11.088705] xt_time: kernel timezone is -0000
[   11.157032] mt76_wmac 10300000.wmac: ASIC revision: 76280001
[   12.184481] mt76_wmac 10300000.wmac: Firmware Version: 20151201
[   12.190507] mt76_wmac 10300000.wmac: Build Time: 20151201183641
[   12.212439] mt76_wmac 10300000.wmac: firmware init done
[   12.385467] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[   12.432307] PPP generic driver version 2.4.2
[   12.441968] NET: Registered protocol family 24
[   12.520429] kmodloader: done loading kernel modules from /etc/modules.d/*
[   13.610714] urandom_read: 5 callbacks suppressed
[   13.610724] random: jshn: uninitialized urandom read (4 bytes read)
[   16.609875] rt3050-esw 10110000.esw: link changed 0x00
[   21.193254] rt3050-esw 10110000.esw: link changed 0x02
[   22.675151] br-lan: port 1(eth0.1) entered blocking state
[   22.680644] br-lan: port 1(eth0.1) entered disabled state
[   22.686582] device eth0.1 entered promiscuous mode
[   22.691446] device eth0 entered promiscuous mode
[   22.832740] br-lan: port 1(eth0.1) entered blocking state
[   22.838240] br-lan: port 1(eth0.1) entered forwarding state
[   22.844348] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[   23.692713] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[   27.466838] IPv6: ADDRCONF(NETDEV_UP): wlan0-1: link is not ready
[   27.483768] br-lan: port 2(wlan0-1) entered blocking state
[   27.489455] br-lan: port 2(wlan0-1) entered disabled state
[   27.495502] device wlan0-1 entered promiscuous mode
[   28.331243] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   29.941096] wlan0: authenticate with ba:69:f4:37:90:30
[   29.953656] wlan0: send auth to ba:69:f4:37:90:30 (try 1/3)
[   29.960501] wlan0: authenticated
[   29.972519] wlan0: associate with ba:69:f4:37:90:30 (try 1/3)
[   29.984646] wlan0: RX AssocResp from ba:69:f4:37:90:30 (capab=0x401 status=0 aid=1)
[   29.992737] wlan0: associated
[   30.711123] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   31.954467] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0-1: link becomes ready
[   31.961413] br-lan: port 2(wlan0-1) entered blocking state
[   31.967062] br-lan: port 2(wlan0-1) entered forwarding state
[   64.512132] random: crng init done

Nothing out of the ordinary.
May I suggest a reset and quick configuration of the wwan only?
Take a backup of the config, reset the router, and on first boot enable the wifi access point, create the wwan interface as before, and assign it to wan zone. That should be all that needs to be done.

1 Like

Sorry for the late reply
I didn't have access to the device during the weekend,
when doing what you told me, everything works fine with a normal phone hotspot.
The router is connected as a client and trough the lan port I get internet connection on my pc.
However with an wpa-enterprise client I can ping on the router to google for example but I don't have internet access trough the lan port

I am almost convinced that this is because of eduroam, or whatever the name of the provider.
Have you asked them if there is any restriction?

Eduroam is a widely used student network and I've seen openwrt being used multiple times for bypassing the wpa-enterprise security. But oh well I'm close to giving up.

It's a long shot but an open network that requires an online login is definitely not gonna work right?

Thanks anyway

If you can ping to a numeric IP like 8.8.4.4 but not if you try to address the same site by name (dns.google), it's a DNS problem.

Captive portal networks generally work you will need to use some machine with a web browser on the LAN side. Logging in registers your router's MAC address to the portal, so then other machines on the LAN will also have Internet.

Before giving up, could you give travelmate a chance?

1 Like

I tried, same thing. Works perfectly with a normal hotspot, not with the wpa-enterprise network. Too bad I guess

Could you explain the process of a captive portal auto login a little more?
Although I have a similar situation, the login screen prompts after connecting the network but the page doesn't even load with this error DNS_PROBE_FINISHED_NXDOMAIN. If this could be avoided with this solution then it might bring some hope

WPA enterprise is not connected to this error.
Change your setting in WWAN and use the DNS advertised by DHCP.

This is already the case, I started with a fresh system to test the captive portal login.
With the captive portal, the connection is trough the WAN port, I'm accessing the router trough the LAN