Would this custom firmware likely run on TL-WR841N?

Built a custom OpenWrt firmware for TL-WR841N using latest stable release. (Decided this is different enough from my earlier question to warrant a new thread, since I took the earlier advice to be re the non-custom build; if that's not correct, let me know and I'll delete this add to the old.)

Followed ' Saving firmware space' guide (most items under ' Modifying build configuration variables'), so the full 'openwrt-ar71xx-tiny-tl-wr841-v8-squashfs-factory.bin' is 3,8400 KB, so ...

  1. If I update / flash this to my router it should fit on the 4 MB Flash, correct?
  2. If it's actually a satisfactory build is it likely to run ok on the 32 MB Ram or is it likely I will run into problems because of this ram limit?



3.84 MB???
Likely not. Or you would not be able to save settings, as there would not be enough free space for the squashfs file system.

You do not have the full 4 MB available. There is bootloader, WiFi calibration data etc., which take maybe 200 kB. And you need some 256 kB or so for settings data file system.

The image should in practice be max. some 3.4 MB or so, I think.

(But I have no experience on your device, so that is based on generic knowledge)

1 Like

Thanks hnyman.

I'll assume you're right be wait for other comment before marking solved, as, obviously I don't really know the answer.

Guess I need to look into shrinking the image further.

If I got the image down to 3.4 MB or so would the 32 MB ram be enough to run it?

Kind regards.

Can you share how did you manage to reduce it down to 3.4MB? Iā€™m also fighting with this router

It might.
No direct connection to the image size (except that smaller image likely contains less packages and thus requires less runtime memory.

32 MB RAM is real pain. Pure simple core routing may work, but many apps easily cause spikes in ram needs, causing out-of-memory crashes.

1 Like

Hi zdringy,

I don't have it down to 3.4 MB yet - just hoping to do so.

Happy to share if I do.

Kind regards

1 Like

I may be wrong, but a FACTORY image should always be 3.8 MB. The sysupgrade image is smaller (I have a working setup with 160 kb free and the factory image is 3.8 MB and the sysupgrade is 3.5MB).
Of course no Luci, no ppp, no ipv6. But I installed wpad-wolfssl to get WPA3.

1 Like

Yeah, it is possible that the factory image contains padding to fill the image up to the end of the flashable area, so that the OEM flash routine accepts the image.

But if that 3.5 MB sized sysupgrade image works, then that gives a clear goal for @lb1 :
Build the images so that the sysupgrade is less than 3.5 MB, and the corresponding factory image should be ok (despite the apparently larger size caused by the padding).

1 Like

Hi SteMax97 / hnyman,
The sysupgrade is only 2.945 MB.
By factory image do you mean the firmware from tp-link?
The most recent such image is 3.45 MB, though that includes the uboot loader.
Is there a safe way to test the image that doesn't risk bricking the device?

Also, when I download openwrt-imagebuilder-ar71xx-tiny.Linux-x86_64.tar.xz, extract it and run e.g. 'make image PROFILE="tl-wr841nd-v8" ', I get: Profile "tl-wr841nd-v8" does not exist!
Is this correct or have I not extracted it to the correct location?
I get the same result if I build it whilst building custom firmware for this router.

No. I mean the OpenWrt factory image, meant for flashing from the router running the OEM firmware. When later sysupgrading from OpenWrt to a newer OpenWrt, you would use sysupgrade image. For most routers there are both.


1 Like

You have to cd inside the folder first. The profile name may be different, type " make info " and search for your device.

1 Like

Thanks hnyman,
18.06.7 runs fine.
cut down latest release seems to give some level of function but the luci interface seems broken.
I can ssh in so I'll try reverting that way.

Downgrade to 18.06.7 via ssh went fine.

I've marked hnyman's first answer as the solution so that anyone else who reads this gets the message that the upgrade may not work.

From what I could tell, if you're happy to work without luci, then maybe a cut down version of 19.07 does run on this device - but didn't really investigate how it runs properly. (Wanted to downgrade whilst I could - worried the system might be unstable / get bricked.)

Thanks hnyman and SteMax97

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.