Working Bridge Pi Zero2 WiFi to Eth0, is this correct?

Hi from a newbie

My project was making a RPI4 into a openWrt Router, and a Pi Zero 2w into a wifi client bridging to the eth0 port.
(NAD C446 media-tuner have a useless b/g WiFi, but a Ethernet port)

RPI4 openWrt = 100% success , and works far beyond expectations. (thanks)
Pi Zero 2w WiFi to Eth0 bridge = 100% success (took forever lol)

Now i would like a review if possible on my Pi Zero setup, as the "finishing part", the eht0 , i had no information on how to setup, so i made up a "client" :coffee:

The most of the way , i followed this guide
https://openwrt.org/docs/guide-user/network/wifi/relay_configuration


root@ZERO:~# cat /etc/config/network

config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd47:ddb6:c163::/48'

config device
option name 'br-lan'
option type 'bridge'
list ports 'eth0'
option bridge_empty '1'

config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.2.1'
option netmask '255.255.255.0'
option ip6assign '60'
option gateway '192.168.1.1'
list dns '192.168.1.1'

config interface 'wwan'
option proto 'static'
option ipaddr '192.168.1.2'
option netmask '255.255.255.0'
option gateway '192.168.1.1'
option dns '192.168.1.1'

config interface 'repeater_bridge'
option proto 'relay'
option ipaddr '192.168.1.2'
list network 'client'
list network 'lan'
list network 'wwan'

config device
option name 'eth0'

config interface 'client'
option proto 'static'
option device '@lan'
option ipaddr '192.168.1.3'
option netmask '255.255.255.0'
option gateway '192.168.1.1'
list dns '192.168.1.1'

cat /etc/config/firewall (the only zone left)

config zone
option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
list network 'lan'
list network 'wwan'
list network 'client'

Edit: The NAD get a static leased ip from the main router RPI, works perfect.