WNR2200 V1 OpenWrt Flash don‘t work


I have a WNR2200 V1 with the Fimware and can not Flash any OpenWRT Version over the Web ui. Even in the Recovery Mode i can send the File without errors but nothing happenend. Before i flashed DDWRT without any Problem and back to stock.

How i can Flash the OpenWRT Image any ideas?

Tell me what exact image of OpenWRT you have tried to flash.
Also please refer to Wiki page to see if you have 8M or 16M version.

Is that v1 written on the backside label? If yes, can you please post a picture of it?

Here is the Picture of the Bottom Side

and here with DDWRT installed.

Does Netgear Mention V1 in the Bottom Side of there Routers? Normaly if there newer Revisions they Mention it like V2 or V3 and so on.

Please check https://openwrt.org/toh/netgear/wnr2200 it has been updated recently. Your feedback about flashing would be very valuable.

  1. Can you try flashing current snapshot from web UI (use this snapshot, your model is likely 8M since you have four labels in two rows) If you do it, what happens? Does firmware accept it or not?
  2. Do you have UART adapter? If you do, what do you see on the console when you try to flash it from web ui?
    Can you provide complete bootlog (you can censor MAC address, but I want to see u-boot output and partition table)
    Does your MAC address match backside label?
  3. Can you provide output head -c 128 WNR2200-V1.0.1.102.img
    Which is your current firmware or confirm that it's same as mine:
    md5sum 64ffb77cf8b7da6ce75b4a53cfd9ffcb WNR2200-V1.0.1.102.img

I have tested flashing OpenWrt from this firmware, it worked for me. Maybe you have a different regional version?

if i want to flash over Web interface it says "Wrong Flash Type".

Here is the Output from the Original Firmware and from OpenWRT 19.07 SNAPTSHOT

Could it be that the name "WNR2200" on the OpenWRT image is to blame because on the original image it is written in small letters "wnr2200" ?

Here is the Output with DDWRT image and there are small letters too.

Yes, this is reason why factory firmware does not accept the image. It has to contain exactly device:wnr2200 in the first line, and the checksum of complete image should be 0xFF. The checkum is just arithmetic sum of all bytes mod 256.

Try to get the snapshot from my link, it has correct header:

$ wget http://downloads.openwrt.org/snapshots/targets/ath79/generic/openwrt-ath79-generic-netgear_wnr2200-8m-squashfs-factory.img
$ head -c 128 openwrt-ath79-generic-netgear_wnr2200-8m-squashfs-factory.img 

I have also checked 19.07 snapshot from this link, it also has correct header:

Where did you get that OpenWRT 19.07 SNAPTSHOT, what is file name?