WNR2000v4 with 18.06?

What is the latest OpenWRT (with luci) that runs on a WNR2000v4? I had been running Chaos Calmer on my Wiener Two Thousand for a long time but figured, for security and to hopefully fix a performance bug, it made sense to upgrade.

According to this page, https://openwrt.org/toh/netgear/wnr2000, the WNR2000v4 is supposed to work with 18.06.1. However, the prebuilt images are broken as they are too large and leave no space for the configuration files to be saved. (Strangely, I got no warning about the overlay being on top of RAM. Hopefully someone will update luci to show a big warning at the top of every page when such disasters occur.)

I tried rebuilding the images using the imagebuilder to remove IPv6 and PPP. That still wasn't small enough. I may have been doing it wrong. Here's my make line:

make image PROFILE=WNR2000V4 PACKAGES="uhttpd uhttpd-mod-ubus libiwinfo-lua luci-base luci-app-firewall luci-mod-admin-full luci-theme-bootstrap -ip6tables -odhcp6c -kmod-ipv6 -kmod-ip6tables -odhcpd-ipv6only -ppp -ppp-mod-pppoe -opkg" CONFIG_IPV6=n

I'm not sure what else to remove at this point.

I tried to find a less new version of OpenWRT. I found LEDE 17.01, but its DHCP server did not work. Eventually, after much googling, I was able to get back to Chaos Calmer and that did indeed work. (It would be very good if there was a link to it on the OpenWRT WNR2000v4 wiki page.)


But now, and this is new, the rfkill button on the back of the router has to be pressed once after booting up or else WiFi is disabled. (I presume I can make shell script to fix it, but any help with that would be appreciated, too).

What is the recommended firmware for this device? What other packages can I remove to save space? If I do manage to build a small enough image of 18.06, where would I post it so others don't have to go through this hassle?

Thank you and sorry for having so many questions.

  • Wow...I apologize you ran into this. There is a thread to report that problem: Report Devices Here With 18.06.0 Provided Image too big to save overlay

  • Your device has 4 MB of flash, nothing is currently suggested for your device. See: https://openwrt.org/supported_devices/432_warning

  • To be clear, "removing" a package from a pre-built firmware only marks the file as deleted, it actually creates more disk usage. You have to compile a custom firmware.

  • I'm not even sure a tiny customized build would work. I actually have similar devices...I almost seemed like a troll when I asked about a similar upgrade:

It may be time to upgrade devices.

Gadzooks, you have it! Empathy, that quality so often in most need -- yet least supply -- in tech support forums. I'm impressed by the LEDE/OpenWRT community.

You mean using opkg on a prebuilt firmware? I didn't do that. I was using ImageBuilder on a Unix host. The resulting image file from glomming the binary modules together was definitely smaller as I removed packages in the Make process. Or am I confused?

You seem on the right track. To save space, you make a custom build.


Okay, I managed to build a version that saves the configuration! :smiley:

Unfortunately it is unusable as the DHCP server doesn't work at first boot. :confused:
I have to login and manually run /etc/init.d/dnsmasq restart.

The problem is that the file /var/etc/dnsmasq.conf.cfg01411c is missing this line:


I found an old thread mentioning some sort of race condition where dnsmasq starts before the lan interface is up. However, I didn't see a solution other than that it was marked "fixed". Could it be a regression?

Any suggestions for how to make sure the dhcp-range is set correctly at boot would be much appreciated.

I have had this same DHCP problem with a completely different router (Ubiquiti Edgerouter-Lite). It may work to move dnsmasq to a higher number in /etc/rc.d making it start later. Though when I flashed the Edgerouter to a trunk build of two days ago, the problem went away.

As for the WNR2000v4 I have a couple of them (acutally WN2000RPTV3) but I've hacked them beyond recognition with 16M flash chip, 64M RAM upgrade, new bootloader, and WRT160NL version of OpenWrt. I can't recommend that though since it does work well at first, they reboot themselves after several hours for some reason.

1 Like