Wnr1000v3 no wifi back to stock


some days ago I flashed my netgear wnr1000v3 with LEDE 17.01.02. Unfortunately I recogniced after flashing, that wifi is not supported with that image. So I tried to flash the stock firmware of netgear (WNR1000v3-V1.0.2.72_60.0.96.chk) but here the nightmare starts:

  • scp the fw file WNR1000v3-V1.0.2.72_60.0.96.chk to /tmp did not work, either the connection dropped or with -b 16 the file could be transfered but the wnr1000v3 rebooted, so I was not able flash this fw
  • nc did also not work, the wnr1000v3 rebooted also; no flashing possible
  • webgui did also not work => reboot of the device

it looks like that there is some problem in the 17.01.02 image for wnr1000v3 when transfering files greater 3 MB to the device.

I tried also the tftp2 from netgear, without success.

Then I saw this thread
LEDE 17.01.02 on WN2500RP-V1 no wifi
and the nmrpflash tool. Finally it worked (no success with ubuntu, no success with win10), at least on an old machbook with osx 10.7.5 (but, I had to increase the timeout to 5000ms to get it work):

sudo ./nmrpflash -v -i en0 -f WNR1000v3-V1.0.2.72_60.0.96/WNR1000v3-V1.0.2.72_60.0.96.chk -t 5000

Adding to interface en0.
Advertising NMRP server on en0 ... |
Received configuration request from 2c:b0:5d:26:1d:c0.
Sending configuration:, netmask
delete: cannot locate
Received upload request without filename.
Using remote filename 'WNR1000v3-V1.0.2.72_60.0.96.chk'.
Uploading WNR1000v3-V1.0.2.72_60.0.96.chk ... OK
Waiting for remote to respond.
Received keep-alive request.
Received keep-alive request.
Received keep-alive request.
Remote finished. Closing connection.
Reboot your device now. ( deleted

Maybe someone else could use this information.

1 Like

Hey just passing by to say thank you for this useful tool ! I bricked my WNR1000 v3 last summer and thought it was dead. Glad I kept it and found this thread.

Thanks again

1 Like