WNDR4700 USB help

Hello, I'm a veteran DD-WRT user and a noob to OpenWrt. I recently got it installed on the Netgear WNDR4700 but I'm having issues getting it to recognize any USB drives plugged in. I got it to recognize the sata disk as sda1 and an sd card as /overlay so that I'm able to install more packages. lsusb returns the following lines but no drives attached.
Bus 001 Device 002: ID 05e3:0723 Generic USB Storage
Bus 001 Device 001: ID 1d6b:0002 Linux 5.4.188 dwc2_hsotg DWC OTG Controller
I have read through and installed any missing packages mentioned in the following so I'm not sure what I'm missing here.

what is the output of:

ls /dev/sd*

/dev/sda /dev/sda1 /dev/sdb /dev/sdb1

looks like your drive is there...

did you setup mounts for them? What specifically did you do and what exactly is the problem?

That is my sata drive as sda1 and my sd card as sda2. Nothing shows up for usb drives. If I go to create a new mount point anything plugged in via usb does not show up.

you have sda and sdb -- I assume you meant that the SATA drive is sda and the sd card is sdb?

Meanwhile, did you install the usb kmods?

Also this device has USB3 ports and the USB3 package was already installed.

meaning you installed it?

What packages did you install?

Those are the mount points... I'll ask again: what packages did you install?

did you install the proper file system support? Have you verified that the USB ports are working properly?

I installed all the common fs support other than hfs+ & zfs if they are even available. The USB ports worked OK with stock. Should I try something other than USB3 even though this has USB3 ports?

Also the thumb drive I have plugged in is formatted to ext4 just like the internal and sd.

try the usb2 packages.

kmod-usb-core - 5.4.188-1
kmod-usb-ehci - 5.4.188-1
kmod-usb-ohci - 5.4.188-1
kmod-usb-storage - 5.4.188-1
kmod-usb2 - 5.4.188-1

ohci was the only missing package. It is installed and rebooted but I still have nothing.

Tried multiple flash drives in both ports and lsusb still looks the same.

I may have solved that issue but not sure. I was told this unit was fully functional when donated to me but when I plug a USB drive with an LED into it I'm not even getting power.

You can try connecting a powered USB hub between the USB on the router and your usb sticks. that would at least provide power (although if the rest of the USB functionality is toast, that won't work either).