WNDR3800 not connecting to upstream BGW210

I'm trying to use a Netgear WNDR3800 router in router mode downstream of my AT&T-issued Arris BGW210. Before flashing the WNDR3800 with OpenWrt, I tested this setup with the stock firmware and it worked: BGW210 LAN to WNDR3800 WAN, then WNDR3800 LAN to my desktop ethernet (haven't tried setting up Wifi yet).

After flashing OpenWrt, I can see that the flash was successful - the web interface is there, I can ssh into the router, etc. - but the WNDR3800 is no longer shown as a connected device in the BGW210's list of connected devices. I've tried following the OpenWrt guide to troubleshooting internet connectivity and setting up a router as a router and as a dumb AP and haven't had any luck.

Here are my network and firewall config files. What am I doing wrong?

/etc/config/network:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdee:4ee1:0bba::/48'

config interface 'wan'
        option device 'eth1'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth1'
        option proto 'dhcpv6'
        option peerdns '0'
        option delegate '0'
        option reqaddress 'try'
        option reqprefix 'no'
        list dns '1.1.1.3'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config device
        option name 'eth0'
        option macaddr '2a:c6:8e:c5:fc:9b'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option ip6ifaceid '::1'
        option ip6assign '60'
        list dns '1.1.1.3'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'
        option blinkrate '2'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5'

config switch_port
        option device 'switch0'
        option port '1'
        option led '6'

config switch_port
        option device 'switch0'
        option port '2'
        option led '9'

config switch_port
        option device 'switch0'
        option port '5'
        option led '2'

/etc/config/firewall:

config defaults
        option syn_flood        1
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config zone
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

config forwarding
        option src              lan
        option dest             wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
        option name             Allow-DHCP-Renew
        option src              wan
        option proto            udp
        option dest_port        68
        option target           ACCEPT
        option family           ipv4

# Allow IPv4 ping
config rule
        option name             Allow-Ping
        option src              wan
        option proto            icmp
        option icmp_type        echo-request
        option family           ipv4
        option target           ACCEPT

config rule
        option name             Allow-IGMP
        option src              wan
        option proto            igmp
        option family           ipv4
        option target           ACCEPT

# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
        option name             Allow-DHCPv6
        option src              wan
        option proto            udp
        option dest_port        546
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-MLD
        option src              wan
        option proto            icmp
        option src_ip           fe80::/10
        list icmp_type          '130/0'
        list icmp_type          '131/0'
        list icmp_type          '132/0'
        list icmp_type          '143/0'
        option family           ipv6
        option target           ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Input
        option src              wan
        option proto    icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        list icmp_type          router-solicitation
        list icmp_type          neighbour-solicitation
        list icmp_type          router-advertisement
        list icmp_type          neighbour-advertisement
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Forward
        option src              wan
        option dest             *
        option proto            icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-IPSec-ESP
        option src              wan
        option dest             lan
        option proto            esp
        option target           ACCEPT

config rule
        option name             Allow-ISAKMP
        option src              wan
        option dest             lan
        option dest_port        500
        option proto            udp
        option target           ACCEPT

Have you scanned for the upstream AP and connected to it?

It does not make much sense to add a DNS with an IPv4 address to an IPv6 interface:

The DNS option signals the DNS available on a interface (not the DNS that should be used by the devices on a interface); it does not belong in here:

According to NETGEAR WNDR3800, your device does not have an eth1, you have to configure the switch properly: ports 0-3 are LAN, port 4 is WAN, and port 5 is CPU on eth0.

Since you do not seem to have done any major changes, I would revert OpenWrt to the default settings, change the LAN IP address, and try again before changing anything else.

1 Like

Alright, after a factory reset and changing nothing but the LAN address, my config is below. The downstream router still doesn't show up as a connected device in the BGW210's web interface.

Regarding this:

The linked page says:

β€œPort 4” are connected to CPU's eth1 and usually it should not be used in your configuration.

Doesn't that imply that there is an eth1 interface? And does the part about not using it in your configuration apply to this case, where I'm not setting up a VLAN, given that that section is talking about how to set up a VLAN?

EDIT: I see now, looking through the network config, that there are some options enabled that look like a VLAN is configured. I'm not sure why that would be necessary though if the router is on its own subnet, since from what I've read a VLAN is just another way to partition off part of a network.

Current config is below.

network:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdd5:3122:5bc5::/48'

config interface 'wan'
        option device 'eth1'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth1'
        option proto 'dhcpv6'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config device
        option name 'eth0'
        option macaddr '2a:c6:8e:c5:fc:9b'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'
        option blinkrate '2'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5'

config switch_port
        option device 'switch0'
        option port '1'
        option led '6'

config switch_port
        option device 'switch0'
        option port '2'
        option led '9'

config switch_port
        option device 'switch0'
        option port '5'
        option led '2'

firewall:

config defaults
        option syn_flood        1
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config zone
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

config forwarding
        option src              lan
        option dest             wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
        option name             Allow-DHCP-Renew
        option src              wan
        option proto            udp
        option dest_port        68
        option target           ACCEPT
        option family           ipv4

# Allow IPv4 ping
config rule
        option name             Allow-Ping
        option src              wan
        option proto            icmp
        option icmp_type        echo-request
        option family           ipv4
        option target           ACCEPT

config rule
        option name             Allow-IGMP
        option src              wan
        option proto            igmp
        option family           ipv4
        option target           ACCEPT

# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
        option name             Allow-DHCPv6
        option src              wan
        option proto            udp
        option dest_port        546
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-MLD
        option src              wan
        option proto            icmp
        option src_ip           fe80::/10
        list icmp_type          '130/0'
        list icmp_type          '131/0'
        list icmp_type          '132/0'
        list icmp_type          '143/0'
        option family           ipv6
        option target           ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Input
        option src              wan
        option proto    icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        list icmp_type          router-solicitation
        list icmp_type          neighbour-solicitation
        list icmp_type          router-advertisement
        list icmp_type          neighbour-advertisement
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Forward
        option src              wan
        option dest             *
        option proto            icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-IPSec-ESP
        option src              wan
        option dest             lan
        option proto            esp
        option target           ACCEPT
 
config rule
        option name             Allow-ISAKMP
        option src              wan
        option dest             lan
        option dest_port        500
        option proto            udp
        option target           ACCEPT

No, how would I do that? I would have thought that with the WAN interface in DHCP mode it would set up the connection automatically. I did also try (on a previous config before this latest reset) putting the WAN interface in static mode and assigning it an IP address I knew was unused, but that didn't work either.

In that case, I think we should look somewhere else: bad cable, broken ethernet port, ... The default configuration (and the files you shared) should work out if the box.

If the default configuration uses eth1, then I must have interpreted the page wrong.

1 Like

Tried all of that, unfortunately. First I tried with the known good configuration that worked with the stock firmware. After that I tried 2 other ethernet cables and 2 other LAN ports on the BGW210 just to be sure it wasn't a hardware issue and none of those make a difference. These are also cables/ports that are otherwise in use by another device on my network (printer and analog telephone adapter) and when I plug the cable back into the original device, the original device connects to the network again and functions normally.

More info in case it's helpful: the WAN light is blinking orange while (I assume) trying to get an address from the BGW210 router, while the power and LAN 1 lights are solid green.

Output of ifconfig:

br-lan    Link encap:Ethernet  HWaddr 2A:C6:8E:C5:FC:9B  
          inet addr:192.168.2.1  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::28c6:8eff:fec5:fc9b/64 Scope:Link
          inet6 addr: fd09:a57e:1841::1/60 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4151 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4008 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:486840 (475.4 KiB)  TX bytes:857041 (836.9 KiB)

eth0      Link encap:Ethernet  HWaddr 2A:C6:8E:C5:FC:9B  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:16799 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16534 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2142716 (2.0 MiB)  TX bytes:5398878 (5.1 MiB)
          Interrupt:4 

eth1      Link encap:Ethernet  HWaddr 28:C6:8E:C5:FC:9C  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:5 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:2409 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2409 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:186679 (182.3 KiB)  TX bytes:186679 (182.3 KiB)

Output of ip a:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel master br-lan state UP qlen 1000
    link/ether 2a:c6:8e:c5:fc:9b brd ff:ff:ff:ff:ff:ff
3: eth1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN qlen 1000
    link/ether 28:c6:8e:c5:fc:9c brd ff:ff:ff:ff:ff:ff
4: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 28:c6:8e:c5:fc:9d brd ff:ff:ff:ff:ff:ff
5: wlan1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 28:c6:8e:c5:fc:9b brd ff:ff:ff:ff:ff:ff
7: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 2a:c6:8e:c5:fc:9b brd ff:ff:ff:ff:ff:ff
    inet 192.168.2.1/24 brd 192.168.2.255 scope global br-lan
       valid_lft forever preferred_lft forever
    inet6 fd09:a57e:1841::1/60 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::28c6:8eff:fec5:fc9b/64 scope link 
       valid_lft forever preferred_lft forever

Attempt to ping the upstream router:

root@OpenWrt:~# ping 192.168.1.254
PING 192.168.1.254 (192.168.1.254): 56 data bytes
ping: sendto: Network unreachable

I tried toggling the entries shown by ip a via ip link set $interface up. Setting wlan0 and wlan1 up turned on the 2.4 GHz and 5 GHz wifi networks, but setting eth1 up did nothing; ip a still shows that it's down. I also tried adding 192.168.1.254 as the LAN gateway and setting all firewall controls to "allow," still no luck. I reverted my changes to the firewall afterward.

Can you try reflashing the device with the standard OpenWrt 23.05.3 sysupgrade file.

The config file that you said is in its default state still looks a bit odd to me. I'd like to see if this changes after you flash the above file.

Here are the configs with the sysupgrade file flashed. I unchecked the option to keep the current settings when flashing, so these should be the completely unchanged, bare stock config files. The only other information that might be relevant is that I left the LAN and WAN ports connected during the flash/reboot process.

/etc/config/network:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd09:d16c:5e64::/48'

config interface 'wan'
        option device 'eth1'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth1'
        option proto 'dhcpv6'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config device
        option name 'eth0'
        option macaddr '2a:c6:8e:c5:fc:9b'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'
        option blinkrate '2'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5'

config switch_port
        option device 'switch0'
        option port '1'
        option led '6'

config switch_port
        option device 'switch0'
        option port '2'
        option led '9'

config switch_port
        option device 'switch0'
        option port '5'
        option led '2'

/etc/config/firewall:

config defaults
        option syn_flood        1
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config zone
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

config forwarding
        option src              lan
        option dest             wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
        option name             Allow-DHCP-Renew
        option src              wan
        option proto            udp
        option dest_port        68
        option target           ACCEPT
        option family           ipv4

# Allow IPv4 ping
config rule
        option name             Allow-Ping
        option src              wan
        option proto            icmp
        option icmp_type        echo-request
        option family           ipv4
        option target           ACCEPT

config rule
        option name             Allow-IGMP
        option src              wan
        option proto            igmp
        option family           ipv4
        option target           ACCEPT

# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
        option name             Allow-DHCPv6
        option src              wan
        option proto            udp
        option dest_port        546
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-MLD
        option src              wan
        option proto            icmp
        option src_ip           fe80::/10
        list icmp_type          '130/0'
        list icmp_type          '131/0'
        list icmp_type          '132/0'
        list icmp_type          '143/0'
        option family           ipv6
        option target           ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Input
        option src              wan
        option proto    icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        list icmp_type          router-solicitation
        list icmp_type          neighbour-solicitation
        list icmp_type          router-advertisement
        list icmp_type          neighbour-advertisement
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Forward
        option src              wan
        option dest             *
        option proto            icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-IPSec-ESP
        option src              wan
        option dest             lan
        option proto            esp
        option target           ACCEPT

config rule
        option name             Allow-ISAKMP
        option src              wan
        option dest             lan
        option dest_port        500
        option proto            udp
        option target           ACCEPT


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option dest             wan
#       option proto    tcp
#       option target   REJECT

# block a specific mac on wan
#config rule
#       option dest             wan
#       option src_mac  00:11:22:33:44:66
#       option target   REJECT

# block incoming ICMP traffic on a zone
#config rule
#       option src              lan
#       option proto    ICMP
#       option target   DROP

# port redirect port coming in on wan to lan
#config redirect
#       option src                      wan
#       option src_dport        80
#       option dest                     lan
#       option dest_ip          192.168.16.235
#       option dest_port        80
#       option proto            tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#       option src              wan
#       option src_dport        22001
#       option dest             lan
#       option dest_port        22
#       option proto            tcp

### FULL CONFIG SECTIONS
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option src_port 80
#       option dest             wan
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp
#       option target   REJECT

#config redirect
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option src_port         1024
#       option src_dport        80
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp

The commented-out example configs were at the bottom of the firewall file previously too, but I included them this time for completeness.

Thanks for doing that. It appears to be the same, so the default state was as promised. Apologies for the extra effort required there, but it was good to confirm.

The address of the upstream BGW210 is 192.168.1.254, correct? And it is a /24 network? Can you check to see what the DHCP pool range is?

Correct.

Yes, the BGW210's subnet mask is 255.255.255.0

Looks like it's 192.168.1.64-192.168.1.253. I'll attach a screenshot in case I'm misinterpreting anything.
Screenshot_20240413_010817

Ok... so let's try this:

  • On the lan interface

Then...

  • On the wan interface:
    • change the protocol to static IP.
    • Enter an address that is unused from the BGW210's nework and outside the DHCP pool (for example, 192.168.1.10).
    • Enter the subnet mask 255.255.255.0
    • Set the gateway to 192.168.1.254
    • Set the DNS to 192.168.1.254

Done, still no connection. The BGW210 still doesn't recognize the WNDR3800 as being connected. The only change I noticed is that the Nslookup diagnostic now gives a message about not being able to reach a server instead of attempting a lookup on 127.0.0.1 like it did previously, although I would guess that's just from having an entry for the DNS on the WAN. Also, attempting to ping 192.168.1.254 in an ssh session gives no output until Ctrl-C is pressed (at which point it reported 90 packets sent, 100% packet loss) instead of immediately failing with "Network unreachable."

Current network config for reference:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd09:d16c:5e64::/48'

config interface 'wan'
        option device 'eth1'
        option proto 'static'
        option ipaddr '192.168.1.10'
        option netmask '255.255.255.0'
        option gateway '192.168.1.254'
        list dns '192.168.1.254'

config interface 'wan6'
        option device 'eth1'
        option proto 'dhcpv6'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config device
        option name 'eth0'
        option macaddr '2a:c6:8e:c5:fc:9b'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.5.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'
        option blinkrate '2'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5'

config switch_port
        option device 'switch0'
        option port '1'
        option led '6'

config switch_port
        option device 'switch0'
        option port '2'
        option led '9'

config switch_port
        option device 'switch0'
        option port '5'
        option led '2'

That all looks fine.

Also, please verify that you are connecting using one of the BGW210's lan ports (yellow), and that the cable is connected to the WNDR3800's wan port (also yellow).

Does the link light appear on either or both devices?

Yes, I've got the cable connected to the "Ethernet 3" LAN port on the BGW210 and to the WAN port on the WNDR3800. I get link lights on both devices, but they blink on and off. The other link lights on the BGW210's LAN ports flicker, but otherwise stay on.

Does anything change if you use another lan port on the BGW210?

Have you tried another (known good) cable?

No, I just tried it on the Ethernet 1 LAN port (which had a working device plugged in a minute ago) with a different, known good ethernet cable. I'm seeing the same link light blinking pattern as before and the BGW210 still doesn't see the router.

I'd think it was a hardware issue if the BGW210 hadn't recognized the WNDR3800 with the stock firmware before I flashed OpenWrt.

The BGW210 may not 'see' the router in the same way you have been checking, assuming that you're looking at the DHCP lease table. That's because we switched to the wan as static IP (not DHCP).

ssh into the OpenWrt router and then perform these tests:

  • ping 192.168.1.254
  • ping 8.8.8.8
  • ping 64.226.122.113
  • ping openwrt.org

Do any of those succeed?

There are no sent packets on eth1, and the DHCP client should be sending requests; this is not normal.

The BGW210 lists all connected devices in its web interface including those with static IPs, and has a column in one table of these devices that says whether the IP is a DHCP allocation or a static IP.

The ping tests were unsuccessful:

root@OpenWrt:~# ping 192.168.1.254
PING 192.168.1.254 (192.168.1.254): 56 data bytes
^C
--- 192.168.1.254 ping statistics ---
31 packets transmitted, 0 packets received, 100% packet loss
root@OpenWrt:~# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
^C
--- 8.8.8.8 ping statistics ---
20 packets transmitted, 0 packets received, 100% packet loss
root@OpenWrt:~# ping 64.226.122.113
PING 64.226.122.113 (64.226.122.113): 56 data bytes
^C
--- 64.226.122.113 ping statistics ---
16 packets transmitted, 0 packets received, 100% packet loss
root@OpenWrt:~# ping openwrt.org
ping: bad address 'openwrt.org'