WNDR3700v4 No Wireless

I have used my wndr3700v4 for years, but just decided to install a new snapshot build of the firmware. I preserved my settings on installation but when I rebooted it I couldn't see the wireless devices as none of them exist anymore. I suspect it might be a kernel module issue or similar.

I have tried rebooting the router. I have tried unplugging the router and plugging it in again. I have tried deleting /etc/config/wireless and doing "wifi config", but nothing shows any networking devices. To be clear "wifi config" gives me an empty file.

Any thoughts on next steps? I realise this hardware is pretty old, but it has always worked "ok" to date.

Thanks,
Michael

Hi, this might be relevant...

https://forum.openwrt.org/t/updating-wndr3700v4-from-v17-lede/185510

You absolutely have to reset configuration moving to ath79 architecture between 19.07.0 and 19.7.latest

1 Like

To be clear I was on a snapshot from about 2 years ago, but it was already ath79.

Anyway I instructed the router to reset to defaults to wipe the whole config, but now, very strangely I can't even get a DHCP connection over ethernet with it. Perhaps there is a bit of a mess with my snapshot compilation, sort of hard to say!

Set static address in 192.168.1.1 network and install release sysyupgrade image
https://firmware-selector.openwrt.org/?version=23.05.3&target=ath79%2Fnand&id=netgear_wndr3700-v4

i.e copy bin file to /tmp, then sysupgrade -n /tmp/file.bin

Setting a static IP was the first thing I had tried, bit of a puzzle, but I am going to try again. I know the networking over ethernet was working before I did a factory reset.

Still no joy of any kind, did a factory reset using a pin in the reset button, but nothing. Looks like it is time to resort to tftp to upload replacement firmware, or something similar.

Only you know how you broke your release.

https://openwrt.org/docs/guide-user/troubleshooting/failsafe_and_factory_reset#entering_failsafe_mode

Well I compiled it, but the result definitely has me baffled!

Install standard 23.05.3 image.