WNDR3700v1 wifi radios not detected


#1

After installing lede-17.01.1-ar71xx-generic-wndr3700-squashfs-factory.img on my WNDR3700v1 I noticed the wireless menu was missing. I tried to return the router to stock and received the same issue - no radios. I then flashed to LEDE again and ran into the same issue yet again. Does anyone have insight on what the router issue may be? Thanks


#2

Your ART (Atheros Radio Test) partition might have been corrupted. While this data is device-specific, you could try re-flashing it, then see if your radios work again. Do back up your ART partition first though, in case it makes no difference, then you can restore your original ART data.

I have a backup from a WNDR3700 v1 ART partition on my website. You will, however, need a LEDE (or OpenWrt) build that allows you to write to the ART partition, which is write-protected under normal circumstances. I have an (old) patch to create such an OpenWrt/LEDE build at the same link (but it has been a few years since I tried it). See the README at the same URL as well.

Good luck.


#3

My community build's download directory contains a also a ready compiled cc15.05 build that has art unlocked. That could be used to write art with mtd.


See the directory "art partition binary contents".


#4

@hnyman to the rescue once more :smiley:


#5

@Borromini @hnyman
Thanks everyone. I plan to take a crack at this today. I'll keep you posted with the results.


#6

Awesome news everyone. Everything worked perfectly. Thank you so much for saving my router!