WNDR3700 running 21.02.3 - LuCi not showing VLAN tagging on WAN

Hello,
i've a WNDR3700 running 21.02.3 and the switch page is not showing the possibility to VLAN tagging the WAN port.

Normally i do

config switch_vlan
        option device 'switch0'
        option ports '5t 0t'
        option vlan '835'

but for whatever reason LuCi is tagging LAN4.
This might be ok given this picture


[OpenWrt Wiki] NETGEAR WNDR3700 and WNDR37AV

were port 0 is LAN 4 and eth0 is port 5 but then how do i tag the WAN?

This unit has a dedicated WAN device not attached to the switch. To do VLANs on it, simply refer to eth1.X where X denotes the VID. Netifd will take care of auto-creating the eth1.X VLAN device.

Example:

config interface wan
  option proto dhcp
  option device eth1.7

config device
  option type bridge
  option name br-iptv
  list ports eth1.835
  list ports eth0.835

config interface iptv
  option proto none
  option device br-iptv
2 Likes

In LuCI go to Network Interfaces and edit the WAN, pull down the device box where it now has eth1 and type in eth1.835<enter> at the bottom. Be sure to press the Enter key if you just click out of the field it will not be saved.

1 Like

i did that thinking it won't work but i have yet to test it.
Is that sufficient?
Can i remove from "switch" page the VLAN then?

If you intent to terminate WAN VLAN 835 on the router itself then yes, you can remove it from the switch settings.

The WAN port does not go through the switch on this model. It has a direct link to the CPU bypassing the switch. Whatever is set in the switch can only affect the LAN ports.

my ISP is asking for 835 VLAN tagged on WAN port

config interface 'wan'
        option proto 'pppoe'
        option ipv6 'auto'
        option username 'xxxx'
        option password 'xxxx'
        option device 'eth1.835'

is this sufficient for navigating or do i have to somehow bridge eth0 on it?

This is sufficient.

No you would not want to do that. eth0 is the LAN side and it needs to be routed to the Internet, not bridged.

This is my current configuration but i honestly do not understand the last 4 entries (switch_vlan + 3x switch_port)

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdfc:36a9:0f6c::/48'

config interface 'wan'
        option proto 'pppoe'
        option ipv6 'auto'
        option username 'xxxx'
        option password 'xxxx'
        option device 'eth1.835'

config interface 'wan6'
        option device 'eth1'
        option proto 'dhcpv6'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config device
        option name 'eth0'
        option macaddr 'e2:91:f5:a6:71:fb'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'
        option blinkrate '2'
        option enable_vlan4k '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '5 3 2 1 0'

config switch_port
        option device 'switch0'
        option port '1'
        option led '6'

config switch_port
        option device 'switch0'
        option port '2'
        option led '9'

config switch_port
        option device 'switch0'
        option port '5'
        option led '2'

the first switch_vlan is ok, i've already seen a lot of devices like this, but what about the others? are they there for LEDs?

Those last four entries basically initialize the builtin switch to its default state; bridging all four lan ports together (instead of having them isolated), and forward them as untagged default vlan 1 to the CPU eth0 port.

The switch_port sections set up the internal switch port to LED number mapping.

1 Like

Thank you, the WAN is established and im up and running with the latest openwrt