Wndr3700: DSA conversion

I have been running few non-DSA builds on this router. It is now time to jump to DSA. I am trying to reconfigure my network in DSA. It is confusing however as I am inexperienced in DSA.

Here is what my network looks like:

		LAN4	LAN3	LAN2	LAN1	WAN	   CPU    INTERFACE
port	0	    1		2		3		4		5           
VLAN1	U        U		U		U		-		U      lan
VLAN11	T       T		-		-		-		T      iot
VLAN13	T		T		-		-		-		T      pub

VLAN 1:
        ports: 0 1 2t 3t 5t
VLAN 11:
        ports: 0t 1t 2 3t 5t
VLAN 13:
        ports: 0t 1t 2t 3 5t

After installing 21.02,

/etc/config/network:
config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdc5:b861:c845::/48'

config interface 'wan'
        option device 'eth1'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth1'
        option proto 'dhcpv6'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config device
        option name 'eth0'
        option macaddr 'ad:46:9a:fe:73:a6'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'
        option blinkrate '2'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5'

config switch_port
        option device 'switch0'
        option port '1'
        option led '6'

config switch_port
        option device 'switch0'
        option port '2'
        option led '9'

config switch_port
        option device 'switch0'
        option port '5'
        option led '2'

will the following config meet the aforementioned network?

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fda8:fff8:6b6c::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        list ports 'eth0'  <-- is it needed?

config interface 'lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option device 'br-lan.1'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

config interface 'iot'
        option proto 'static'
        option ipaddr '172.31.11.1'
        option netmask '255.255.255.0'
        option device 'br-lan.11'

config interface 'pub'
        option proto 'static'
        option ipaddr '172.31.13.1'
        option netmask '255.255.255.0'
        option device 'br-lan.13'

config bridge-vlan
        option device 'br-lan'
        option vlan '1'
        list ports 'lan1:u*'
        list ports 'lan2:u*'
        list ports 'lan3:t'
        list ports 'lan4:t'

config bridge-vlan
        option device 'br-lan'
        option vlan '11'
        list ports 'lan3:t'
        list ports 'lan4:t'

config bridge-vlan
        option device 'br-lan'
        option vlan '13'
        list ports 'lan3:t'
        list ports 'lan4:t'

Thanks

It is not quite clear what device you're talking about, as there are at least 5 different hardware revisions to this day.
v1, v2, v4 would be ath79
v3 an unsupported Broadcom variant
and v5 mt7621

Of this lot, only the v5 (mt7621) has moved to DSA in 21.02 - and PRs to add DSA in the future would only apply to v4 (yet).

I assume it's the device and version the OP listed in their profile...

Devices in use with OpenWrt: wndr3700v1, R6300v2

I don't really like guessing or assuming…

But in that case (WNDR3700 v1), neither 21.02.x nor master have DSA support yet - and the pending PR#4622 doesn't cover AR7161 either (RTL8366SR will be yet another can of worms as well).

tl;dr: Sorry, no DSA for you anytime soon.

1 Like

That's fine...have the OP confirm.

I just mentioned what I saw.

Thank you. And sorry for my ignorance, it's v1.

In any event, is the dsa config I posted good for the network setup. I may need to do it for my netgear R6300v3.

btw, is R6300v3 dsa ready ?

J

I assume you're talking about the bcm53xx based R6300v2?
In that case (I'm not really following bcm53xx development - and its wireless is more or less unsupported anyways), the answer would be 'no' for 21.02.x and 'yes' for current master.

Yes, it's the bcm53xx.
Thanks again. I will check out a snapshot build.

I believe the wndr3700v1 and wndr3800 share a base DTSI. Id be interested to hear if your wifi LEDs are correct.

I have a feeling that the wndr3800 ones are reversed and it may need to be redefined in its DTS but I’ve not heard from anyone else complaining.

They are right, but sometimes (rarely) wifi phy0 and phy1 get detected/assigned mixed at boot, which then causes also LEDs to be mixed.

I noticed that already when I initially added ath79 WiFi support for wndr3800
I mentioned that in

1 Like

Thanks. I must have been unlucky.
Is there a way to detect and fix that elegantly? I can think of a few using uci-defaults scripts

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.