WNDR 3700v4 bricked, HELP

So i build current firmware as always and after flashing it took too much time. After about 15-20 minutes i turned off router. Power button is flashin each second. Lan leds are on when connected to PC but router never turns on. I tried to power off and enter failsafe mode when turning on pressing and holding reset button, but it just flashes all leds when i release reset button and does not start flashing power led frequently. What can i do to recover it? I have flashed it 10s of times like this and this has never happened before :frowning:

I connected via UART cable and this is output. Last line "Upgrade Mode" flashes. I guess i have to upload firmware through tftp from my laptop. I'll try that.

find_hif: bootstrap = 0xaf055a
WASP BootROM Ver. 1.1
Nand Flash init
ONFI: Control setting = 0xb44
hdr: [0xbd004000 : 0xbd004000 : 0x3000 : 0xc200e86c]
nand_load_fw: read 6 pages
nand_load_fw: 0x10000 0x800 0xbd0047f0
nand_load_fw: 0x20000 0x800 0xbd004ff0
nand_load_fw: 0x30000 0x800 0xbd0057f0
nand_load_fw: 0x40000 0x800 0xbd005ff0
nand_load_fw: 0x50000 0x800 0xbd0067f0
f/w 0 read complete, jumping to 0xbd004000
initialize PLL & DDR

Wasp 1.2
Wasp (32bit) ddr2 init
setting for 40
fw1: Nand Init
leave FW1
f/w 0 execution complete
hdr: [0xa0100000 : 0xa0100000 : 0x11000 : 0x45d0eb56]
nand_load_fw: read 34 pages
nand_load_fw: 0x70000 0x800 0xa01007f0
nand_load_fw: 0x80000 0x800 0xa0100ff0
nand_load_fw: 0x90000 0x800 0xa01017f0
nand_load_fw: 0xa0000 0x800 0xa0101ff0
nand_load_fw: 0xb0000 0x800 0xa01027f0
nand_load_fw: 0xc0000 0x800 0xa0102ff0
nand_load_fw: 0xd0000 0x800 0xa01037f0
nand_load_fw: 0xe0000 0x800 0xa0103ff0
nand_load_fw: 0xf0000 0x800 0xa01047f0
nand_load_fw: 0x100000 0x800 0xa0104ff0
nand_load_fw: 0x110000 0x800 0xa01057f0
nand_load_fw: 0x120000 0x800 0xa0105ff0
nand_load_fw: 0x130000 0x800 0xa01067f0
nand_load_fw: 0x140000 0x800 0xa0106ff0
nand_load_fw: 0x150000 0x800 0xa01077f0
nand_load_fw: 0x160000 0x800 0xa0107ff0
nand_load_fw: 0x170000 0x800 0xa01087f0
nand_load_fw: 0x180000 0x800 0xa0108ff0
nand_load_fw: 0x190000 0x800 0xa01097f0
nand_load_fw: 0x1a0000 0x800 0xa0109ff0
nand_load_fw: 0x1b0000 0x800 0xa010a7f0
nand_load_fw: 0x1c0000 0x800 0xa010aff0
nand_load_fw: 0x1d0000 0x800 0xa010b7f0
nand_load_fw: 0x1e0000 0x800 0xa010bff0
nand_load_fw: 0x1f0000 0x800 0xa010c7f0
nand_load_fw: 0x200000 0x800 0xa010cff0
nand_load_fw: 0x210000 0x800 0xa010d7f0
nand_load_fw: 0x220000 0x800 0xa010dff0
nand_load_fw: 0x230000 0x800 0xa010e7f0
nand_load_fw: 0x240000 0x800 0xa010eff0
nand_load_fw: 0x250000 0x800 0xa010f7f0
nand_load_fw: 0x260000 0x800 0xa010fff0
nand_load_fw: 0x270000 0x800 0xa01107f0
f/w 1 read complete, jumping to 0xa0100000

U-Boot 1.1.4 (Jun 21 2012 - 11:09:33)

DNI HW ID: 29763948 flash 128MB RAM 128MB U-boot dni29 V1.8

DRAM:  128 MB
Atheros on-chip NAND FLash Controller Driver, Version 0.1 (c) 2010 Atheros Communications, Ltd.
Ath Nand ID[87ff0178]: 2c:f1:80:95:02
Micron NAND 128MiB 3,3V 8-bit [128MB]
====== NAND Parameters ======
sc = 0x87ff0158 bbt = 0x87f68008 bbt_size = 0x100 nf_ctrl = 0x344
page = 0x800 block = 0x20000 oob = 0x40
size = 128MB
Setting 0xb8116290 to 0x48902d0f
Using default environment

In:    serial
Out:   serial
Err:   serial
Net:   ag934x_enet_initialize...
 4096 bytes read: OK
Fetching MAC Address from 0x87fe7928
 wasp  reset mask:c02300
WASP  ----> S17 PHY *
: cfg1 0x80000000 cfg2 0x7114
eth0: 28:c6:8e:b3:9b:2a
athrs17_reg_init: complete
eth0 up
Hit any key to stop autoboot:  0
eth0 link down

 Client starts...[Listening] for ADVERTISE...TTT
Retry count exceeded; boot the image as usual

 nmrp server is stopped or failed !

Loading from device 0: ath-nand (offset 0x6c0000)

** Bad partition size, kernel: 0x400000, rootfs: 0xffffffff **
eth0 link down

The Router is in TFTP Server Firmware Recovery mode NOW!
Listening on Port : 69, IP Address:
Upgrade Mode

Try using factory image or OEM image to recover

you mean netgear_wndr3700-v4-squashfs-factory.img right?

factory image worked. Then i again flashed my built firmware with sysupgrade command from /tmp and this time it worked. I do not know why it bricked. Now i have to restore all configs. I backed up configs and restore option does not work :frowning:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.