WMM problem with Globe smart bulbs limited to linksys?

My GF bought some cheap Globe smart bulbs, but couldn't get them to work. She, of course, did everything right, but couldn't connect to the fancy wrt3200 I bought her. After enough digging I found I could disable WMM for now and make it work. It looks like the best solution is to enable WMM again, but make a separate WMM disabled SSID for these devices?

It seems only this family of routers has issues where WMM is incompatible with these IoT devices? And I assume this bug lies in the binary firmware blob, so only the vendor can fix it - and since it has been an issue for years it is unlikely to ever be fixed at this point?

If it isn't an OpenWrt issue I can potentially sell this router and buy a mt76 based one for her instead?

You could try: the WMM flag is per interface, so your idea should be easily put to the test.

Are you sure?

It seems that the manufacturer knows about this issue with their bulbs - and it's not as isolated to your specific models as you believe. It's also interesting that the manufacturer attributes this to their device, not to any known issues:

This is a known issue between the chips used by many IoT devices (ESP8266) and the drivers in that particular router. And you have found the only known "solution".

Please, see here for more info: https://github.com/kaloz/mwlwifi/issues/278


Personally I have lifx bulbs and they work fine with my mt76 router with wmm enabled and openwrt.

My gf has cheap globe bulbs and a wrt3200 I setup for her that don't talk unless I disable wmm. One day I'll try switching routers and we can confirm the problem. I was hoping somebody already did this and would chime in.

But searching these forums I see a ton of complaints about wmm incompatibilities, and the common thread is the wrt routers.

I traded routers with my gf because after I disabled wmm her son reported connection issues in his bedroom (furthest from the router in her house).

My mt76 Netgear 6220 works just fine with her cheap globe bulbs. The wrt3200 is now at my place with wmm re-enabled. My more expensive LIFX bulbs don't expose the wmm bug, so I can re-enable it.

If somebody has issues connecting cheap bulbs to their expensive router they can either make a second SSID (I didn't try, but it is the common recommendation), buy LIFX bulbs instead, or switch to a router running the mt76 driver.

1 Like

I was recently told there is a new 3.5 firmware for my lifx lightbulbs (we live in a word world) that has "WiFi onboarding & connectivity improvements." I couldn't download with my wrt3200acm, presumably due to the bug mentioned earlier.
However I ended up trading it for an original wrt1900ac and the bulbs connected and downloaded just fine. I guess the wmm bug is limited wrt3200acm, not all Linksys.

I ended up getting a cheap c7 for now as I just need reliable wifi to fall back on.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.