Can anyone help me figure out the problem I am having with my wireless interface? No wireless devices can get a page loaded when i turn WMM mode on despite being served an ip and connecting to wifi. Once i turn off WMM they can. It's really odd but I don't want to be limited to 802.11a/802.11g speeds with it off and its driving me nuts. Much appreciated.
Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </>
" button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:
ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
root@asus:~# ubus call system board
{
"kernel": "5.15.162",
"hostname": "asus",
"system": "ARMv7 Processor rev 0 (v7l)",
"model": "ASUS RT-AC3100",
"board_name": "asus,rt-ac3100",
"rootfs_type": "squashfs",
"release": {
"distribution": "OpenWrt",
"version": "23.05.4",
"revision": "r24012-d8dd03c46f",
"target": "bcm53xx/generic",
"description": "OpenWrt 23.05.4 r24012-d8dd03c46f"
}
}
root@asus:~# cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd4c:0d0c:e2b2::/48'
config device
option name 'br-lan'
option type 'bridge'
option ipv6 '0'
list ports 'eth0'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
option mtu '1500'
option macaddr '2C:56:DC:54:C4:21'
option txqueuelen '10000'
option igmp_snooping '1'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ip6assign '60'
list dns '1.1.1.1'
list dns '8.8.8.8'
option gateway '192.168.1.22'
list ipaddr '192.168.12.1/24'
config device
option name 'wan'
option macaddr '2C:56:DC:54:c4:20'
option acceptlocal '1'
option ipv6 '0'
config interface 'wan'
option device 'wan'
option proto 'static'
option gateway '192.168.1.1'
option type 'bridge'
option mtu '9000'
list ipaddr '192.168.1.22/24'
list dns '8.8.8.8'
list dns '1.1.1.1'
config interface 'wan6'
option device 'wan'
option proto 'dhcpv6'
option reqaddress 'try'
option reqprefix 'auto'
config device
option name 'wlan0'
option ipv6 '0'
option macaddr '2C:56:DC:54:C4:21'
config device
option name 'phy1-ap0'
option macaddr '2C:56:DC:54:C4:21'
option ipv6 '0'
config device
option name 'eth0'
option ipv6 '0'
root@asus:~# cat /etc/config/wireless
config wifi-device 'radio0'
option type 'mac80211'
option path '18000000.axi/bcma0:7/pci0000:00/0000:00:00.0/0000:01:00.0'
option channel '11'
option band '2g'
option htmode 'HT40'
option cell_density '0'
option legacy_rates '1'
option disabled '0'
config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'Raze_2G'
option encryption 'psk2+ccmp'
option macaddr 'random'
option skip_inactivity_poll '1'
option key 'Choostik1552!'
option disabled '1'
option multicast_to_unicast '0'
config wifi-device 'radio1'
option type 'mac80211'
option path '18000000.axi/bcma0:8/pci0001:00/0001:00:00.0/0001:01:00.0'
option channel '100'
option band '5g'
option cell_density '0'
option htmode 'VHT80'
option noscan '1'
option rts '2347'
option frag '2346'
option country 'US'
config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'Raze_5G'
option encryption 'psk2+ccmp'
option key 'Choostik1552!'
option disassoc_low_ack '0'
option dtim_period '2'
option wpa_group_rekey '86400'
option disabled '0'
option ieee80211w '0'
option wmm '0'
root@asus:~# cat /etc/config/dhcp
config dnsmasq
option domainneeded '1'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option localservice '1'
option dnssec '1'
option ednspacket_max '1232'
option filter_aaaa '1'
list server '1.1.1.1'
list server '8.8.8.8'
option rapidcommit '1'
option dhcpleasemax '20'
option dnsforwardmax '100'
option min_cache_ttl '65'
list interface 'lan'
list notinterface 'loopback'
config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv4 'server'
option force '1'
option master '1'
config dhcp 'wan'
option interface 'wan'
option ignore '1'
option start '100'
option limit '150'
option leasetime '12h'
config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'
config host
option name 'Raze'
option ip '192.168.12.226'
option mac '3C:22:FB:19:E9:D5'
config domain
option name 'OpenWrt'
option ip '192.168.1.1'
config host
option name 'OpenWrt'
list mac '2C:56:DC:54:C4:20'
list mac 'F8:5E:3C:16:10:EE'
root@asus:~# cat /etc/config/firewall
config defaults
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option synflood_protect '1'
option flow_offloading '1'
option drop_invalid '1'
config zone
option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
list network 'lan'
config zone
option name 'wan'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
list network 'wan'
list network 'wan6'
config forwarding
option src 'lan'
option dest 'wan'
config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'
config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-IPSec-ESP'
option src 'wan'
option dest 'lan'
option proto 'esp'
option target 'ACCEPT'
config rule
option name 'Allow-ISAKMP'
option src 'wan'
option dest 'lan'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT'
config redirect
option dest 'lan'
option target 'DNAT'
option name '443'
option src 'wan'
option src_dport '443'
option dest_ip '192.168.12.1'
option dest_port '443'
config redirect
option dest 'lan'
option target 'DNAT'
option src 'wan'
option src_dport '80'
option dest_ip '192.168.12.1'
option dest_port '80'
config rule
option src 'wan'
option dest 'lan'
option target 'ACCEPT'
option family 'ipv4'
list proto 'all'
list src_ip '192.168.1.22'
list dest_ip '192.168.12.1'
config rule
option src 'lan'
list src_ip '192.168.12.1'
option src_port '443'
option dest 'wan'
list dest_ip '192.168.1.22'
option dest_port '80 443'
option target 'ACCEPT'
config zone
option name 'wg'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
config forwarding
option src 'lan'
option dest 'wg'
config zone
option name 'vpn'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
list network 'vpn'
config forwarding
option src 'lan'
option dest 'vpn'
config rule
option src 'lan'
list src_ip '192.168.12.117'
option dest 'lan'
list dest_ip '192.168.12.1'
option target 'ACCEPT'
config redirect
option dest 'lan'
option target 'DNAT'
option family 'ipv4'
list proto 'all'
option src 'wan'
option dest_ip '192.168.12.1'
config rule
list proto 'udp'
option src 'wan'
option src_port '67-68'
option dest_port '67-68'
option target 'ACCEPT'
Remove this line and reboot the router:
option mtu '9000'
Did it but still no go
Did it work before ?
There is way too much overcustomisation done in your config.
Remove all useless-to-problematic parameters:
Make this default 1000 or zero
HT20
Both out, and add country code to 2.4GHz
All three out
These 3 out too
Firewall and dhcp look sane as in close to defaults.
No it never worked before. Even when it’s bone stock once WMM goes on it never works. I’m thinking it’s just a Broadcom chipset issue with openwrt and my router at this point
it is, and it'll never improve as long as you keep using Openwrt.
Due to its closed source drivers Broadcom is not well supported on OpenWRT.
You are using the Opensource drivers but not many people having Broadcom routers use OpenWRT.
I have/administer a lot of Broadcom routers and had better luck with another third party firmware
The 2.4 isnt running and hasn’t been running. I removed the options but it’s still not working. It’s only the wireless devices that connect, get served an ip, but never load a webpage it begins the process but never moves then fails. My laptop connects to the wireless and works fine. One thing I did notice that seems odd is the tx/rx rates are astronomical for one device, let’s say my laptop, and around what I would expect for the wireless ones. I don’t know what to make of that but with WMM off everyone on The wireless is more or less getting the same treatment in terms of tx/rx rates when associated with the wireless. I connected via wire from my laptop to check whether it being on wireless was the problem but nope, the first device that connects gets those astronomical rates but even with those rates that wireless device didn’t load the page
Yea it makes sense because I would have WMM on with DD-WRT and it was smooth sailing
What if I extract blobs and pcie files from a asus firmware and place them in the system files within openwrt?
What do you get from logs enabling one single AP with generic settings (i.e country set, and only set network lan, ap name and security key)?
You can download other set of non-distributable blobs from AOSP
Assuming they're forward compatible with the kernel your openwrt device is using.
At least they work with a rendition of mainline driver unlike blob for blob driver in OEM FW
This is probably unrelated, but the definition of the LAN interface is wrong, I do not understand how can it work at all.
Thu Sep 19 11:13:45 2024 kern.info kernel: [ 10.469226] Broadcom 43xx driver loaded [ Features: PNL ]
Thu Sep 19 11:13:45 2024 kern.info kernel: [ 10.494843] usbcore: registered new interface driver brcmfmac
Thu Sep 19 11:13:45 2024 kern.info kernel: [ 10.500808] pci 0000:00:00.0: enabling device (0140 -> 0142)
Thu Sep 19 11:13:45 2024 kern.info kernel: [ 10.506492] brcmfmac 0000:01:00.0: enabling device (0140 -> 0142)
Thu Sep 19 11:13:45 2024 kern.info kernel: [ 10.657885] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac4366b-pcie for chip BCM4366/3
Thu Sep 19 11:13:45 2024 kern.info kernel: [ 10.666811] pci 0001:00:00.0: enabling device (0140 -> 0142)
Thu Sep 19 11:13:45 2024 kern.info kernel: [ 10.672532] brcmfmac 0001:01:00.0: enabling device (0140 -> 0142)
Thu Sep 19 11:13:45 2024 kern.warn kernel: [ 10.681440] brcmfmac 0000:01:00.0: Direct firmware load for brcm/brcmfmac4366b-pcie.asus,rt-ac3100.bin failed with error -2
Thu Sep 19 11:13:45 2024 kern.info kernel: [ 10.797975] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac4366b-pcie for chip BCM4366/3
Thu Sep 19 11:13:45 2024 kern.warn kernel: [ 10.806933] brcmfmac 0001:01:00.0: Direct firmware load for brcm/brcmfmac4366b-pcie.asus,rt-ac3100.bin failed with error -2
Thu Sep 19 11:13:45 2024 user.info kernel: [ 10.825681] kmodloader: done loading kernel modules from /etc/modules.d/*
Thu Sep 19 11:13:45 2024 kern.warn kernel: [ 10.920747] brcmfmac 0000:01:00.0: Direct firmware load for brcm/brcmfmac4366b-pcie.txt failed with error -2
Thu Sep 19 11:13:45 2024 kern.warn kernel: [ 10.930766] brcmfmac 0001:01:00.0: Direct firmware load for brcm/brcmfmac4366b-pcie.txt failed with error -2
Thu Sep 19 11:13:45 2024 kern.warn kernel: [ 10.941333] brcmfmac 0001:01:00.0: Direct firmware load for brcm/brcmfmac4366b-pcie.clm_blob failed with error -2
Thu Sep 19 11:13:45 2024 kern.warn kernel: [ 10.996009] brcmfmac 0000:01:00.0: Direct firmware load for brcm/brcmfmac4366b-pcie.clm_blob failed with error -2
Thu Sep 19 11:13:45 2024 kern.info kernel: [ 11.280401] brcmfmac: brcmf_c_process_clm_blob: no clm_blob available (err=-2), device may have limited channels available
Thu Sep 19 11:13:45 2024 kern.info kernel: [ 11.292889] brcmfmac: brcmf_c_process_clm_blob: no clm_blob available (err=-2), device may have limited channels available
Those files are not found in the open. Maybe your initial approach extracting them from OEM firmware was correct.