Wlan0, 5g radio trouble on acm3200

Dear Everyone,

My last two builds (a month apart) were not successful for my 5g radio.
with a build with kernel 4.14.78 finally wlan0 (5g radio) comes up. In the sense that it actually starts beaconing.
It takes significantly longer to come up (2 minutes after wlan1 (2g) came up).
Then after a day or so it stops beconing and the light of the radio go out again.
After a reboot, same thing happens over and over again.
With a build of last week, the 5g wlan0 never started beaconing in the first place.
It always shows the same thing, so it looks ok, but it isn't.
I now reverted back to the latest stable release. I was considering buying a new one, because I dont know whether this might be a hardware issue. No further debug output is given, is there a group busy with these Marvell radios that can assist?

[    8.861593] pci 0000:00:01.0: enabling device (0140 -> 0142)
[    8.867376] ieee80211 phy0: priv->pcmd_buf = ddcf0000  priv->pphys_cmd_buf = 1dcf0000
[    8.920762] ieee80211 phy0: fw download start
[    8.920767] ieee80211 phy0: ddr init: download start
[    8.921145] ieee80211 phy0: ddr init: download complete
[    9.059061] ieee80211 phy0: FwSize = 450732 downloaded Size = 450732 curr_iteration 65521
[   11.927313] ieee80211 phy0: fw download complete
[   11.927350] ieee80211 phy0: device node: /soc/pcie/pcie@1,0
[   11.942593] ieee80211 phy0: pcmd = ddcf0000
[   11.960331] ieee80211 phy0: firmware version: 0x9030206
[   12.320318] ieee80211 phy0: firmware region code: 10
[   12.350133] ieee80211 phy0: 2G disabled, 5G enabled
[   12.355053] ieee80211 phy0: 4 TX antennas, 4 RX antennas
[   12.360553] pci 0000:00:02.0: enabling device (0140 -> 0142)
[   12.366365] ieee80211 phy1: priv->pcmd_buf = d98c0000  priv->pphys_cmd_buf = 198c0000
[   12.371341] ieee80211 phy1: fw download start
[   12.371346] ieee80211 phy1: ddr init: download start
[   12.371728] ieee80211 phy1: ddr init: download complete
[   12.512925] ieee80211 phy1: FwSize = 450732 downloaded Size = 450732 curr_iteration 65527
[   13.707317] ieee80211 phy1: fw download complete
[   13.707362] ieee80211 phy1: device node: /soc/pcie/pcie@2,0
[   13.722637] ieee80211 phy1: pcmd = d98c0000
[   13.740330] ieee80211 phy1: firmware version: 0x9030206
[   14.100318] ieee80211 phy1: firmware region code: 10
[   14.124161] ieee80211 phy1: 2G enabled, 5G disabled
[   14.129070] ieee80211 phy1: 4 TX antennas, 4 RX antennas


A group of one, but working OK on a rango for me.

It works ok for you, but not for me, I want to know why.

And that happens also when you use as vanilla wifi configuration as possible? Using a narrow channel outside the DFS channel area...

The symptoms sound like you might be using a DFS channel and some radar gets detected. Radar detection takes time at the wifi initialisation phase, and if some radar is detected, wifi does not get up. And later you can be kicked out from the channel if a radar gets detected.

You might read these:

Thanks for all your responses. I unfor know about dfs etc. However, the main thing is that I didn't move. I'm at exactly the same place as a year ago. So unless the environment changed and we got more activity, it doesn't explain it. I do see issues with newer builds. Issues that I did not see before. With the release version I do not see problems. I didn't use to have problems with snapshots and they did seem to work fine. So to me it seems like a software issue provided it's not a hardware issue. What I'm very much interested in is getting more output from the radio to see what's going on. It seems you're not experiencing issues. Questions, what's the percentage you're seeing in wireless overview of the 5g radio?
I think to be on the safe side i'll buy an additional acm3200 and see how it behaves, if it's the same, it has to be software. So these are my considerations, is there a way to enable some flags so I get more output from the 5g radio? I am talking about the driver.


If you look in the system log you might see something like "missing noise floor" or "DFS channel scan started". That is the scanning in progress.

It's just a legal requirement that the radio scans for other transmissions on the 5GHz DFS spectrum. Setting your region correctly could alleviate some of the problem, but unfortunately it is always going to scan if you are using a channel that is, in your part of the world, designated as DFS. Another thing to do would be to change the channel from "auto" to some known non-DFS channel, such as 36.