WLan-connection is lost after a few seconds

i have openwrt set up as a wifi client (ssid 'o2-WLAN37'). The connection is lost after a few seconds and automatically re-established after another few seconds.
How can I repat this?

System information
Model: Nexx WT3020 (8M)
Architecture: MediaTek MT7620N ver:2 eco:6
Firmware Version: OpenWrt 19.07.7 r11306-c4a6851c72 / LuCI openwrt-19.07 branch git-21.044.30835-34e0d65
Kernel Version: 4.14.221

******* /etc/config/network **************
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd49:ff68:e542::/48'

config interface 'lan'
option type 'bridge'
option ifname 'eth0.1'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'

config device 'lan_eth0_1_dev'
option name 'eth0.1'
option macaddr '20:28:18:a2:9a:3a'

config interface 'wan'
option proto 'dhcp'
option ifname 'eth0.2'

config device 'wan_eth0_2_dev'
option name 'eth0.2'
option macaddr '20:28:18:a2:9a:3b'

config interface 'wan6'
option ifname 'eth0.2'
option proto 'dhcpv6'
option reqaddress 'try'
option reqprefix 'auto'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '4 6t'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '0 6t'

config interface 'wwan'
option proto 'dhcp'

****** /etc/config/wireless ****************
config wifi-device 'radio0'
option type 'mac80211'
option hwmode '11g'
option path 'platform/10180000.wmac'
option htmode 'HT20'
option channel 'auto'

config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'OpenWrt'
option encryption 'none'
option disabled '1'

config wifi-iface 'wifinet1'
option ssid 'FRITZ!Box Fon WLAN 7360'
option device 'radio0'
option mode 'sta'
option key ''
option network 'wwan'
option encryption 'psk2'
option disabled '1'

config wifi-iface 'wifinet2'
option ssid 'o2-WLAN37'
option device 'radio0'
option mode 'sta'
option key ''
option network 'wwan'
option encryption 'psk2'

does anyone have any ideas?