WLAN client does not come up after power on on Raspi 4 & 5

I have connected a Raspi 5 as a client to a WLAN which works fine until I power on the Raspi. After the power on I do not see the Associated Stations which is another router.
It works again after I have restarted the corresponding interface and disabted/enabled the client connection. The same problem occurred with a Raspi 4.
Any ideas?

Let’s review the config to see if we can find the issue.

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless

Here is the ubus answer:

{
        "kernel": "6.6.73",
        "hostname": "myrouter",
        "system": "ARMv8 Processor rev 1",
        "model": "Raspberry Pi 5 Model B Rev 1.1",
        "board_name": "raspberrypi,5-model-b",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "24.10.0",
                "revision": "r28427-6df0e3d02a",
                "target": "bcm27xx/bcm2712",
                "description": "OpenWrt 24.10.0 r28427-6df0e3d02a",
                "builddate": "1738624177"
        }
}

the network configuration

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd21:b956:7720::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.2'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.1.1'
        option nameserver '192.168.1.1'
        list dns '192.168.2.1'

config interface 'wwan'
        option proto 'static'
        option gateway '192.168.2.1'
        list ipaddr '192.168.2.8/24'
        option device 'phy0-sta0'

and the wireless configuration

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/axi/1001100000.mmc/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
        option band '5g'
        option channel '36'
        option htmode 'VHT80'
        option cell_density '0'

config wifi-iface 'wifinet0'
        option device 'radio0'
        option mode 'sta'
        option network 'wwan'
        option ssid 'MagentaWLAN'
        option encryption 'sae-mixed'
        option key 'secretpassword'
        option ocv '0'

By the way: The described problem does not occur on my OpenWRT One (same OpenWRT version), I suspect, it is a Raspi specific.problem

Remove the device line below:

Set the channel to auto:

Don’t use sae-mixed. Select wpa2 or wpa3. Mixed mode doesn’t often work properly. (Change the upstream, too)

Reboot and try again.

1 Like

Thanks Peter,

now the Client connection to the WLAN comes up without manual intervention.
I had realized that the encryption was only on WPA2 level but unfortunately the ISP router is not mine. I will check, if we can switch to WPA3. By the way, that is one reason why I use my own router :slightly_smiling_face:.
The Raspi router is just for testing and backup, the "production" router runs on an OpenWRT One.

Thanks again
Reinhard

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.