Wireless Repeater (5 GHz) on WRT1200AC

my network configuration in repeater mode ( relayd ) :
Mac Addr are fanciful


config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdb4:8fd7:e657::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0 eth0.1 eth0.2'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.1.1'
        option dns '192.168.1.1 8.8.8.8'
        option ipaddr '192.168.2.252'
        option macaddr 'D4:5F:25:EA:F9:96'
        option igmp_snooping '1'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr 'D4:5F:25:EA:F9:94'

config device 'wan_dev'
        option name 'eth0.2'
        option macaddr 'D4:5F:25:EA:F9:95'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0t 1 2 3 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0 6t'
        option vid '2'

config interface 'wwan'
        option proto 'static'
        option netmask '255.255.255.0'
        option gateway '192.168.1.1'
        option dns '192.168.1.1 8.8.8.8'
        option ipaddr '192.168.1.252'

config interface 'stabridge'
        option proto 'relay'
        list network 'lan'
        list network 'wwan'
        option ipaddr '192.168.1.252'


WDS isn't the issue here, all my APs support WDS (works pretty well and as intended on 2.4 GHz).

At least by (incorrectly) setting the channel on the WRT1200AC I got the 5 GHz repeater to work. But it breaks down once the upstream AP does DFS and moves to another frequency, unless I manually adjust the channel on the WRT1200AC every time this happens.

Does your Orange Livebox4 never ever change the channel?

With my Livebox 4 the radio channel is automatic ( 100 ) for use DFS channels

Try setting up a 5 GHz AP on the WRT1200AC and see how it fails as well.

It's been a while since I used wds on my wrt1200, but it did work fine on both 2 & 5ghz. I think @lantis1008 was on the right track, have you tried setting master to one of the lower non-dfs channels (36-48)?

I have modified with AP -> option disabled '0' and run always no problem

--

Only a little bug -> no host IP address

The higher non DFS (149 up) channels don't work on the WRT1200AC (radio stays disabled, no client connection). Channel 36 (the only other non-DFS choice) is too congested and full of noise, AP-AP connection is worse than 2.4 GHz due too low transmit power and the Master AP quickly selects a new less congested channel.

Currently the (broken) configuration with manually setting the channel to 128 on the WRT1200AC at least brought the 5 GHz repeater AP up temporarily (only as long as the Master AP stays on channel 128).

So something in hostapd's or the drivers frequency selection is broken. While LuCI displays Locked to channel 128 used by: Client "..." that "lock" doesn't actually work. It has to read "option channel 128" from /etc/config/wireless file to be able to enable the WDS Slave (repeating) AP on correct channel, if I remove the channel or set it to "auto" it simply ends up with something like this:

hostapd: wlan0-1: DFS-CAC-START freq=5260 chan=52 sec_chan=1, width=1, seg0=58, seg1=0, cac_time=60s
hostapd: wlan0-1: DFS-CAC-COMPLETED success=1 freq=5260 ht_enabled=0 chan_offset=0 chan_width=3 cf1=5290 cf2=0
hostapd: Using interface wlan0-1 with hwaddr ... and ssid "..."
hostapd: wlan0-1: interface state DFS->ENABLED
hostapd: wlan0-1: AP-ENABLED
hostapd: Failed to check if DFS is required; ret=-1
hostapd: Failed to set beacon parameters

DFS on a WDS Slave AP doesn't make any sense anyway, as the Master already controls access to the channel.

On 2.4 GHz option channel "auto" does the correct thing, it enables the 2.4 GHz WDS Slave (repeater) AP on the correct channel: that of the Client communicating to the Master and if the Master changes frequency, the WDS Client moves with it. Somehow this doesn't work at all on 5 GHz.

I'm a little lost on what your current settings are, but it still sounds like you're choosing auto for channel selection and I really think that's where the problem is, setting a non-dfs channel on the gateway router and the same non-dfs channel on the AP should work, as far as I know 128 is a dfs channel.

WRT1200AC doesn't support non-DFS channels (149+).

I’ll ask again, where is your documentation that the device doesn’t support regular channels?
You earlier stated you used channel 36 but it is “too congested”. So perhaps you meant to say:
“ I would like to use DFS channels due to congestion”

The channel option is as far as I know, mandatory (at least in AP mode) which explains why you had so much trouble.

I don’t think you are going to have success in STA+AP mode in the DFS region. The AP doesn’t know to follow what the STA changed to. A static channel upstream (hence, non DFS) will fix this as suggested.

And I still disagree that it doesn’t need to do its own CAC. Show me otherwise.

Setting the channel manually is disadvised on 5 GHz, because it interferes with DFS. It's also not needed on 2.4 GHz, because hostapd automatically selects the channel of the STA. It's just broken on 5 GHz.

Currently it's being fixed by manually adjusting the channel each time the STA needs to go a new channel, because the master changed it. In the long term is going to be fixed by purchasing a closed source wireless repeater, which has 802.11h properly implemented and works on DFS channels. (The WRT1200AC's broken Marvell Wi-Fi is already closed source, so that's not a big loss).

Setting the channel for the AP only governs the starting channel in DFS. If the AP is required to move, it will move.
If you reboot the router or otherwise restart the wifi, it will try to go back to the set channel, and then move again if necessary.

It appears you’re making a lot of assumptions rather incorrectly and basing your next move on those. And it also seems you’re not willing to listen to reason, so this concludes my input to this thread.

I already tested all this and posted the results above.

If the master AP changes channel due to interference/congestion, the STA won't change channel, because its fixed to channel 128 by configuration and it simply loses connection (clients connected to slave AP lose connection, because their WDS uplink is gone). If the slave AP detects interference, it will simply disable itself, because the STA is fixed to channel 128 by configuration and the STA stays connected (now useless for repeating, because clients lose connection to the slave AP).

The AP disabling itself is exactly what happened since I configured it to channel 128, now hostapd spams the log with

Sun Nov 11 14:03:53 2018 daemon.notice hostapd: handle_probe_req: send failed
Sun Nov 11 14:03:53 2018 daemon.notice hostapd: handle_probe_req: send failed
Sun Nov 11 14:03:54 2018 daemon.err hostapd: Failed to set beacon parameters
Sun Nov 11 14:04:00 2018 daemon.err hostapd: Failed to set beacon parameters

It only stayed active for a few hours. With channel "auto" the STA follows the WDS master, but the repeating slave AP will never go on air and stay offline with error messages posted above.

On 2.4 GHz with no channel set (defaults to "auto") everything works as intended, the WDS slave (both STA and AP) follows the WDS master, when it changes channels due to interference/congestion and everything works.

Conclusion: Single radio wireless repeating on 5 GHz is simply broken as it is on WRT1200AC.

can you try like me using relayd and not WDS ?

I need to have a STA and AP on the same wireless radio (definition of a "wireless repeater"), where the issue is keeping both active. Relayd doesn't change anything about hostapd trying to do DFS in a repeater setup and either disabling the AP or disconnecting the STA.

All the WDS bridging is working fine, so I don't see where relayd solves the problem. (The issue is not about connecting wired clients to a non-WDS AP.)

I do not see the point of having an AP mode with a box used as a Repeater ...

So wireless clients can access the network?

Do we have a common understanding of what a wireless repeater is? You know like this stuff: https://www.amazon.com/TP-Link-Extender-Repeater-Housing-RE200/dp/B00NR2VMNC/

The wireless clients simply connect to the repeater 's ( the same name as master router )

==

I use a specific extender TV with WPS ( not WDS ) only because I did not find the solution with OpenWrt to switch the TV stream of my ISP Orange
https://www.arris.com/products/vap3400-wireless-video-access-point/

Hi,
try to use 20MHz bandwidth. 5GHz AP+STA with auto channel doesn't work with 40Mhz and 80Mhz.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.