Wireless WAN on TP-LInk RE450 a device with only one LAN [Solved]

Dear friends,

I installed OpenWRT 19.07.3 on TP-LInk RE450, a device with only one LAN RJ45 network connector, which I am planning to use as MESH to extend my network. The problem is that there is no WAN and I need to upgrade and install a few packages.

I want to avoid bricking the RE450 which could happen very easily because there is only one LAN. What is the best and easiest approach?

I already created a WAN client to another AP

config wifi-iface 'wifinet2'               
        option encryption 'psk2'           
        option device 'radio1'             
        option mode 'sta'                  
        option key 'mypassword'
        option ssid 'myAP'

Now how do I declare the Wireless client as WAN in OpenWRT? I tried to create a bridge interface, but it did not succeed in receiving a DHCP address. Can anyone guide me, thanks ...


You've created a wifi client but not attached it to any network. Add option network 'wan' in /etc/config/wireless. In /etc/config/network, create a non-bridge 'wan' network with proto DHCP. A regular STA cannot be in a bridge. It doesn't need to be a bridge because everything will be NAT to the one IP you have on the upstream network.

The default /etc/config/firewall that installs with every OpenWrt includes rules to forward from 'lan' to 'wan'. So as long as you name your networks that the firewall is ready.

Thanks it worked like a charm. In LuCi, I created a WAN:

config interface 'WAN'
        option ifname 'wlan1'
        option proto 'dhcp'
        option auto '0'

The WAN interface could DHCP and it sufficed to add the correct gateway. Now I can proceed with further installation, thanks.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

Done, thanks.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.