Wireless USB dongle doesn't work in Openwrt

I'm new to OpenWRT and trying to setup a travel router using a RPi3. I got the image installed and have done basic setup and gotten the internal wireless online and connected to my home wireless for package updates, but I haven't been able to get my USB wireless dongle to get installed. Looking at the documentation I think the 2.4 GHz radio isn't supported. Is that right or am I reading it wrong? The USB adapter is 2.4 GHz only but I wanted to use it as an access point.

What is the chipset in the USB dongle? Some aren't supported at all, some can only work in STA mode not as an AP. It isn't a question of which band though.

Trying to get that information. I got it on Amazon but when I connect it to the Pi and do a lsusb all I get is what looks like "&. &" On 1 of the lines. If I remove it the line goes away. Based on the item description it should be RT5370.

You could check dmesg too.

When i disconnect and re-connect the usb dongle I get this in dmesg

[  569.199476] usb 1-1.1.2: USB disconnect, device number 4
[  572.573293] usb 1-1.1.2: new high-speed USB device number 6 using dwc_otg
[  572.704051] usb 1-1.1.2: New USB device found, idVendor=148f, idProduct=7601, bcdDevice= 0.01
[  572.716685] usb 1-1.1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  572.728403] usb 1-1.1.2: Product: Љ
[  572.734030] usb 1-1.1.2: Manufacturer: Љ
[  572.739981] usb 1-1.1.2: SerialNumber: Љ

Looking online for RT5370 I saw someone post that the Atheros AR9271 driver might be required so I tried "opkg install kmod-ath9k-htc" but that wasn't found. I previously ran this to install via opkg:

opkg install kmod-rt2800-lib kmod-rt2800-usb kmod-rt200-lib kmod-rt2x00-usb kmod-usb-core kmod-usb-uhci kmod-usb-ohci kmod-usb2 usbutils openvpn-openssl luci-app-openvpn

148f:7601 is Ralink MT7601U, according to Google.

Thanks. I found the same but when I tried to install the 7601 from what I found online kmod-mt7601u and mt7601u-firmware I get the following:

root@OpenWrt:~# opkg install kernel kmod-mac80211 kmod-usb-core mt7601u-firmware
Package kernel (5.4.154-1-9a704ddd8f7cd359a0628a6f45e5e494) installed in root is up to date.
Package kmod-mac80211 (5.4.154+5.10.68-1-1) installed in root is up to date.
Package kmod-usb-core (5.4.154-1) installed in root is up to date.
Unknown package 'mt7601u-firmware'.
Collected errors:
 * opkg_install_cmd: Cannot install package mt7601u-firmware.

Am I missing something?

do a "opkg update" and retry
firmware is there https://downloads.openwrt.org/releases/21.02.1/packages/aarch64_cortex-a53/base/mt7601u-firmware_20201118-3_aarch64_cortex-a53.ipk

Thanks. That worked even though before it didn't. Now when I remove and re-insert the adapter i get a message about the eeprom:


[  340.994264] usb 1-1.1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  341.006371] usb 1-1.1.2: Product: Љ
[  341.012274] usb 1-1.1.2: Manufacturer: Љ
[  341.018598] usb 1-1.1.2: SerialNumber: Љ
[  341.120810] usb 1-1.1.2: reset high-speed USB device number 6 using dwc_otg
[  341.251637] mt7601u 1-1.1.2:1.0: ASIC revision: 76010001 MAC revision: 76010500
[  341.262583] mt7601u 1-1.1.2:1.0: Firmware Version: 0.1.00 Build: 7640 Build time: 201302052146____
[  341.711279] mt7601u 1-1.1.2:1.0: Error: your device needs default EEPROM file and this driver doesn't support it!
[  341.727222] mt7601u: probe of 1-1.1.2:1.0 failed with error -22

The mt7601u doesn't support AP mode. I have two of them but they are used for client mode only. You can check capability with iw list. The adapters that use mt7610u and mt7612u chipsets should do what you want. Here are some ideas:

I use a ALFA AWUS036ACHM plugged into the USB2 port of my router that runs OpenWRT.

Good luck.

2 Likes

Thanks for the feedback. I'm ok with it in client mode if I can get it to work just for a PoC at this point. But I'll check out the adapter you linked too. Biggest issue is Pi doesn't seem to want to recognize and use the adapter in with AP or client mode.

So I got a new usb adapter and that installed and I'm able to configure the radio but I'm not seeing the network come up, or at least not broadcasting. In the GUI it shows as enabled and the config file is as follows:

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '7'
        option hwmode '11g'
        option path 'platform/soc/3f300000.mmcnr/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
        option htmode 'HT20'
        option disabled '0'
        option short_gi_40 '0'
        option cell_density '0'

config wifi-iface 'wifinet1'
        option device 'radio0'
        option mode 'sta'
        option network 'wwan'
        option ssid 'Network1'
        option encryption 'psk2'
        option key 'password1'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/soc/3f980000.usb/usb1/1-1/1-1.3/1-1.3:1.0'
        option cell_density '0'
        option country 'US'
        option disabled '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'MyTravelNetwork'
        option encryption 'psk2'
        option key 'password'

If I'm in the GUI it says the interface is disabled when I hover over wlan1. Do I need to add an interface to the configuration or is that automatically done since the dongle was recognized and ifcong wlan1 up seems to take without any errors.