Wireless stopped working

As expected, you did overwrite the device specific calibration with garbage, preventing the wireless card from initializing (which is fatal).

Flashing again the D-Link original firmware could help me fix this?
Otherwise is there any other method?

Try that, although the ART is device specific, so the firmware image might not carry it. It's definitely worth trying but you might need to flash an ART backup from someone else's 2570B B1.

Restoring the original D-Link firmware the wireless works.. Is there a way to "erase/clear" the ART so doing another flash of the openwrt firmware again can write it from scratch?

other infos:

root@OpenWrt:~# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 00010000 00010000 "cfe"
mtd1: 007c0000 00010000 "linux"
mtd2: 0018e510 00010000 "kernel"
mtd3: 006319f0 00010000 "rootfs"
mtd4: 003d0000 00010000 "rootfs_data"
mtd5: 00010000 00010000 "cal_data"
mtd6: 00020000 00010000 "nvram"

Otherway, is it possible to connect a wifi-usb adapter and use it as my new wifi interface?


but same issue as here: Archer C7 AC1750 ver. 5 USB wifi dongle

1 Like

I'll read it, thank you frollic.


it seems that on my device usb port is not enable.. what packages should I install to let it work?

I'd buy a cheap used router, and use as AP.

Would 1st make sure it was supported by openwrt :wink:

Ineed.. my intention was to let my actual old router works :smiley: but it seems to be too complicated for the scope.

depends on what kind of device you're inserting into the usb port.

the dongle: usb 3.0/2.0, 2.4/5ghz, chipset RTL8812BU

the router has a 2.0 usb port but it seems that there is any package installed to let it work.. what packages should I install to enable the usb port on the router?

start with kmod-rtl8812au-ct

OpenWrt does not wipe your ART. You can wipe that yourself if you'd like (and likewise restore it). It will not be regenerated in any way (calibration is done by the manufacturer).

Examples below assume mtd5 (named cal_data) contains your calibration data, but you need to be sure that's what it actually is (although it doesn't hurt to back up the flash layout together with all the partitions on your flash).

# dd if=/dev/mtd5 of=/tmp/mtd5-caldata.mtd


# opkg update && opkg install kmod-mtd-rw
# insmod /lib/modules/$(uname -r)/mtd-rw.ko
# dd if=/tmp/mtd5-caldata.mtd of=/dev/mtd5
1 Like

package installed but it seems it is not recognized because I don't see any usb adapter or interface available, what Am I missing?

root@OpenWrt:~# dmesg  | grep usb
[   15.783743] usbcore: registered new interface driver usbfs
[   15.789703] usbcore: registered new interface driver hub
[   15.795420] usbcore: registered new device driver usb
[   17.703303] usbcore: registered new interface driver rtl8812au
root@OpenWrt:~# lsusb
unable to initialize libusb: -99

If your internal Atheros wireless still works well enough by any means please use that. USB dongles are hit and miss and Realtek makes that even worse, their drivers are shitty and little more than dumps of code often.

The AR5008 (despite its number) is the very first ath9k chip. It usually holds ART in a dedicated EEPROM chip connected to the AR5008. This requires special consideration in OpenWrt. I think it is the ath9k "build for laptop cards" option.

1 Like

I need to use the wireless in client mode, it is possible only with openwrt firmware (the dlink one does not provide this feature).. at the moment I'm stuck with the ART issue.

This thread could be closed. More info here: D-Link 2750B ver.B1: ART backup needed

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.