Wireless not working in OpenWrt Raspberrypi b+

I've installed OpenWrt on raspberry pi b+. when I logged into the router via Lucci or ssh wireless was missing.
I tried changing wifi country code through pi's default os raspbian as suggested by official OpenWrt website:


to make wifi country code change I followed this blog: https://miapple.me/fix-raspberry-pi-wifi-country-not-set/

I also recompiled OpenWrt is case something was missing.

I know its not a hardware issue because wifi worked fine on raspbian os.

The wifi is disabled by default.
You can use command wifi

Usage: /sbin/wifi [config|up|down|reload|status]
enables (default), disables or configures devices not yet configured.

Thanks for the quick replay. problem is wifi is not there at all, I know its disabled from configuration but there seems to be no configuration file in raspberry.
I have installed OpenWrt on regular router and enabled wifi from configuration.

Makes sense as on a raspberry anyone can connect whatever wifi usb stick they wish, so the wifi cannot be standarised, in contrast to a router with a specific chip for wifi.

Thanks, I 've used command wifi up. but it does not work am I missing configuration?

root@OpenWrt:/sbin# wifi up
root@OpenWrt:/sbin# wifi status



Start with wifi config
If this doesn't work you'll need to troubleshoot if the usb dongle is recognised properly and modules are loaded.

1 Like

Thanks, this helped me to understand little bit more about the issue.

For some reason I can not configure wifi channels.

with google search I found that it might me country code issue. but even if I change country code it resets to 00 (after reboot).


Here is wifi status:

and config:

I also looked into the system log and fond an error:
Could not find PHY for device 'radio0'

Can you locate the usb dongle in lsusb?
Are the proper modules loaded ? lsmod
Is there a wireless interface available? ifconfig -a
What does iwinfo report?
Please copy-paste the output of the commands here in preformatted text (Ctrl-Shift-c) rather than uploading screenshots.

-ash: lsusb: not found
root@OpenWrt:/# lsmod
brcmfmac 200704 0
brcmutil 16384 1 brcmfmac
cfg80211 282624 1 brcmfmac
compat 16384 2 brcmfmac,cfg80211
crc_ccitt 16384 1 ppp_async
evdev 24576 0
fat 61440 1 vfat
hid 94208 2 usbhid,hid_generic
hid_generic 16384 0
ip_tables 20480 4 iptable_nat,iptable_mangle,iptable_filter
ip6_tables 20480 24 ip6table_mangle,ip6table_filter
ip6t_REJECT 16384 2
ip6table_filter 16384 1
ip6table_mangle 16384 1
ipt_MASQUERADE 16384 1
ipt_REJECT 16384 2
iptable_filter 16384 1
iptable_mangle 16384 1
iptable_nat 16384 1
nf_conntrack 73728 9 ipt_MASQUERADE,xt_state,xt_nat,xt_conntrack,xt_REDIRECT,nf_nat_ipv4,nf_nat,nf_flow_table,nf_conntrack_rtcache
nf_conntrack_rtcache 16384 0
nf_defrag_ipv4 16384 1 nf_conntrack
nf_defrag_ipv6 16384 1 nf_conntrack
nf_flow_table 24576 2 xt_FLOWOFFLOAD,nf_flow_table_hw
nf_flow_table_hw 16384 1
nf_log_common 16384 2 nf_log_ipv4,nf_log_ipv6
nf_log_ipv4 16384 0
nf_log_ipv6 16384 0
nf_nat 20480 3 xt_nat,xt_REDIRECT,nf_nat_ipv4
nf_nat_ipv4 16384 2 iptable_nat,ipt_MASQUERADE
nf_reject_ipv4 16384 1 ipt_REJECT
nf_reject_ipv6 16384 1 ip6t_REJECT
nls_cp437 16384 1
nls_iso8859_1 16384 1
nls_utf8 16384 0
ppp_async 20480 0
ppp_generic 32768 3 pppoe,ppp_async,pppox
pppoe 20480 0
pppox 16384 1 pppoe
slhc 16384 1 ppp_generic
snd 49152 9 snd_bcm2835,snd_rawmidi,snd_seq_device,snd_pcm_oss,snd_pcm,snd_timer,snd_mixer_oss,snd_hwdep,snd_compress
snd_bcm2835 20480 0
snd_compress 20480 0
snd_hwdep 16384 0
snd_mixer_oss 24576 1 snd_pcm_oss
snd_pcm 73728 2 snd_bcm2835,snd_pcm_oss
snd_pcm_oss 45056 0
snd_rawmidi 24576 0
snd_seq_device 16384 1 snd_rawmidi
snd_timer 28672 1 snd_pcm
soundcore 16384 1 snd
usbhid 32768 0
vfat 20480 1
x_tables 24576 23 ipt_MASQUERADE,xt_state,xt_nat,xt_conntrack,xt_REDIRECT,xt_FLOWOFFLOAD,ipt_REJECT,xt_time,xt_tcpudp,xt_multiport,xt_mark,xt_mac,xt_limit,xt_comment,xt_TCPMSS,xt_LOG,iptable_mangle,iptable_filter,ip_tables,ip6table_mangle,ip6table_filter,ip6_tables,ip6t_REJECT
xt_FLOWOFFLOAD 16384 0
xt_LOG 16384 0
xt_REDIRECT 16384 0
xt_TCPMSS 16384 2
xt_comment 16384137
xt_conntrack 16384 16
xt_limit 16384 20
xt_mac 16384 0
xt_mark 16384 0
xt_multiport 16384 0
xt_nat 16384 0
xt_state 16384 0
xt_tcpudp 16384 10
xt_time 16384 0

ifconfig -a

root@OpenWrt:/# ifconfig -a
br-lan Link encap:Ethernet HWaddr B8:27:EB:D8:22:6F
inet addr: Bcast: Mask:
inet6 addr: fd38:d65a:86ed::1/60 Scope:Global
inet6 addr: fe80::ba27:ebff:fed8:226f/64 Scope:Link
RX packets:4775 errors:0 dropped:0 overruns:0 frame:0
TX packets:4322 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:378589 (369.7 KiB) TX bytes:428103 (418.0 KiB)

br-test Link encap:Ethernet HWaddr 06:AE:54:E0:16:33
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

eth0 Link encap:Ethernet HWaddr B8:27:EB:D8:22:6F
RX packets:4779 errors:0 dropped:4 overruns:0 frame:0
TX packets:4322 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:378773 (369.8 KiB) TX bytes:472347 (461.2 KiB)

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:161 errors:0 dropped:0 overruns:0 frame:0
TX packets:161 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:10956 (10.6 KiB) TX bytes:10956 (10.6 KiB)


does not output anything.

There doesn't seem to be any dongle recognized. Install usbutils package first and probe again with lsusb