Wireless not associated after reset and upload backup

Dear all,

I have a TP W8970 which was working flawless. I wanted to do some changes and I think I made few too many and made the system unsable.

Before I started to work on the machine I did a backup.

After several tries, considering I had the backup, I decided to reset the machine and reload it.
I realized there was no package list saved and I installed the required ones I'm aware I need and these started to work immediately using previous imported config file.

The only hiccup I'm facing is to set up the wifi. Obviously the files network and wireless are the one from backup so configuration are ok.

In the wireless tab the SSID shows msg:Wireless is not associated.

My assumption at this point is that considering the config files should be correct I might miss some software/package.
When I did set it up years ago I remember strugle for it but after so long I can't remember what was key action.
I've checked online and couldn't find anything helping
I run OpenWrt 18.06.9 r8077-7cbbab7246 due to limited RAM

Can someone give any hint outside the commong config file setup?

Cheers

Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have

ubus call system board; \
uci export network; uci export wireless; \
uci export dhcp; uci export firewall

Thanks for the prompt reply

I hope you can see something between the XXX

Below the file as requested

system board

	"kernel": "4.9.243",
	"hostname": "OpenWrt",
	"system": "xRX200 rev 1.2",
	"model": "TP-LINK TD-W8970",
	"board_name": "tplink,tdw8970",
	"release": {
		"distribution": "OpenWrt",
		"version": "18.06.9",
		"revision": "r8077-7cbbab7246",
		"target": "lantiq\/xrx200",
		"description": "OpenWrt 18.06.9 r8077-7cbbab7246"
	}

network

config interface 'loopback'       
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'              
        option netmask '255.0.0.0'
                       
config globals 'globals'   
        option ula_prefix 'XXXXXX'
                               
config atm-bridge 'atm'
        option encaps 'llc'
        option payload 'bridged'
        option nameprefix 'dsl'
        option vci '35'   
        option vpi '8'          

config dsl 'dsl'      
        option annex 'a2p'  
        option ds_snr_offset '0'
                                   
config interface 'lan'                
        option type 'bridge' 
        option proto 'static' 
        option ipaddr 'xx.xx.98.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ifname 'eth0.1'
                       
config interface 'wan'      
        option ifname 'dsl0'
        option proto 'pppoe'       
        option ipv6 '1'         
        option keepalive '0'
        option mtu '1492'   
        option username 'XXXXXX'
        option password 'XXXXXX'          

config device 'wan_dsl0_dev'
        option name 'dsl0'  
        option macaddr 'ZZ:ZZ:ZZ:ZZ:ZZ:ZZ'

config interface 'wan6'
        option ifname '@wan' 
        option proto 'dhcpv6'
                              
config switch
        option name 'switch0'
        option reset '1'       
        option enable_vlan '1'
                      
config switch_vlan           
        option device 'switch0'
        option vlan '1'
        option vid '1'         
        option ports '0 5 6t'
                      
config switch_vlan           
        option device 'switch0'
        option vlan '2'
        option vid '2'       
        option ports '2 4 6t' 

config interface 'XXXX' 
        option proto 'static'
        option ifname 'eth0.2'
        option ipaddr XX.XX.79.1'
        option netmask '255.255.255.0'

wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'HT20'
        option legacy_rates '1'
        option country 'IT'
        option txpower '20'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'ap'
        option encryption 'psk2'
        option key 'XXXXXX'
        option ssid 'XXXXXXX'
        option wps_pushbutton '1'
        option network 'lan'

dhcp

config dnsmasq                
        option domainneeded '1' 
        option localise_queries '1'         
        option rebind_protection '1'                 
        option rebind_localhost '1'              
        option local '/lan/'                         
        option domain 'lan'                      
        option expandhosts '1'
        option authoritative '1'      
        option readethers '1'               
        option leasefile '/tmp/dhcp.leases'          
        option resolvfile '/tmp/resolv.conf.auto'
        option nonwildcard '1'                       
        option localservice '1'   
                                      
config dhcp 'lan'                     
        option interface 'lan'              
        option start 'XXX'                           
        option limit 'XXX'                  
        option leasetime '12h'                       
        option dhcpv6 'server'    
        option ra 'server'            
        option ra_management '1'       
                                            
config dhcp 'wan'                                    
        option interface 'wan'              
        option ignore '1'                            
                                  
config odhcpd 'odhcpd'                 
        option maindhcp '0'           
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'                          
                                          
config dhcp 'XXX'                     
        option interface 'XXX'         
        option start 'XXX'            
        option leasetime '24h'         
        option limit 'XXX'                      
                                       
config dhcp '--'                     
        option interface '--' 
        option start 'XXX'                
        option limit 'XXX'             
        option leasetime '24h'         
                                                   

firewall

config defaults                             
        option syn_flood '1'                    
        option input 'ACCEPT'                   
        option output 'ACCEPT'                  
        option forward 'REJECT'                 
                                                
config zone                                 
        option name 'lan'                   
        option input 'ACCEPT'                   
        option output 'ACCEPT'                  
        option forward 'ACCEPT'                 
        option network 'lan'                    
                                                
config zone                                 
        option name 'wan'                   
        option input 'REJECT'                   
        option output 'ACCEPT'                  
        option forward 'REJECT'                 
        option masq '1'                         
        option mtu_fix '1'                      
        option network 'wan wan6'           
                                            
config rule                                     
        option name 'Allow-DHCP-Renew'          
        option src 'wan'                        
        option proto 'udp'                      
        option dest_port '68'                   
        option target 'ACCEPT'              
        option family 'ipv4'                
                                                
config rule                                     
        option name 'Allow-Ping'                
        option src 'wan'                        
        option proto 'icmp'                     
        option icmp_type 'echo-request'     
        option family 'ipv4'                
        option target 'ACCEPT'                  
                                                
config rule                                     
        option name 'Allow-IGMP'                
        option src 'wan'                        
        option proto 'igmp'                 
        option family 'ipv4'                
        option target 'ACCEPT'                  
                                                
config rule                                     
        option name 'Allow-DHCPv6'              
        option src 'wan'                        
        option proto 'udp'                  
        option src_ip 'fc00::/6'            
        option dest_ip 'fc00::/6'               
        option dest_port '546'                  
        option family 'ipv6'                    
        option target 'ACCEPT'                  

                                            
config rule                                 
        option name 'Allow-MLD'                 
        option src 'wan'                        
        option proto 'icmp'                     
        option src_ip 'fe80::/10'               
        list icmp_type '130/0'                  
        list icmp_type '131/0'              
        list icmp_type '132/0'              
        list icmp_type '143/0'                  
        option family 'ipv6'                    
        option target 'ACCEPT'                  
                                                
config rule                                     
        option name 'Allow-ICMPv6-Input'    
        option src 'wan'                    
        option proto 'icmp'                     
        list icmp_type 'echo-request'           
        list icmp_type 'echo-reply'             
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'         
        list icmp_type 'time-exceeded'      
        list icmp_type 'bad-header'         
        list icmp_type 'unknown-header-type'    
        list icmp_type 'router-solicitation'    
        list icmp_type 'neighbour-solicitation' 
        list icmp_type 'router-advertisement'   
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'             
        option family 'ipv6'                
        option target 'ACCEPT'                  
                                                
config rule                                     
        option name 'Allow-ICMPv6-Forward'      
        option src 'wan'                        
        option dest '*'                     
        option proto 'icmp'                 
        list icmp_type 'echo-request'           
        list icmp_type 'echo-reply'             
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'         
        list icmp_type 'time-exceeded'          
        list icmp_type 'bad-header'         
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'                 
        option family 'ipv6'                    
        option target 'ACCEPT'                  
                                                
config rule                                     
        option name 'Allow-IPSec-ESP'       
        option src 'wan'                    
        option dest 'lan'                       
        option proto 'esp'                      
        option target 'ACCEPT'                  
                                                
config rule                                     
        option name 'Allow-ISAKMP'          
        option src 'wan'                    
        option dest 'lan'                       
        option dest_port '500'                  
        option proto 'udp'                      
        option target 'ACCEPT'                  

config include                              
        option path '/etc/firewall.user'    
                                                
config zone                                     
        option name 'XXX'                       
        option input 'ACCEPT'                   
        option output 'ACCEPT'                  
        option network 'XXX'                
        option family 'ipv4'                
        option forward 'REJECT'                 
                                                
config forwarding                               
        option dest 'wan'                       
        option src 'XXX'                        
                                            
config redirect                             
        option target 'DNAT'                    
        option src 'wan'                        
        option dest 'XXX'                       
        option proto 'tcp'                      
        option src_dport 'XX'                   
        option dest_ip 'XXXXX'      
        option dest_port 'XXX'               
        option name 'http'                      
                                                
config redirect                                 
        option target 'DNAT'                    
        option src 'wan'                        
        option dest 'XXX'                   
        option proto 'tcp'                  
        option src_dport 'XXXX'                  
        option dest_ip 'XXXX'          
        option dest_port 'XXXX'                  
        option name 'https'                         
                                                
config zone                                     
        option name 'XXX'               
        option input 'ACCEPT'               
        option forward 'REJECT'                 
        option output 'ACCEPT'                  
        option network 'XXXX'                

config forwarding                               
        option dest 'XXX'                       
        option src 'XXXX'                    
                                                
config rule                                     
        option target 'ACCEPT'              
        option src 'lan'                    
        option name 'XXXX'                 
        option proto 'tcp'                      
        option dest 'XXXX'                       
        option dest_ip 'XXXX'          
        option dest_port 'XXX'                   
                                            
config rule                                 
        option target 'ACCEPT'                  
        option src 'XXXX'                    
        option name 'XXXX'       
        option proto 'tcp'                      
        option dest 'XXXX'                       
        option dest_ip 'XXXXX'      
        option dest_port 'XXX'              
                                                
config rule                                     
        option target 'ACCEPT'                  
        option src 'lan'                        
        option name 'XXXXXXX'           
        option dest 'XXXX'                   
        option dest_port 'XXXX'              
                                                
config forwarding                               
        option dest 'wan'                       
        option src 'lan'                                           

Cheers

I don't see anything wrong in there. If you do a scan from a smartphone, do you see the SSID? Can you connect?

That's why I'm thinking being a minimal installation i need to install some package, may be kernel

The cofig files also as u see r ok

Any option?

I know by fact wifi was worhing before the reset

Is there a dedicate Wifi power button on the back? Sometimes I punch Elvis on my TP's by accident.

You didn't answer my questions though.

1 Like

You mentioned limited RAM, what are your ram stats?

free
cat /proc/meminfo

1 Like

Sorry for late reply,

I've been away.

@Bill: there is a wifi switch. I double checked and make sure it is on but nothing has changed
@trendy: no there is no SSID shown in any wifi scanner app from smartphone or pc programs
@account4538: 23528 kB / 59092 kB (39%) (from the openwrt status overview)

as I know the system was fine before reset.

A fresh new installation rather than reset do you think might help?
I'm still believing this is a sw issue like package or kernel

Still open to new checks and hints

Cheers

Would you be willing to post a list of packages you have installed? It'll help to see if anything you need is missing.

@VA1DER : I don't see a problem to post the installed package.

I just checked the Atheros ar9k family packages and are up to date.

scrolling the dedicated wiki I saw the iw command and I've installed the full version.

Still no joy :frowning:

cheers

Then please do... opkg list-installed
Then we can see if you have everything you need, including wpad/hostapd, etc.

1 Like

Hi there,
reading @VA1DER post he reminded me the hostapd package. I did check and I think it was not installed or at least was broken.

After it I deleted the old SSID, restarded the wireles and created a new SSID and now it is working!!!!!

Thanks for helping

Ciao

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.