"Wireless is not associated"

I am new to OpenWRT, but not new to Linux or Routers (used the WRT54 in the old days).
Currently I am trying to set up a wireless connection with a OrangePi R1 (21.02.1).

Basically the router is running, only without the wireless (currently some old router connected as wifi gate).

From the FAQ:

How do I enable WiFi?

Issue: After flashing OpenWrt, WiFi is not working.
Root cause: By default the wireless is OFF.
Solution: Turn it ON in /etc/config/wireless by changing disabled 1disabled 0

Sounds reasonable, but now I want to get wireless working...
... only there is no /etc/config/wireless

Can anyone talk me through the steps needed since the FAQ clearly does not help:

  1. I do not know for sure the USB wifi dongle is going to work ("cheap RTL clone")
  2. how can I detect the wlan?
  3. how can I set up the wlan?

From what I can see the FAQ dates back ages, refering to old tools.

What I tried:

  1. ifconfig does not show a wlan-device (which I don't find encouraging)
  2. dmesg show the realtek drivers have been installed and have seen a device
  3. the "radio0" (radio not active) shows a list of AP's in the neighborhood with a scan
  4. when I try a client connection to my wifi router I get "not associated" (not when I configure manually and not when I configure with the scan + connect)

Since I can scan a network I would guess I should be able to connect, however no luck so far.

The devices I tried:

Realtek RTL8811AU chipset ( USB ID = 0BDA:A811 )
Realtek RTL8821CU chipset ( USB ID = 0BDA:C820, Initial CDROM mode = 0BDA:1A2B )

You really need to identify your USB chipset, FCC ID, USB device IDs, dmesg - having a look with a general purpose linux distribution (arch, gentoo, debian, fedora, mageia, mandriva, OpenSuSE, Ubuntu, whatever).

But... USB wireless is already bad to begin with - and realtek/ reasil USB wireless is... RUN... abandon all hope.

I know what you are getting at, but I don't think that is the issue here.

This is the dialog I get:

radio0     Generic 802.11a                 Restart | Scan | Add
           Device is not active

disabled   SSID SomeSSID Mode Client       Enable  | Edit | Remove
           Wireless is disabled

disabled   SSID openWRT Mode Master        Disable | Edit | Remove
           Wireless is not associated

The big advantage of a GUI is that when you see it you automatically sense what action is expected to get it to work. The third line tells that it doesn't work and that you have the option to disable it?

The dialog is 100% a OpenWRT problem. The lacking documentation also.

I've used openwrt and ddwrt on and off for a while. Just decided to get back into it with a Netgear R8000 and thought I would chime in on this.
I did a wireless scan of my apartment, and was setting my radios accordingly, when I found that radio0 wasn't coming up. I was trying to set it to the top of the range, channel 165, but was getting "device is not active. wireless is not associated". I then dropped it down to the next available channel (161) and it came up no prob.
Maybe it has issues with statically setting certain channels? Not sure but hope this will help others.