Wireless interface not showing up even though its configured and enabled

I have configured a device on wlan1

wlan0     Link encap:Ethernet  HWaddr B8:27:EB:AF:09:8E  
          inet addr:xx.xx.xx.xx  Bcast:xx.xx.xx.xx  Mask:255.255.255.0
          inet6 addr: xxxxxxxxxxxxxxxxxxxx/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3705 errors:0 dropped:0 overruns:0 frame:0
          TX packets:338 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:476766 (465.5 KiB)  TX bytes:49656 (48.4 KiB)

wlan1     Link encap:Ethernet  HWaddr 3C:33:00:60:3B:B4  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

I have enabled it in the /etc/config/wireless file

uci show wireless has this:

wireless.radio0=wifi-device
wireless.radio0.type='mac80211'
wireless.radio0.path='platform/soc/3f300000.mmcnr/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
wireless.radio0.htmode='HT20'
wireless.radio0.disabled='0'
wireless.radio0.short_gi_40='0'
wireless.radio0.cell_density='0'
wireless.wifinet1=wifi-iface
wireless.wifinet1.device='radio0'
wireless.wifinet1.mode='sta'
wireless.wifinet1.network='wwan'
wireless.wifinet1.ssid='xxxxx'
wireless.wifinet1.encryption='psk2'
wireless.wifinet1.key='xxxxx'
wireless.radio1=wifi-device
wireless.radio1.type='mac80211'
wireless.radio1.path='platform/soc/3f980000.usb/usb1/1-1/1-1.2/1-1.2:1.0'
wireless.radio1.channel='1'
wireless.radio1.band='2g'
wireless.radio1.htmode='HT20'
wireless.radio1.disabled='0'
wireless.default_radio1=wifi-iface
wireless.default_radio1.device='radio1'
wireless.default_radio1.network='lan'
wireless.default_radio1.mode='ap'
wireless.default_radio1.ssid='xxxxx'
wireless.default_radio1.encryption='psk2'
wireless.default_radio1.key='xxxxx'

GUI shows this:

You haven't set a country code... that could be part of it.

Let's see the output of the following:

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless

Ubus call system board

"kernel": "5.10.161",
	"hostname": "OpenWrt",
	"system": "ARMv8 Processor rev 4",
	"model": "Raspberry Pi 3 Model B Rev 1.2",
	"board_name": "raspberrypi,3-model-b",
	"rootfs_type": "ext4",
	"release": {
		"distribution": "OpenWrt",
		"version": "22.03.3",
		"revision": "r20028-43d71ad93e",
		"target": "bcm27xx/bcm2710",
		"description": "OpenWrt 22.03.3 r20028-43d71ad93e"

network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'xx.xxx.xxx.xx::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr 'xxx.xxxx.xxx'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option force_nk '1'

config interface 'wwan'
	option roto 'dhcp'
	option peerdns '0'
	option dns '1.1.1.1 8.8.8.8'
	option proto 'dhcp'

config interface 'vpnclient'
	option ifname 'tun0'
	option proto 'none'

wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/3f300000.mmcnr/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
	option htmode 'HT20'
	option disabled '0'
	option short_gi_40 '0'
	option cell_density '0'

config wifi-iface 'wifinet1'
	option device 'radio0'
	option mode 'sta'
	option network 'wwan'
	option ssid 'xxxxx'
	option encryption 'psk2'
	option key 'xxxxxxx'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/3f980000.usb/usb1/1-1/1-1.2/1-1.2:1.0'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option disabled '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'xxxx'
	option encryption 'psk2'
        option key 'xxxxxx'

This is your issue.

The RPi (all of them) uses a very low end WiFi chipset. It only supports use as either a WiFi ap or a WiFi sta mode device, not both simultaneously.

IIRC, it also only supports one band at a time (no dual band operation), and Iā€™m pretty sure it cannot do multiple ssids when used in ap mode.

1 Like

Ohh boy so the solution is not using RPi at all?

that's the best solution :wink:

1 Like

The RPi4 (not the RPi3 or earlier) can be a very fast and capable wired router, but its wireless side is not worth looking at. Range and performance are cr^wbad and brcmfmac is rather limiting as a driver (interface combinations, features).