Wireless failed frequently when using OpenWrt 18.06.1

Hi, my device is TP-Link WR845N v4, which has the same CPU as tl-wr842n-v3. I have modded my router with 16MB flash and 64MB RAM. I tested RAM by memtester and confirmed the hardware mod is working.

I often come across the same issue that even though my devices are connected to the Wi-Fi, I experience a lot of lag or even failed to connect. SSH to router often return with 'Connection timeout'. Even when I am lucky to login, it is still very laggy. When I reboot my router, the Wi-Fi becomes normal for a few days then the problem appears again.

However, the switch is working well. I experience no lag at all when I connect with a cable.

My /etc/config/network:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd56:0a23:bccf::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth1'
        option proto 'pppoe'
        option username 'my-username'
        option password 'my-password'
        option ipv6 'auto'

config interface 'wan6'
        option ifname 'eth1'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 0t'

My /etc/config/wireless:

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/qca953x_wmac'
        option htmode 'HT20'
        option country 'CN'
        option legacy_rates '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'my-ssid'
        option key 'my-passwd'
        option encryption 'psk2'

Every time I disconnect a device and connect again, 'logread && logread -f' always shows the same output:

Fri Sep  7 00:34:15 2018 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED 64:bc:0c:80:3a:1f
Fri Sep  7 00:34:20 2018 daemon.info hostapd: wlan0: STA 64:bc:0c:80:3a:1f IEEE 802.11: authenticated
Fri Sep  7 00:34:20 2018 daemon.info hostapd: wlan0: STA 64:bc:0c:80:3a:1f IEEE 802.11: associated (aid 3)
Fri Sep  7 00:34:20 2018 daemon.notice hostapd: wlan0: AP-STA-CONNECTED 64:bc:0c:80:3a:1f
Fri Sep  7 00:34:20 2018 daemon.info hostapd: wlan0: STA 64:bc:0c:80:3a:1f WPA: pairwise key handshake completed (RSN)
Fri Sep  7 00:34:35 2018 daemon.info dnsmasq-dhcp[1453]: DHCPDISCOVER(br-lan) 64:bc:0c:80:3a:1f
Fri Sep  7 00:34:35 2018 daemon.info dnsmasq-dhcp[1453]: DHCPOFFER(br-lan) 192.168.1.223 64:bc:0c:80:3a:1f
Fri Sep  7 00:34:41 2018 daemon.info dnsmasq-dhcp[1453]: DHCPREQUEST(br-lan) 192.168.1.223 64:bc:0c:80:3a:1f
Fri Sep  7 00:34:41 2018 daemon.info dnsmasq-dhcp[1453]: DHCPACK(br-lan) 192.168.1.223 64:bc:0c:80:3a:1f

Is there any device?