Wireless config for Linksys WRT1200AC

I use custom image from git to flash to device but I seemed to messed up the wireless config.
now the 5GHz speed is the same as 2.5Ghz at " Channel: 36 (5.180 GHz) | Bitrate: 54 Mbit/s "
how do I fix this.
I tried copying from image the wireless vanilla config but still this speed doesn't change.

could it be because of my clients speed?
my phone use to get the 300Mb/s speed on shown in wireless tab in luci.
but now it doesn't.

this is my wireless setting:

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
        option htmode 'VHT80'
        option country 'DE'
        option legacy_rates '0'
        option log_level 3

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option macaddr 'xxxxxxxxxxxx'
        option ssid 'openwrt5'
        option hidden '1'
        option wmm '0'
        option key 'xxxxxxxxxxxxxx'
        option encryption 'psk2+ccmp'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
        option country 'DE'
        option channel 'auto'
        option htmode 'HT40'
        option legacy_rates '0'
        option log_level 3

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option macaddr 'xxxxxxxxxxxx'
        option ssid 'openwrt'
        option hidden '1'
        option wmm '0'
        option key 'xxxxxxxxxxx'
        option encryption 'psk2+ccmp'


  • 5GHz AC networks should be configured with the highest possible channel available in your country (which I assume is Germany from your config)
    • No 2.4GHz N channels should be used (I believe channels <72)

  • Not sure about the legacy_rates option... where did you get that from?

  • Wireless interfaces should never be configured with channel 'auto', else performance and throughput will suffer.

I dont understand which part you are saying causes this.
I thought I am using the wrong "option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'"
because they are different from the stock one that is created when I delete the file and reboot.
and the auto one is for 2.5G chipset so that doesnt matter.
what channel shoud i use that is lower that 72, 71?

I think I found the problem
when I enable ""WMM Mode" my phone connects with 390Mb/s speed but if I disable it it connects with 54Mb/s speed (my tablet too by the way).
that is weird, I thought that was irrelevant to that.
maybe a bug?
because in past I had that disabled and still got good speed.

WMM is "required" for 802.11n. See, for example

https://www.smallnetbuilder.com/wireless/wireless-features/30938-dont-mess-with-wmm

A recent Forum post reported what appeared to be a bug involving the NETGEAR WNDR3700 and Intel 5300 WiFi Link mini PCIe client. The gist of the problem was that the reader could only get a 54 Mbps maximum connection rate between the two products in both the 2.4 and 5 GHz bands. But connecting the same notebook (with Intel 5300) to a Trendnet TEW-672GR 802.11n router yielded the expected 300 Mbps link rate (with 40 MHz mode enabled).

2 Likes