Wireless bridge from cisco 881w to OpenWrt

Hi guys.

I'm configuring non root wireless bridge @ cisco 881w as wireless client to non cisco accesspoint (openWRT)
I put following configuration to c881w:

!
! Last configuration change at 02:14:04 UTC Mon Mar 1 1993 by sam
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname gate-cottage-ap
!
!
logging rate-limit console 9
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization exec default local
!
!
!
aaa session-id common
no ip cef
!
!
!
!
dot11 syslog
dot11 vlan-name WBR-UPLINK vlan 1
!
dot11 ssid a81m-guest
vlan WBR-UPLINK
authentication open
authentication key-management wpa version 2
mbssid guest-mode
wpa-psk ascii 0 yyyyyyyyyyyyy
!
!
bridge irb
!
!
!
interface Dot11Radio0
no ip address
no ip route-cache
ip tcp adjust-mss 1360
!
encryption vlan WBR-UPLINK mode ciphers aes-ccm
!
ssid a81m-guest
!
antenna gain 0
speed basic-1.0 2.0 5.5 11.0 6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0 m0. m1. m2. m3. m4. m8. m9. m10. m11. m12. m13. m14. m15.
power client 20
packet retries 24 drop-packet
station-role non-root bridge
beacon period 101
beacon dtim-period 1
world-mode dot11d country-code US outdoor
infrastructure-client
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
no ip route-cache
bridge-group 1
bridge-group 1 spanning-disabled
!
interface GigabitEthernet0
description -= downlink to the router =-
no ip address
no ip route-cache
!
interface GigabitEthernet0.1
encapsulation dot1Q 1 native
no ip route-cache
bridge-group 1
bridge-group 1 spanning-disabled
!
interface BVI1
no ip address
no ip route-cache

!
ip forward-protocol nd
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
!
!
!
bridge 1 route ip
!
!
!
line con 0
logging synchronous
no activation-character
line vty 0 4
transport input all
!
end

wheneever i shut& no shut dot0 interface I see following:

*Mar  1 02:15:39.815: %LINK-5-CHANGED: Interface Dot11Radio0, changed state to administratively down
*Mar  1 02:15:43.887: %LINK-5-CHANGED: Interface Dot11Radio0, changed state to reset
*Mar  1 02:15:55.195: %DOT11-4-CANT_ASSOC: Interface Dot11Radio0, cannot associate: No Response

at openwrt access point I see following in log:

May 21 14:17:52 ap.sk1.net hostapd: wlan0-11: STA 00:07:7d:ae:3b:90 IEEE 802.11: authenticated
May 21 14:17:52 ap.sk1.net hostapd: wlan0-11: STA 00:07:7d:ae:3b:90 IEEE 802.11: associated (aid 1)
May 21 14:18:01 ap.sk1.net hostapd: wlan0-11: STA 00:07:7d:ae:3b:90 IEEE 802.11: deauthenticated due to local deauth request

where:
00:07:7d:ae:3b:90 is MAC of c881w dot0.1 interface

my openwrt wireless config looks like:

config wifi-device 'radio0'
option type 'mac80211'
option channel '11'
option hwmode '11g'
option path 'platform/qca955x_wmac'
option htmode 'HT40-' #for channel 6,11 only
option country 'US'
option txpower '23'
option noscan '1'
option distance '20'
option disabled '0'
option diversity '1'
option require_mode 'ng'
option log_level '1'
option beacon_int '300'
option wpa_group_rekey '600'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'RX-STBC1'
list ht_capab 'TX-STBC'
list ht_capab 'DSSS_CCK-40'
list ht_capab 'LDPC'
list ht_capab 'MAX-AMSDU-7935'
option ldpc '1'
option short_gi_20 '1'
option short_gi_40 '1'
#option tx_stbc '1'
#option rx_stbc '1'
option max_amsdu '1'
option dsss_cck_40 '1'
option legacy_rates '0'
# for madwifi only
#option bursting '1'
#option ff '1'
#option compression '1'
#option uapsd '0'


config wifi-iface
option device 'radio0'
option mode 'ap'
option bgscan '0'
option wds '0'
option ssid 'a81m-guest'
option network 'vlan12'
option disabled '0'
option isolate '1'
option encryption 'psk2+ccmp'
option key 'XXXXXXXXXXX'
option disassoc_low_ack '0'
option wmm '0'
option hidden '0'
option powersave '1'
option short_preamble '0'
#option doth '1' # doth for A mode DFS and TPC only. it's irrelevant for .11n

could somebody explain why and who is iniating deauthention process? is "deauthenticated due to local deauth request" mean opwnwrt access point begins deauth process?

Thank you.

openwrt version:

root@ap:/home/sam# cat /etc/openwrt_release
DISTRIB_ID='OpenWrt'
DISTRIB_RELEASE='18.06.1'
DISTRIB_REVISION='r7258-5eb055306f'
DISTRIB_TARGET='ar71xx/generic'
DISTRIB_ARCH='mips_24kc'
DISTRIB_DESCRIPTION='OpenWrt 18.06.1 r7258-5eb055306f'
DISTRIB_TAINTS=''
root@ap:/home/sam#