Wireless associated to WAN - device not acquiring IP

following upgrade from 19xx to stable 21xx.
tp-link archer c7 v2
2 wireless bgn
1 is with LAN interface and the other with WAN
wireless clients connecing to the wireless associated to the WAN are not acquiring IP address.

was working fine previously with 19xx firmware.

can someone help please.
thank you.

''''cat wireless 

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'pci0000:00/0000:00:00.0'
	option channel '36'
	option band '5g'
	option htmode 'VHT80'
	option disabled '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/ahb/18100000.wmac'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option cell_density '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'LANassociation'
	option hidden '1'
	option encryption 'sae-mixed'
	option key '---------------'
	option wpa_disable_eapol_key_retries '1'

config wifi-iface 'wifinet1'
	option device 'radio1'
	option mode 'ap'
	option ssid 'WANassociation'
	option encryption 'sae-mixed'
	option hidden '1'
	option isolate '1'
	option key '--------------------'
	option wpa_disable_eapol_key_retries '1'
	option network 'wan''''''''

were settings reset during upgrade ?

yes factory default setting

any idea how to reconfigure this up?

or best i retrograde the firmware?

config wifi-iface 'default_radio1'
	option device 'radio1'
....
config wifi-iface 'wifinet1'
	option device 'radio1'

seems both LAN and WAN are both using the same radio ?
should the uplink really be option mode 'ap'?
there's no option network in the section for the WAN uplink.

did you just C&P these settings from somewhere?
it can easily configured via the webUI, no need for doing (and failing) it manually ...

configured from webui, do you want a screen shot?
above details was copied from the resulting config file in /etc/config/wireless

option network 'wan'

dhcp server activated on wan-if?
fw configured to accept dhcp requests from wan?

yes, please

mine look like this when I do a wifi scan -> join

config wifi-iface 'wifinet0'
        option device 'radio1'
        option mode 'sta'
        option network 'wwan'
        option ssid 'wonttell'
        option encryption 'psk2'
        option key 'willhelmtell'

it's set up as the network the clients are supposed to connect to, but you've attached it to the wan zone.

how should it be?

that one should probably be lan, not wan.

and the wan then?

this is how it were before

do you have the tplink archer c7?

no, would it make any difference ?

I dont know, may be its a bug.

Wifi enable as access point sharing same interface as WAN, a transparent point of access to the previous router before this one.

25 meters. but its not a cable issue as was working fine before upgrade

still not clear to me what you want to achieve, but this might be a better solution for you

1 Like

thank you, but the archer c7 is not only beng used as access point but as router, wireless access to the c7 itself and also as bridge to the previous router in the line. still working good with another tplink 4300 with old 19xx firmware.

if no solution i will have to revert the firmware.
thank you for your help