Wireless access point from x86 device not showing on available networks

I installed the latest OpenWRT on an old x86 notebook. I needed to install some packages to get "Wireless" to show up under "Network" in the web ui: libnl libnl-tiny kmod-cfg80211 kmod-lib80211 kmod-mac80211 kmod-mac80211-hwsim kmod-iwlwifi hostapd

I followed this guide to set up a Tor client, no errors, and all seemed to go well in the "Wireless Overview":

But when I look for available networks on any of my devices, I do not see the access point.

I've read this multiple times - and the only thing I could say is this:

  1. First make sure WiFi works
  2. Then configure Tor

A lot of what you discussed regarding WiFI seems completely unrelated to Tor.

  • Can you provide your WiFi and network configurations?
  • What WiFi chip?
  • Did you install those relevant packages?
  • Is this WiFi chip capable of being an Access Point?
3 Likes
root@OpenWrt:~# cat /etc/config/network 

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'xxxx:xxxx:xxxx::/xx'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option gateway 'xxx.xxx.x.xxx'
	list dns '1.1.1.1'

config interface 'transtor'
	option proto 'static'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'
root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option phy 'phy0'
	option htmode 'HT20'
	list ht_capab 'SHORT-GI-40'
	list ht_capab 'DSSS_CCK-40'
	option cell_density '0'
	option hwmode '11g'
	option channel '11'
	option country 'GB'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'virtual/mac80211_hwsim/hwsim1'
	option channel '36'
	option band '5g'
	option htmode 'HE80'
	option cell_density '0'

config wifi-iface 'wifinet0'
	option device 'radio0'
	option mode 'ap'
	option encryption 'psk2'
	option key 'xxxxxxxxx'
	option macaddr '00:88:88:88:00:2A'
	option network 'transtor'
	option ssid 'Transparent Tor'

10:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)

Yes.

There should be no need to hide this IP, it has to be in the 192.168.1.x range to be valid anyways.

You missed a question.

Provide the output of:

iw list | grep 'valid interface combinations' -A 3

Perhaps you should just use default configs.

192.168.1.254 (IP of main router as gateway)

Maybe not...

root@OpenWrt:~# iw list | grep 'valid interface combinations' -A 3
	valid interface combinations:
		* #{ IBSS } <= 1, #{ managed, AP, mesh point, P2P-client, P2P-GO } <= 2048, #{ P2P-device } <= 1,
		  total <= 2050, #channels <= 1, radar detect widths: { 20 MHz (no HT), 20 MHz, 40 MHz, 80 MHz, 160 MHz, 5 MHz, 10 MHz }

--
	valid interface combinations:
		* #{ IBSS } <= 1, #{ managed, AP, mesh point, P2P-client, P2P-GO } <= 2048, #{ P2P-device } <= 1,
		  total <= 2050, #channels <= 1, radar detect widths: { 20 MHz (no HT), 20 MHz, 40 MHz, 80 MHz, 160 MHz, 5 MHz, 10 MHz }

It should.

:spiral_notepad: I don't think this is correct. Where did the phy0 come from?

Maybe this should be...?

option path 'virtual/mac80211_hwsim/hwsim0'

Where did you get the path information - is it default?

Remove these .

Yep - I have not touched that at all.

I'll change the values...

Then leave them as is, just remove:

these. Let us know if this works.

Unfortunately not.

5 GHz is not supported on any Intel wireless card in AP mode.

2 Likes

Remove kmod-mac80211-hwsim. That is an extra radio that is only simulated, it doesn't do anything useful. Remove the /etc/config/wireless file then reboot. This should generate a new /etc/config/wireless with default settings. If it does not you're still missing a driver. If you do get an /etc/config/wireless, edit it making no changes other than add your country code and remove the disabled line. That should start up an unencrypted AP on LAN. If that does not work the chip probably doesn't really support AP mode (only a few Intel chips do). Examine the system log for errors starting wireless.

3 Likes

I'll have to look for another driver, as there is no wireless config.

Edit: kmod-iwl3945 is the driver. I reflashed (reset not on web ui, and firstboot doesn't work) the firmware to start from scratch (no Tor - just defaults).

So now I have a wireless config, then added my country code, etc. But on the "Wireless Overview" on the web ui, the AP shows Wireless is not associated

And the system logs show this:

daemon.notice netifd: radio0 (2639): Command failed: Request timed out
daemon.notice netifd: radio0 (2639): Command failed: Not found
daemon.notice netifd: radio0 (2639): Device setup failed: HOSTAPD_START_FAILED
daemon.notice netifd: Wireless device 'radio0' set retry=0
daemon.crit netifd: Wireless device 'radio0' setup failed, retry=0
daemon.notice netifd: Wireless device 'radio0' is now down