WireGuard VPN with WireGuard router server

Hello again. Here now i want to set the WireGuard server with WireGuard vpn, So the vpn i used is protonvpn, It's just working fine now with routing on different SSID, but i also want to set the WireGuard server on the Router. i tried to enable it here is my config, And yes WireGuard Server not working, And no handshakes.
WireGuard Status

interface: wireguard_home
  public key: 3+=
  private key: (hidden)
  listening port: 56641

peer: +=
  preshared key: (hidden)
  allowed ips: 10.0.13.2/32

interface: wireguard_usa
  public key: =
  private key: (hidden)
  listening port: 52493

peer: /=
  endpoint: 89.187.185.161:51820
  allowed ips: 0.0.0.0/0
  latest handshake: 48 seconds ago
  transfer: 78.19 MiB received, 93.57 MiB sent

NETWORK

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdfa:ea41:f7cd::/48'

config interface 'wan'
	option device 'eth0.1'
	option proto 'dhcp'

config interface 'wan6'
	option device 'eth0.1'
	option proto 'dhcpv6'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.2'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '2 4 6t'

config interface 'wf_wireguard'
	option proto 'static'
	option ipaddr '10.0.3.1'
	option netmask '255.255.255.0'

config interface 'wireguard_usa'
	option proto 'wireguard'
	option private_key '++='
	list addresses '10.2.0.2/24'
	list dns '10.2.0.1'

config wireguard_wireguard_usa
	option description 'ProtonVPN WIreGuard US-FREE#413002'
	option public_key '/=/='
	list allowed_ips '0.0.0.0/0'
	option endpoint_host '89.187.185.161'
	option endpoint_port '51820'

config route
	option interface 'wireguard_usa'
	option target '0.0.0.0/0'
	option table '102'
	option source '10.2.0.2/24'

config route
	option interface 'wireguard_usa'
	option target '0.0.0.0/0'
	option table '102'
	option source '10.2.0.1'

config rule
	option in 'wf_wireguard'
	option lookup '102'

config interface 'wf_home'
	option proto 'static'
	option ipaddr '10.0.5.1'
	option netmask '255.255.255.0'

config interface 'wf_free'
	option proto 'static'
	option ipaddr '10.0.7.1'
	option netmask '255.255.255.0'

config interface 'wf_main'
	option proto 'static'
	option ipaddr '10.0.9.1'
	option netmask '255.255.255.0'

config interface 'wireguard_home'
	option proto 'wireguard'
	option private_key '='
	list addresses '10.0.13.1/24'

config wireguard_wireguard_home
	option description 'OpenWRT WireGuard Home Server'
	option public_key '+='
	option private_key '+/='
	option preshared_key '+='
	list allowed_ips '10.0.13.2/24'

FireWall

config defaults
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option synflood_protect '1'
	option drop_invalid '1'
	option flow_offloading '1'
	option flow_offloading_hw '1'

config zone
	option name 'lan'
	list network 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'

config zone
	option name 'wan'
	list network 'wan'
	list network 'wan6'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config zone
	option name 'wf_wg'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	list network 'wf_wireguard'

config zone
	option name 'wg_usa'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	list network 'wireguard_usa'
	option masq '1'
	option mtu_fix '1'

config rule
	option name 'WF_WireGuard DNS'
	option src 'wf_wg'
	option dest_port '53'
	option target 'ACCEPT'

config rule
	option name 'WF_WireGuard DHCP'
	list proto 'udp'
	option src 'wf_wg'
	option dest_port '67'
	option target 'ACCEPT'

config forwarding
	option src 'wf_wg'
	option dest 'wg_usa'

config zone
	option name 'wf_home'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	list network 'wf_home'

config forwarding
	option src 'wf_home'
	option dest 'wan'

config rule
	option name 'WF_Home DNS'
	option src 'wf_home'
	option dest_port '53'
	option target 'ACCEPT'

config rule
	option name 'WF_Home DHCP'
	list proto 'udp'
	option src 'wf_home'
	option dest_port '67'
	option target 'ACCEPT'

config zone
	option name 'wf_free'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	list network 'wf_free'

config forwarding
	option src 'wf_free'
	option dest 'wan'

config rule
	option name 'WF_Free DNS'
	option src 'wf_free'
	option dest_port '53'
	option target 'ACCEPT'

config rule
	option name 'WF_Free DHCP'
	list proto 'udp'
	option src 'wf_free'
	option dest_port '67'
	option target 'ACCEPT'

config zone
	option name 'wf_main'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	list network 'wf_main'

config forwarding
	option src 'wf_main'
	option dest 'wan'

config rule
	option name 'WF_Main DNS'
	option src 'wf_main'
	option dest_port '53'
	option target 'ACCEPT'

config rule
	option name 'WF_Main DHCP'
	list proto 'udp'
	option src 'wf_main'
	option dest_port '67'
	option target 'ACCEPT'

config zone
	option name 'wg_home'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	list network 'wireguard_home'

config forwarding
	option src 'wg_home'
	option dest 'wan'

DHCP

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option cachesize '1000'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'
	option filter_aaaa '0'
	option filter_a '0'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	option ra_slaac '1'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

config dhcp 'wf_wireguard'
	option interface 'wf_wireguard'
	option start '100'
	option limit '150'
	option leasetime '12h'

config dhcp 'wf_home'
	option interface 'wf_home'
	option start '100'
	option limit '150'
	option leasetime '12h'
	list dhcp_option '6,1.1.1.3,1.0.0.3'
	option force '1'

config dhcp 'wf_free'
	option interface 'wf_free'
	option start '100'
	option limit '150'
	option leasetime '12h'
	list dhcp_option '6,9.9.9.11,149.112.112.11'
	option force '1'

config dhcp 'wf_main'
	option interface 'wf_main'
	option start '100'
	option limit '150'
	option leasetime '12h'
	list dhcp_option '6,45.90.28.229,45.90.30.229'
	option force '1'

config dhcp 'wireguard_home'
	option interface 'wireguard_home'
	option ignore '1'