Wireguard VPN with PBR leaking DNS

I am using WireGuard VPN with PBR (Policy-Based Routing), but there is DNS leakage. Please help me understand what is happening.

When I connect to ports 4 (VPN), they return DNS results that do not correspond to the DNS of that country.

I have turn off Use DNS servers advertised by peer on WAN interface and add: list dhcp_option '6,9.9.9.9' to port 4 dhcp

root@ImmortalWrt:~# uci export network
package network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd8c:0fd2:3239::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.100.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'
        option peerdns '0'
        list dns '1.1.1.1'

config device
        option name 'lan4'

config interface 'lan4'
        option proto 'static'
        option device 'lan4'
        option ipaddr '192.168.101.1'
        option netmask '255.255.255.0'

config interface 'wg'
        option proto 'wireguard'
        option force_link '1'
        option private_key '.......'
        list addresses '10.67.203.69/32'

config wireguard_wg
        option public_key '......'
        option endpoint_host '146.70.199.194'
        option endpoint_port '3306'
        option persistent_keepalive '25'
        list allowed_ips '0.0.0.0/0'

And does port 4 get 9.9.9.9 as DNS server?

If not please show the whole picture, connect to your OpenWRT device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:

Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/dhcp
cat /etc/config/firewall
ip ro
ip route show table all
ip ru
wg show
cat /etc/config/pbr
/etc/init.d/pbr status