Wireguard server on relayd

I want to access my home network from anywhere using wireguard.
I am able to connect to Wireguard server on client but I am not able to ping any device except for server(dump client).

My setup:
Main router --(Wifi)--->client (relay d)---->other lan devices

First of all a dumb ap and relayd are mutually exclusive as the first is connected by wire (ethernet) and the second a wireless bridge.

As you do not provide any configuration I can, unfortunately, only describe a general solution.
You need to set a static route on the main router for the wg servers subnet pointing to the lan ip address of your secondary router.

Yea, I misused term its not an ap its just adapts wifi to ethernet. I don't know what exactly to give but here are some files
/etc/config/network

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd04:df55:979f::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'wan'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '10.0.0.2'
        option netmask '255.0.0.0'
        option ip6assign '60'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

config interface 'wwan'
        option proto 'static'
        option ipaddr '10.0.0.2'
        option netmask '255.0.0.0'
        option gateway '10.0.0.1'
        option device 'phy1-sta0'
        list dns '1.1.1.1'
        list dns '8.8.8.8'

config interface 'Repeater'
        option proto 'relay'
        option ipaddr '10.0.0.2'
        list network 'lan'
        list network 'wwan'

config interface 'Wireguard_VPN'
        option proto 'wireguard'
        option private_key <removed>
        option listen_port '61247'
        list addresses '10.0.0.2/8'

config wireguard_Wireguard_VPN
        option description 'Phone'
        option public_key <removed>
        option private_key <removed>
        option preshared_key <removed>
        option route_allowed_ips '1'
        list allowed_ips '192.168.0.100/8'

wg show

root@OpenWrt:~# wg show
interface: Wireguard_VPN
  public key: <removed>
  private key: (hidden)
  listening port: 61247

peer: <removed>
  preshared key: (hidden)
  endpoint: <removed>:49407
  allowed ips: 192.0.0.0/8
  latest handshake: 6 seconds ago
  transfer: 57.18 KiB received, 3.52 KiB sent

firewall on the main router

root@OpenWrt:~# cat /etc/config/firewall

config defaults
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option flow_offloading '1'
        option synflood_protect '1'
        option flow_offloading_hw '1'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'
        list network 'Home_VPN'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'beammp'
        option src 'wan'
        option src_dport '30815'
        option dest_ip '10.0.2.3'
        option dest_port '30815'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'jaunmerdzene'
        option src 'wan'
        option src_dport '25566'
        option dest_ip '10.0.2.3'
        option dest_port '25566'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'amd-ssh'
        option src 'wan'
        option src_dport '15022'
        option dest_ip '10.0.2.3'
        option dest_port '22'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'debian-ssh'
        option src 'wan'
        option src_dport '13022'
        option dest_ip '10.0.2.1'
        option dest_port '22'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'sunshine'
        list proto 'tcp'
        option src 'wan'
        option src_dport '47984'
        option dest_ip '10.0.1.1'
        option dest_port '47984'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'sunshine'
        list proto 'tcp'
        option src 'wan'
        option src_dport '47989'
        option dest_ip '10.0.1.1'
        option dest_port '47989'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'sunshine'
        list proto 'tcp'
        option src 'wan'
        option src_dport '48010'
        option dest_ip '10.0.1.1'
        option dest_port '48010'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'sunshine'
        list proto 'udp'
        option src 'wan'
        option src_dport '47998-48000'
        option dest_ip '10.0.1.1'
        option dest_port '47998-48000'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'Wireguard-ASUS'
        option src 'wan'
        option dest_ip '10.0.0.2'
        list proto 'tcp'
        list proto 'udp'
        option src_dport '61247'
        option dest_port '61247'

I cannot comment on the use of relayd, I never use it, it is an ugly hack, if I cannot pull a cable, I use wds or mesh, or I use powerline adapters, anything better than relayd.

But apart from that why are you using a ridiculously large subnet of /8 ?
Consider just using a /24 subnet.

Apart from my earlier mentioned static route.

I would recommend to start over regarding wireguard both network and firewall are flawed.
Remove everything and use the wireguard road warrior setup.
To be sure: Wireguard is a routed solution which need three different subnets , server side, client side and wireguard need to be on a different subnet
(hence my remark about the /8 subnet).

See:
https://openwrt.org/docs/guide-user/services/vpn/wireguard/road-warrior

I don't know how to use wds but relayd works for me. Maybe If I setup using wds, it would work?

What do you mean by flawed firewall?
Large subnet I am using just to sort devices more conveniently.