Wireguard server config for Bridged AP - only connection to AP works

I set up a wireguard server on my ap router, for ap i set it up exactly as here https://openwrt.org/docs/guide-user/network/wifi/wifiextenders/bridgedap
Wireguard kinda works, i can connect to 192.168.1.2 no problem, but if i want to tunnel all the traffic through the connection, peers dont have internet access, and theres no connection to 192.168.1.1

my configs:

config rule
	option name 'Allow-WireGuard'
	option src 'wan'
	option proto 'udp'
	option dest_port '55055'
	option target 'ACCEPT'

config zone
	option name 'vpn'
	option network 'wg0'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	option masq '1'

config forwarding
	option src 'lan'
	option dest 'vpn'

config forwarding
	option src 'vpn'
	option dest 'wan'

config forwarding
	option src 'vpn'
	option dest 'lan'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.2'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option gateway '192.168.1.1'
	list dns '192.168.1.1'

config interface 'wg0'
	option proto 'wireguard'
	option private_key 'xx'
	option listen_port '55055'
	list addresses '10.10.0.1/24'

config wireguard_wg0
	option public_key 'xx'
	option private_key 'xx'
	option preshared_key 'xx'
	list allowed_ips '10.10.0.2/32'
	option route_allowed_ips '1'
	option persistent_keepalive '25'

I dont know what else to do with this, ive tried alot of different options and nothing works.

I currently have that running, I took some note how I have set it up maybe they are helpful:

You need the WireGuard Server setup guide, better download it as github only shows the first 5 pages.
There is a paragraph about running a server on a BridgedAP :slight_smile:

2 Likes

Thank you very much, i've wasted so much time trying to figure it out, and it was so simple, should've asked sooner...

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.