WireGuard over IPv6

Your problem might be you only have (limited) IPv4 Internet

Your server address is outside the address range of the ULA clients address theoretically possible but not advisable
Just use fd00:1234:5678::1/64
Add IPv4 address: 192.168.100.1/24, assuming your client has 192.168.100.2/24 (technically not necessary but to keep things tidy)

Now if you want to have IPv6 internet access you have to masquerade the ULA subnet of WG out of the wan6
You can enable NAT 6 on the Advanced page of WAN6 but better is selective NAT, add in /etc/config/firewall

config nat 'nat6'
	option family 'ipv6'
	option proto 'all'
	option src 'wan'
	option src_ip 'fd00:1234:5678::0/64'
	option target 'MASQUERADE'

Next thing is that you should provide a default IPv6 route, for that disable Source routing:

uci set network.wan6.sourcefilter="0"
uci commit network
service network restart

or add in /etc/config/network under config interface 'wan6':
option sourcefilter '0'

Lets review the final result.
Reboot first and connect to your OpenWRT device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:

Remember to redact keys, passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/firewall
ip route show
ip -6 route show
wg show