Wireguard not recieving packets and traffic routing to wan

Hi,

I have been setting up wireguard in my router over a PPoE wan connection. Configured the wireguard.

Installed the wireguard and added a new interface and firewall. The handshake is not happening and wireguard not receiving any packets.

My expectation:

Firewalls:

Interfaces:

Output of /etc/config/network:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd67:6902:6a24::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.0.1'

config device
        option name 'eth0.2'
        option macaddr 'e4:fa:c4:71:e9:98'

config interface 'wan'
        option device 'eth0.2'
        option proto 'pppoe'
        option username '<hidden>'
        option password '<hidden>'
        option ipv6 'auto'

config interface 'wan6'
        option device 'eth0.2'
        option proto 'pppoe'
        option username '<hidden>'
        option password '<hidden>'
        option ipv6 'auto'
        option mtu '1480'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0 6t'

config interface 'wg0'
        option proto 'wireguard'
        option private_key '<hidden>'
        list addresses '10.134.68.7/24'
        list addresses 'fd11:5ee:bad:c0de::7/64'
        list dns '1.1.1.1'
        list dns '1.0.0.1'

Please let me know if anything more details needed.

You don't appear to have a peer configured, just the main interface...

unless not all of the config was copied into place??

Also, let's see:

ubus call system board
cat /etc/config/firewall

And your remote peer's config, too.

1 Like

Its worked. Thanks a lot. I have added the peer config manually to /etc/config/network , and packets started receiving.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.