Wireguard no handshake


I have configured Mullvad Wireguard VPN on my Linksys WRT1900ACS router. I got it working for a while, and then I turned it off for a few days while its use was not needed. Upon turning the router back on, the WIreguard connection will not complete any handshakes. I tried using the race conditions comnand found here. I used this command previously to get the Wireguard up and running. I also checked Mullvad's site, and the server I am using is still listed as online.

I am pretty new to OpenWRT so if I need to run any commands to help you all diagnose anything, please let me know. Any help to get my VPN back up and running would be much appreciated. Thank you.

  • Did you pay for service?
  • Can you show the exact commands?

(It's been a while since I used them, but that sounds similar to other's expriences and I assume your IPs are not the same as on the Wiki.)

Yes, Mullvad is paid for.

Here at the commands.

# Resolve race conditions
cat << "EOF" >> /etc/crontabs/root
* * * * * date -s 2030-01-01; /etc/init.d/sysntpd restart
uci set system.@system[0].cronloglevel="9"
uci commit system
/etc/init.d/cron restart

Is anyone able to help?

The purpose of that race conditions method is to set the time to something that is not in the past... WG (and other VPNs) will often fail if the clock is significantly behind (and since most routers do not have a true RTC, time is only good if it can sync with an NTP server).

So, with that in mind, try disabling the WG interface and ensure that the router itself has proper internet connectivity. Verify that the router is able to set the time via NTP, and then try to start the WG interface. If the time is correct and the WG interface won't start, it is likely not related to the time.


Are you sure the keys have not simply expired due to inactivity? (I have this issue with Keepsolid VPN when I turn off my router when previously tested)

No, my VPN susbcription was purchased for 1 year only a few weeks ago.

I was referring to the possibility the wireguard keys have expired, not your subscirption. Have you tried generating new wireguard keys?

1 Like