Wireguard Kernel not compatible (19.07.1, ar71xx )

So, trying to install wireguard on a wndr3700v2 and no matter if I use this build, a snapshot or you know, the latest stable one..

I get: The installed version of package *kernel* is not compatible, require 4.14.169-1-b84a5a29… while 4.14.169-1-e510eb36… is installed. (this is the output from the latest stable)

Any advice?

How are you trying to install it? By opkg install from repository? Or you ar trying to install from ipk?

From luci.

Strange, however, that that error is due to the incompatibility between kernel and module, because wireguard eventually plugs into the kernel. Normally on stable versions the package repository is updated and therefore the versions are always corresponding. Also try from the command line, just for scruple, after an opkg update. Otherwise you can always compile a build with included wireguard. In this last case you will have no problems.

Thanks for the fast reply.
Hmm.. myeah.. I also thought every package in the repository was a-ok.

I'll give it a whirl tomorrow.

Backstory time: Only reason to be honest 'why', is I can't get windows wireguard client to access my local lan (router), which feels.. disconnect to get to the router. Feels wrong to disable killswitch, when one at least aught to just add "" and that should be it. But oh no..

So I'll wireguard the lot.

Have you installed or upgraded any other packages since the original installation of 19.07.1?

I have WG installed on my ar71xx based TL-WR902AC running 19.07.1 and it works perfectly. I also have it running without issue on my ath79 (previously ar71xx) RouterStation Pro on 19.07.1.

Nope. It's a fresh one, other than I used "keep settings".

Maybe try the official stable release build that you can find in the main downloads page

EDIT: And, when you flash, do not keep settings.

1 Like


I used that one, a snapshot and the linked build as stated in OP.

Yes. You wrote it. Try to do a clean flash and if it doesn't go fill in yourself. However after a clean flash it should work.

Try it again. Do not keep settings when you flash. Don't update anything else, just run the following:

opkg update
opkg install wireguard

It's actually better if he updates. If maybe the kernel in the repository was updated and he didn't update it, he would still have that error.

opkg upgrade
opkg list-upgradable (for looking at upgradable package)
opkg list-upgradable | cut -f 1 -d ' ' | xargs opkg upgrade (for upgrading all upgradable installed packages)
opkg install wireguard

What are you proposing be updated? And how?

Will check in here in 10h and follow your advice, 'till then. Toodles.


using opkg upgrade will cause problems, almost guaranteed.

1 Like

So you never update?

Only upgrade by means of installing a new complete firmware image (i.e. 19.07.0 > 19.07.1) using the sysupgrade functionality.

The images (and packages from that build cycle) are all self-consistent in terms of kernel versions and dependencies. Performing an opkg upgrade operation will likely break things -- there are no advanced compatibility checks in the package manager to ensure that everything will continue to work.

See this link and search the forums for the number of times that people have broken their installations by using the opkg upgrade command. It is never advisable to upgrade this way, but if you absolutely must have some specific bug fix or new feature or something, be sure to do this very carefully, selectively, and with the complete knowledge that you may soft-brick your router in the process (most of the time it is recoverable by booting failsafe mode and then performing firstboot to reset everything to defaults).

1 Like

@mittkonto - Since you said you would check back to see the recommendation, I would strongly suggest that you follow my recommended procedure below. If things still don't work, there is a proper baseline from which we can troubleshoot. Doing anything else may make it extremely difficult to figure out what has gone wrong.


  1. Download and install a fresh copy of 19.07.1 for your device
  2. Flash without keeping settings (it will prompt you if you use LuCI to install, or if you use an ssh session, the syntax would be sysupgrade -n <path-to-file> (you can make a backup of your previous configuration, but I would recommend against restoring it; instead, use it as a reference if necessary)
  3. Perform only the basic configuration that is required (such as your wifi SSID/password, system password, LAN IP address change if necessary, and WAN configuration/credentials if required).


  1. In an ssh session, run opkg update; opkg install wireguard (optionally you might install luci-app-wireguard, too); or if you prefer to use LuCI to do the installation, log in, navigate to System > Software, click the update lists button, then filter for wireguard and click the install button next to wireguard). The system will automatically handle the installation of all dependencies.
  2. report back with your status (success, hopefully; if any problems arise, complete output of the error messages).

EDIT: I just had a successful installation of WG on a fresh 19.07.1 (official stable release) flash on my WR902AC which is also in the ar71xx target family. I did this just now to verify that there are no issues with the kernel compatibility for the stable release and the respective repository.

1 Like

The update in a tag (e.g. 19.07.1) via opkg takes place in the repository of the same tag, i.e. opkg only shows you the packages that you can update safely, not packages from other branches or who knows what other infamous place. On master, perhaps it is not convenient to use opkg, but it is relative there too. Finally, opkg does not update you from OpenWrt 18 to 19, only updates the components of the same version. I have been using opkg for two years and have never had a problem. Instead of reading the forum, take a look at the official project pages. Having said that, I am no longer speaking.

It just compares the package version numbers, but make no evaluation of compatibility.