Wireguard freezes after a short time

I might have given you a slightly wrong command:

sysupgrade -F -n /tmp/<filename_of_firmware_image>

The difference is a capital F rather than lowercase.
Try that and report back with the result.

My ar750s device is officially BRICKED.
HELP ME

Did you wait for it to reboot -- sometimes it can take a while. Check to make sure you get an IP address on your computer when connected to the LAN port.

If it appears to be bricked, follow the directions on the gl-inet website.
https://docs.gl-inet.com/en/3/troubleshooting/debrick/

Ok I have reset everything. During the recovery procedure I tried to do the SYSUPGRADE but to no avail. I don't understand why OPENWRT gives the upgrade as compatible: "openwrt-19.07.3-ar71xx-generic-gl-ar750s-squashfs-sysupgrade" but then it makes the router go brick.

During the firmware recovery procedure I first loaded the SYSUPGRADE to no avail, then I repeated the procedure they load the official relase of GL.inet and the router has started to work.

GL.inet Firmware Restore

Glad you managed to recover the device. I don't know why the sysupgrade image isn't working, but it looks like the device info page I linked earlier may have some information about how to get it flashed with official OpenWrt using a generic image. If you want to flash to official OpenWrt and you have trouble even after reading through the information on the device info page, open a new thread specifically to address upgrade issues.

If you decide to stick with the stock firmware, you should direct your further operational questions to gl-inet (hopefully they have some support or user forums), since it is a customized version and may not behave quite the same way as the official release versions.

No no, I want to delete this proprietary firmware because it is worth nothing. I would not have made a mistake, when I loaded the SYSUPGRADE I gave 192.168.1.1 and then 192.168.8.1. Did I do well to access the LUCI interface?

I have no experience with your device, so I cannot guide you through the upgrade from stock firmware to official OpenWrt.

I can tell you that wifi is disabled by default on the official OpenWrt builds -- you must connect by ethernet to a LAN port. If everything is working properly, your computer will get a DHCP supplied IP address in the 192.168.1.0/24 network, and the router itself will be at 192.168.1.1. SSH should always be available with default login as root with no password. If you have installed an official stable release build, LuCI is included and you can reach the web interface using a web browser.

As I said before, if you want help getting the router running OpenWrt official, you should open a new thread specifically for that purpose. This is off-topic for the thread title, you will be more likely to get help if you have a title like "Help flashing OpenWrt from stock gl-inet ar750s firmware" or similar.

I confirm that I have tried the flashing again and the result is always the same. "BRICK". There is no way to perform the SYSUPGRADE and to connect via ethernet to any network interface, evidently the guide present on the AR750S device by the OPENWRT TEAM is wrong or missing some details.

Have you looked at https://forum.gl-inet.com/t/installing-openwrt-on-gl-750s/5291/23 and followed what others have done?

1 Like

It is entirely possible that there are errors in the process and/or a bug in the creation of the firmware image itself (every time I used 19.07.x sysupgrade images on the TP-Link TL-WR902ACv1, it ended up bricked... this bug is presumably fixed now, but just brought this up to point out that these things can happen).

Regarding the device info page and your seeming accusation of the "OPENWRT TEAM" (forgive me if I am reading too much into this) -- please understand that these pages are added and maintained by individual volunteers. While every effort is made to ensure accuracy, the "team" may literally have just been one person who wrote up the information on that page. Because of the distributed nature of this volunteer effort, there are times when the information may not be proof-read or validated. This is very different than the support provided by a for-profit corporation regarding the products that they develop and release under their own brand name.

All of that said, I will repeat the advice I have given several times -- if you believe there is a bug with the OpenWrt firmware image and/or the device info page, open a new thread to discuss the device specific issue. Make sure that it has descriptive title that includes the model of your router, and include details in the initial post about your experience, installation process, and troubleshooting thus far. This will help ensure that people who have used the same device will see the thread and can comment or even help investigate the issue (I assure you that fewer users of that specific router will end up reading this specific thread than a thread dedicated to the device itself).

Of course, I do not make any accusations, I am enormously grateful to you who have been very kind and to the immense contribution of the opewrt team. I will immediately open a specific thread on flashing the AR750S EXT device. in the hope that the bug can be resolved soon.

1 Like

All peers have a listening port (it's simply the dynamic port that WG binds to in cases where a port is not defined)...but one device (the "server") needs a static port set and their firewall open.

Nothing to make friends, even uploading the NAND file "openwrt-ath79-nand-glinet_gl-ar750s-nor-nand-squashfs-factory.img" the AR750S router goes to BRICK. The WIFI LEDs after the flashig remain off and it is not possible to access the 192.168.8.1 interface.

What am I doing wrong I don't understand?

WiFi is disabled by default on openwrt (for security reasons). You must connect via Ethernet to the lan port.

The default IP address of the router after successfully flashing OpenWrt will be 192.168.1.1.

Which is really stupid IMO. :slight_smile:

Maybe in your opinion. And I'll admit that it can be a bit inconvenient for some people who don't have readily available ethernet connectivity on their devices.

But there is a good reason for this... security is a key reason to use OpenWrt. If wifi was enabled by default, the wifi network would also need to have a default (or no) password. And the same goes for the main OpenWrt installation (which is root with no password). This means that the router would be especially vulnerable when it has just been flashed if it was available via Wifi.

As it turns out, one of the biggest security threats to the average home user is the default username/password situation on many routers and wifi networks (and IoT devices) which many users never change. This has been documented extensively -- one such article here.

Requiring a wired connection means that it is very unlikely that any non-authorized users can connect to the OpenWrt device in the default state, which could compromise not only the router itself but also possibly other hosts on the network. While there is nothing to ensure that the administrator will set a reasonably secure password as they go through the process of enabling wifi, it does necessitate actively logging into the router to enable the radios which will hopefully make the user think about the security and passwords. At the very least, the network would not have been vulnerable just by the mere presence of OpenWrt in a default state.

For those that wish to have the radios enabled by default and/or configured with a custom SSID and password, it is relatively easy to build a custom image with the desired configuration included.

1 Like

Ok, mission accomplished!

I was talking about wifi led because the GL.inet official guide said that the 2G led of the completed flash device should have come on, I know very well that access to the interface must be done with lan cable.

The mistake I made through SSH was to query 192.168.8.1 instead of 192.168.1.1. This error did not allow me to verify the correct outcome of the flashing.

Ok finally the OPENWRT Firmware is installed, the version I used for the AR750S device is the following: http://downloads.openwrt.org/releases/19.07.3/targets/ar71xx/generic/openwrt-19.07.3-ar71xx -generic-gl-ar750s-squashfs-sysupgrade.bin