Wireguard freezes after a short time

Hi, friends, after having purchased for almost a month and made several attempts with settings and firmware, I still cannot get my AR750S's wireguard network to work well, once started after a few hours or minutes the traffic goes into congestion, so particular the block concerns the "ListenPort", when the network is blocked I have to manually update this port and at that point the wireguard network traffic returns to work.

" Powered by LuCI openwrt-18.06 branch (git-18.196.56128-9112198) / OpenWrt 18.06.1 r7258-5eb055306f "


I tried with LUCI to configure everything so that it can work, I reset the firmware several times, currently I use the relase openwrt-ar750s-3.104.tar

Can anyone tell me what trick I can follow to make my wireguard network work well?

Some quick points before I comment on the specific problem...

  1. It seems that you are not using a standard OpenWrt release (you are probably using a non-official OpenWrt derivative directly from gl-inet), so if the advice here doesn't work, please ask the questions on their forums, or consider upgrading to an official release build of OpenWrt.
  2. The version of OpenWrt is rather old. You should look for an update for your device. As of this writing, OpenWrt 18.06.8 is the latest for the v18.06.x series, and OpenWrt 19.07.3 is the latest available stable release (at least for the official releases). If gl-inet doesn't have updated images, this would be another reason to consider upgrading to the official releases.

Now, on to your problem...
normally, a ListenPort is only necessary for the inbound connections. So if this peer is acting as a client, you can just remove the ListenPort entirely. Try that and see if it helps.

Unfortunately, as the official GL.inet website shows, the version of LUCI that I have indicated is the latest available release, however I tried to remove the "listenport" item from the client, but this automatically reappears.

I don't understand why the parameters I read through SSH are in one way and then the Gl.inet interface shows them in another.

last relase

If you don't mind loosing the proprietary interface, it looks like this device is supported by the current version of standard OpenWRT

No, I have no problem to eliminate the proprietary interface (GL.inet) also because it works very badly, which stable OPENWRT relase can I download for my ar750s ext. Router?
Thanks

Look under the "installation" section on the device info page that @aboaboit linked. That provides a direct link to the firmware image (current supports is 19.07.3 which is the latest as of right now).

1 Like

I found these but I don't know which one to choose for my GL.inet ar750s:

https://downloads.openwrt.org/releases/19.07.3/targets/

the @aboaboit link is wrong I have the AR750S version while that is the AR750.

Although I took the official version of OPENWRT to upgrade my AR750S device, I get the following error:

https://openwrt.org/toh/gl.inet/gl-ar750s

Not to be snarky here, but it's actually really easy to find. You can look directly on the TOH, but in this case I literally just typed into google "AR750S OpenWrt"

1 Like

You may need to ssh into the device and then use sysupgrade command with -f (force) and -n (don't save settings).

  1. Make a backup of your configuration first.
  2. Then use scp to copy your firmware file to the router in the /tmp/ location.
  3. ssh into the device and issue the following command
sysupgrade -f -n /tmp/<filename_of_firmware_image>

I arrived before you to find him, read above ...

the upgrade does not work with the file that I have taken directly from the page dedicated to the ar750s device

did you try the command line sysupgrade process?

I downloaded the SYSUPGRADE file on the PC how can I transfer it to / tmp via SSH?

I'm already in the / tmp directory in SSH ...

On a Mac or Linux system:

scp <file> root@host:/tmp/

I use W7 x64, I don't understand what I'm wrong: scp C: \ Users \ ANONYMOUS \ Desktop \ openwrt-19.07.2-ar71xx-generic-gl-ar750s-squashfs-sysupgrade root @ GL-AR750S: / tmp /

Try using the IP address instead of the name of the device.

nothing to do, not even with command line SYSUPGRADE manages to go into execution.

Did you copy the file to your /tmp/ directory? The screenshot shows that you did an ls and the file doesn’t appear to be in the directory.
Sorry - didn’t see it on the right side. Stupid mobile screens :laughing: